LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Security (https://www.linuxquestions.org/questions/linux-security-4/)
-   -   firestarter problem with initscripts (https://www.linuxquestions.org/questions/linux-security-4/firestarter-problem-with-initscripts-242244/)

Adrian13 10-13-2004 02:39 PM

Firestarter Configuration Problem
 
Hello, i'm very new at this, i'm trying to install firestarter on suse 9.0 but it sends the following error "firestarter needs initscripts".. i have ignored this error (warning) but don't know if it will cause any problems
any help will be appreciated.....:confused:

anacOndazz 10-14-2004 07:24 PM

init scripts firestarter
 
Hi there,

The message you see referes probably at unmet dependencies. You should make a search through your packages, to see whether init package is installed.

Adrian13 10-14-2004 08:10 PM

hi thanks for the info, i checked out the packages, the only thing i found is the follwing
init(folder) in /etcwebmin,
init(folder) in /usr/share/doc/packages/sensors/prog,
init(folder) in /usr/libexec/webmin,
init(folder) in /usr/libexec/webmin/caldera
init(folder) in /usr/libexec/webmin/style3
init /sbin "bynary program"

i dont know if its one of the above???

iŽd appreciate more help.... thanks
:confused:

anacOndazz 10-15-2004 05:25 AM

initscripts
 
Hi Adrian,

i wasn't clear enough at previous, but for so far i understand , you miss the "initscripts" package ~ wich are used 4 booting&shutting down services. Now, you depends on the distro you are using ~ open your package manager (YAST ? ) 2 see whether this package has been installed . I didn't worked with SUse yet, but it should be possible to let your package manager take care of dependencies as well. Are you trying to install firestarter from a tarball or from a rpm package?

Adrian13 10-15-2004 11:00 AM

Hi anacondazz thanks for the reply
well, i have installed firestarter from an rpm, using webmin, but i have indicated the webmin package installer to ingnore dependencies...
but the problem i now have is that the firestarter wont stop....
i have all ready tryed looking for the initscripts on yast but i couln't find them......

what would you think it is? thanks.......:confused:

anacOndazz 10-16-2004 02:25 PM

firestarter
 
He Adrian,


Well, it sounds to be a classic problem ~ that is ignoring dependencies. It's a NOT do , unless you know what you're doing. If i were you , i would remove the package , and re-install it again, that's either by using your package manager ~ either by issuing the appropiate command in terminal. ( i don't work much with rpm , but is easy to have a look through the man page of rpm). This time , let the program check for dependencies, and if possible ( if ya using a GUI package manager ) , let him install the satellite packages as well. If you skip the dependencies, you either know very well what you are doing, or the package will not work properly.
By just doing a :#rpm --whatrequires firestarter in your command line , will reveal the missing package.
At that point you have pin-pointed the troublemaker. LIfe should become easier by now. Then go 2 the package archive @ Suse and perform install , in case you don't have it on disk.
Hope it helps.

anacOndazz 10-16-2004 02:37 PM

firestarter
 
U can stop firestarter by typing into your terminal : ps aux / or ps ax / , then look what PID firestarter has . Kill it with : kill -9 PID ( firestarter )

Adrian13 10-18-2004 12:40 PM

Thanks anacOndazz !
it was great help... it worked


All times are GMT -5. The time now is 06:38 AM.