-   Linux - Security (
-   -   file permissions on VFAT partition - access denied (

cevjr 09-04-2003 11:27 AM

file permissions on VFAT partition - access denied
WHen I log in as root I CAN SEE all of my files/dir in a fat partition.
WHen I login as a user and try to access those same directories, it gives me back the message asscess denied. However I checked the permissions and OTHER has r read permissions.

I tried changing the permissions to chmod o+rwx "My Documents" , just in case...but it doesn;t allow me to change the permissions.

One more a regular user I checked the properties for the directories I want access to and it says it is an unknown type.

WHats the deal??? Please help.


Mathieu 09-04-2003 12:51 PM

To change permissions on a non-Linux partition, you will have to edit /etc/fstab by adding the umask option to the FAT entry.
Here is an example of syntax:

/dev/hda1                /mnt/windows98            vfat    defaults,user,umask=022 0 0

cevjr 09-04-2003 04:50 PM

thanks, before I got your response I tried the following and it seemed to work:
/dev/hda6 /fatmydoc vfat uid=1033 1 0

where uid=1033 is the user id of my username. although this doesn't help if I need username2 to access this same partition.

can you tell me what the the umask feature would do....and am I completely wrong with the above statement. It works fine now but I would not want to have problems down the road.

Thanks again,
- C

jdblock 09-04-2003 05:50 PM

umask normally controls the default permissions on a newly created file. A umask of 022 will give you a -rw-r--r-- file, so that only you can modify the file while other can read it. A 002 will give you a -rw-rw-r-- file, this allows members of the same group to modify your file.

In this case it is controlling the default mask of the files in the file system. If you use the method above all users will be able to access the files in the vfat partition.


All times are GMT -5. The time now is 06:47 AM.