LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices


Reply
  Search this Thread
Old 04-26-2004, 10:58 PM   #1
Electronkz
Member
 
Registered: Mar 2004
Location: Punta del Este, Uruguay
Distribution: Fedora
Posts: 176

Rep: Reputation: 31
Question Failed Dependencies for Guarddog: Iptables


HI, I am Using Mandrake 9.2 and I have the following Dependencies Problems when i try to install GuardDog Firewall,
Code:
[root@localhost Recent-Downloads]# rpm -ivh guarddog-2.3.1-1mdk.i586.rpm
error: Failed dependencies:
        iptables is needed by guarddog-2.3.1-1mdk
        libXinerama.so.1 is needed by guarddog-2.3.1-1mdk
My Kernel Version is: Linux 2.4.22-10mdk
And iīm currently using Mandrake Security Level: High
And I have The same problem when i try to run an adsl-shaper script,
I donīt understand why i donīt have the iptables installed, I mean because, what kind of security i have then?
Well, I went to http://tldp.org/HOWTO/Querying-libip...O/install.html
And then I went http://www.iptables.org/downloads.html
And I donloaded This: iptables-1.2.9.tar.bz2
And then i went to this site:

http://www.linuxheadquarters.com/how...lsources.shtml
Then i did what they said i looked up in /usr/src/linux But This Directory/Symbolic-link doesnīt exist, But i did find a linux directory in /usr/include/linux I guess that this is where the linux kernel is installed, because You cant run linux OS without the Kernel, Linux=Linux Kernel, of this i am 100% sure.
Well After some of this sites, i decided to try to install iptables, with the instruction of the tldp.org,
But i changed the location in to /usr/include/linux on the step 5, And here i get my fisrt error:
Code:
[root@localhost iptables-1.2.9]# make pending-patches KERNEL_DIR=/usr/include/linux
Making dependencies: please wait...
make: *** No rule to make target `pending-patches'.  Stop.
What happened here??
Please Thanks for your help, I will be waiting for your response to continue on doing this,
Regards,
||||Electronkz||||

Last edited by Electronkz; 04-26-2004 at 11:00 PM.
 
Old 04-27-2004, 04:42 AM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 475Reputation: 475Reputation: 475Reputation: 475Reputation: 475
IPTables should be on your install cds to be installed via rpmdrake, or you can install it via urpmi. Both of these methods will resolve dependencies.

Last edited by XavierP; 04-27-2004 at 04:46 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
IPtables/Guarddog blocking to much. How do I fix this? M$ISBS Linux - Security 7 11-14-2005 10:42 PM
UT2004, Guarddog/iptables, and LAN games - ?? achallenger1 Linux - Games 3 09-19-2005 01:52 PM
Guarddog iptables and DHCP conflict (web-browsing impossible) nomind Linux - Networking 6 09-08-2005 07:18 PM
I recieve a failed dependencies error, but I have all required dependencies Laptop2250 Linux - Software 15 02-03-2004 08:58 PM
rsync through Guarddog/IPTables on Gentoo Chip D Linux - Security 3 01-05-2004 06:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Security

All times are GMT -5. The time now is 01:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration