-   Linux - Security (
-   -   Does not prompt for password (

ssharma_02 05-30-2005 04:55 AM

Does not prompt for password
I recently installed SuSE 9.2 on my machine, when i log on to it it does not prompt for the password and logs on to a non root login directly. How do i make it wait so that it may wait for the user to enter the account and the password

bramhastra 05-30-2005 05:05 AM

have u checked ur passwords and user file entry

ssharma_02 05-30-2005 05:18 AM

Yes, the problem of prompt only occurs when KDE starts up, as of console it always does the expected , even when i run commands like su or yast passwd is asked for

bramhastra 05-30-2005 05:27 AM

so this happens in GUI why dont u checkup /etc/securtty file
or try and reconfigure your bootloader

Izmo 05-30-2005 03:11 PM

I recently installed SuSe 9.2 on my parents' machine and during the install, during the account setup phase I noticed a checkbox that said (something like) "Log in automatically". It was checked by default, and I left it at that hoping that it would do the exact same thing you wished to avoid. (My parents don't need that kind of security.) If you've recently installed the OS, I suggest you try it again, and uncheck the box.

Hope this helps.

zackarya 05-30-2005 03:26 PM

Hi ssharma_02, what you need to do is :
Click the KDE start button(lower left),
at the bottom is a button that says Administrator Mode(click it if your not the admin(which you should not be))
Type in the root password and click the tab up top that says Convenience.
Uncheck the box that says autologin.
That should be it. Hope that helps.


ssharma_02 06-02-2005 01:51 AM

Thank You your suggestion worked out and i am happy to inform that the system now prompts for the passwd.
also while i was looking into control center i saw options to manage the start up screen , fonts , images etc.. any idea if how this configuration can be managed from console ie nt via control center.
I wish to know which files need to be changed rather which files hold the conf. information for kde start up etc.

All times are GMT -5. The time now is 06:37 AM.