-   Linux - Security (
-   -   Disable the firewall on Debian Linux 2.6.32-5-686 (

fmr 10-16-2011 07:19 AM

Disable the firewall on Debian Linux 2.6.32-5-686
Hi, I need to disable my firewall on Debian. I do not know what is preventing inbound connections to my machine, as I have another Debian machine (also 2.6.* but 64-bit) which accepts inbound connections, and I have already flushed all my ipTables. I used the script @

Anything else that might be blocking ports?

EricTRA 10-17-2011 12:19 AM


What kind of 'inbound connections' are you talking about? If you flushed your iptables then you should be able to connect to your machine if you didn't install something else like for example firestarter. Could it be that you are trying to connect to something that's not listening, a service that didn't start up or so?

Kind regards,


Lexus45 10-17-2011 06:40 AM

Seems strange if a fresh-installed Debian system has some iptables rules activated and stored somewhere.
What shows the "iptables -L -n" command?

hen770 10-17-2011 08:15 AM

couldn't it be the inet or xinet server ?

fmr 10-18-2011 07:02 AM

Thank's for the replies!

Firestarter is not installed, and AFAIK, no other firewall software is installed except iptables.

# iptables -L -n says:

Chain INPUT (policy ACCEPT)
target    prot opt source              destination       

Chain FORWARD (policy ACCEPT)
target    prot opt source              destination       

Chain OUTPUT (policy ACCEPT)
target    prot opt source              destination

I tried this with numerous ports. I have a bittorrent client which uses port 27260 for incoming connections. Incoming connections are not working in the client. I also tried accessing a MySQL database on 3306 on my machine from another machine, and it does not work. Accessing 3306 on the local machine does work. (The SQL user has access from host %, i.e. anywhere).

hen770, I do not understand what you mean...

EricTRA 10-18-2011 07:27 AM


For what MySQL concerns, did you configure the bind-address to the IP you want to connect to? Default installation has set as bind-address so it's only normal that your MySQL instance isn't responding on a LAN / public IP if that's the case. Can you check what listening ports/service you have running? Run:

netstat -tunalp
and post output.

Kind regards,


fmr 10-18-2011 08:38 AM

Cool beans! I forgot about the netstat utility. It seems the problem was with MySQL only listening on The bind-address is now and it's working. Some other ports are still not working, but those must be similar problems...

Thank you!

EricTRA 10-18-2011 08:47 AM


You're welcome! Glad you've found at least a solution for MySQL. I'm sure you'll figure out what's wrong with the other processes/services. If you need assistance, don't hesitate to post details about what process / service you need to configure.

Kind regards,


All times are GMT -5. The time now is 04:07 AM.