LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices


Reply
  Search this Thread
Old 02-13-2006, 12:33 PM   #1
piforever
Member
 
Registered: Dec 2005
Distribution: CentOS 5 - Debian 5
Posts: 112

Rep: Reputation: 15
disable SELinux for some daemons from runlevel 3


How can I do that??

If I wanted to disable the whole thing I will edit "/etc/selinux/config" and set
Code:
SELINUX=disabled

but what I want is for instance disable SELinux for httpd at runlevel 3!

thnx in advance,
 
Old 02-13-2006, 04:36 PM   #2
Capt_Caveman
Senior Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 69
First let me ask why do you want to do that? If you are having problems with SELinux, I'd recommend fixing them rather than disabling it.
 
Old 02-13-2006, 06:33 PM   #3
piforever
Member
 
Registered: Dec 2005
Distribution: CentOS 5 - Debian 5
Posts: 112

Original Poster
Rep: Reputation: 15
I did have some troubles in the past with SELinux....and I just want to know how to do that since google always leads me to the same answer which is how to disable from gnome for instance....what I want is to control it from runlevel 3....even if this practice is not advisable I would like to know how....can you help me???

thnx


*EDIT*
This is an example
http://www.linuxquestions.org/questi...d.php?t=395439

Last edited by piforever; 02-13-2006 at 06:35 PM.
 
Old 02-13-2006, 08:52 PM   #4
Capt_Caveman
Senior Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 69
You should be able to disable the selinux httpd targeted policy using:

setsebool -P httpd_disable_trans 1

Then restart the httpd daemon.

I'd still recommend you specifically fix the actual problem you are having with the httpd policy rather than shutting selinux enforcement off for httpd.

If you are having problems with CGI scripts, you may just need to enable CGI scripting under httpd using:

setsebool -P httpd_enable_cgi 1

If you are still having problems them post the error messages.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
What's the difference between runlevel 2 and runlevel 5 in Debian? davidas Linux - Newbie 2 01-05-2012 01:10 PM
disable SELinux for some daemons from runlevel 3 piforever Fedora 1 02-13-2006 08:35 PM
Soun Mixer absent in Runlevel 3 but present in Runlevel 5 debloxie SUSE / openSUSE 1 01-18-2006 09:15 AM
disable selinux on ubuntu linuxmandrake Ubuntu 2 01-11-2006 05:10 AM
Runlevel Editor - Cannot Enable/Disable caesium5 SUSE / openSUSE 1 10-06-2005 05:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Security

All times are GMT -5. The time now is 10:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration