-   Linux - Security (
-   -   Access Denied Error (

rlhjr20002 03-01-2005 12:23 PM

Access Denied Error
I am an inexperienced Linux user who has Linux installed on my laptop. I am running Red Hat Linux. Until yesterday I was successfully able to read and write files to my hard drive as well as to my zip drive. However, I was only able to write to my ZIP drive from root. So, as an inexperienced but brave newbie I tried to fix it myself. I went to root, typed in 'chmod 777 /dev/sda4', deleted /mnt/zip250.0 and re-created it, and thought this would fix the problem.

Now, I cannot write to ANYTHING. No matter if I'm logged in as root or as myself, and no matter if I am trying to write to my zip drive or my hard drive, I cannot write files anywhere. I get the message "Access denied. Could not write to [directory]", where [directory] is whatever directory I'm trying to access.

I checked the permissions using 'ls -l' and the permissions on the directory are read+write, so I don't understand why I'm getting this. Can someone help? I'm going to lose my data!

Thanks to anyone who can help. Your assistance is greatly appreciated.

Matir 03-01-2005 02:07 PM

Chmoding devices can be problematic, though it should not have affected your hard drive. What are the permissions on your hard drive's device? Also please post the output of "mount" so we can see what options each partition has been mounted with.

rlhjr20002 03-01-2005 03:14 PM

Thanks. Actually I solved this problem myself. I am learning that I must be careful creating directories as root. Without know not to do this, I had logged in as root and created a lot of directories. I was then trying to access them from a user account. I fixed this by changing ownership to the user.

The only unresolved issue I have is how to have read and write access to my Zip drive. I still get the "access denied" message. I mount it from root using 'mount /dev/sda4 /mnt/zip250.0'. It would be nice if I could access my zip drive from a user account, although if I can't get this fixed it's not the end of the world to me.

Matir 03-01-2005 03:42 PM

First, what filesystem is on the zip disk? If it's fat32, you'll want to look into the umask option for mount.

All times are GMT -5. The time now is 03:14 PM.