-   Linux - Newbie (
-   -   ~user pointing to wrong directory (

jmckeown 11-03-2003 05:30 AM

~user pointing to wrong directory
I'm passing this machine on to my mum
so I changed the user name - using the
Yast2 - it changed the /home/username
and set file ownereship to the new name

But when I tried to login again it said:
"No write access to $HOME directory
"KDE is unable to start

I tried --- cd ~username
and it said "No directory /home/oldusername

So somewhere the tilde user is still set to the
old username - I don't know where to fix this
but I suspectf this and KDE problem related

Seems failing in Suse 8.2 that its "Edit User"
facility has such fundamental omissions?

John McKeown

dannybpng 11-03-2003 06:13 AM

Take a look at the /etc/passwd file by getting to a shell prompt and typing:
more /etc/passwd

Does the "username" exist in the file?


jmckeown 11-03-2003 02:46 PM

Thanks - yes i found Yast "Edit User" hadn't updated /etc/passwd - but when I did a word-serach on olduername it was all over, e.g. in myriad StarOffice files, so i gave up and changed back to oldusername - Lesson learnt - it really isn't possib;e to change a username after apps have been installed under the old name.

What I'd like to do now is make KDE apps menu just say "Logout" rather than "Logout oldusername" - and similarly the box that appears on logout to not mention oldusername. Apart from that i don't think it appears much ( my mum won't mind the actual directory being /home/john )

John McKeown

All times are GMT -5. The time now is 05:26 AM.