LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-05-2010, 11:46 PM   #1
metal312
LQ Newbie
 
Registered: Jul 2010
Posts: 2

Rep: Reputation: 0
zlib-dev problem


Hi all,
I has encountered an probelem with zlib-devel
I'm using Centos 5.3 -i386, when I used yum to check if i installed zlib-devel, the system respond.

Code:
[root@localhost cs_rootfs_1.2.8]# yum list zlib-devel 
Loaded plugins: fastestmirror 
Loading mirror speeds from cached hostfile  
* base: ftp.cuhk.edu.hk  
* updates: ftp.cuhk.edu.hk  
*
 addons: mirror.eshk.hk  
* extras: ftp.cuhk.edu.hk 
Installed Packages 
zlib-devel.i386                        1.2.3-3                         installed
So i suppose that zlib-devel has been installed on my system. But when i try to complile cs_rootsf package. The error with zlib-devel come!
Code:
[root@localhost cs_rootfs_1.2.8]# make 

makeconfig:184: *** Error: 'zlib-dev' not available.  Stop.
I has tried to uninstall and reinstall the zlib-devel package but the problem still appear the same!
Could you help me to solved the problem? Any suggeststion will be much appreciated!
 
Old 07-06-2010, 04:00 PM   #2
rweaver
Senior Member
 
Registered: Dec 2008
Location: Louisville, OH
Distribution: Debian, CentOS, Slackware, RHEL, Gentoo
Posts: 1,833

Rep: Reputation: 164Reputation: 164
Did you run ./configure before running make (if applicable) is there a .config file does it contain an incorrect path?

Edit: (Would also be useful to know what you're attempting to compile.)

Last edited by rweaver; 07-06-2010 at 04:03 PM.
 
Old 07-07-2010, 04:42 AM   #3
metal312
LQ Newbie
 
Registered: Jul 2010
Posts: 2

Original Poster
Rep: Reputation: 0
The problem has been solved. I reinstall CentOS and now i can complie the package!

Thanks for your support!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
zlib problem when installing libpng SpinningCone Linux - Software 7 10-21-2011 11:47 AM
Zlib-1.2.3 Problem on Chapter 6.11 BrandonJ Linux From Scratch 1 04-06-2010 04:38 PM
no matching comp found: client zlib none, zlib@openssh.com lost connection jorge_ivan Linux - Networking 0 08-14-2006 08:09 PM
zlib.h problem jnusa Programming 4 01-14-2005 01:47 AM
Slackware 9.1, zlib and libpng-dev...???? ansemax Slackware 2 11-17-2003 01:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration