-   Linux - Newbie (
-   -   yum repositories (

steinz 11-12-2012 10:25 AM

yum repositories

I am using Oracle Linux, I am able to do yum update, but I am not sure which repository its using.
I have two files in /etc/yum.repos.d, both have enabled = 0. I have checked /etc/yum.conf and see not repositories listed. I can do a yum repolist and I see :
Loaded plugins: rhnplugin, security
repo id repo name status
ol6_x86_64_latest Oracle Linux 6 Latest (x86_64) 18,150
repolist: 18,150

where is Linux getting this info from?


unSpawn 11-12-2012 10:40 AM

'yum repolist enabled'

steinz 11-12-2012 11:49 AM

thanks but
that did not help, it still gives a list of the repository names. I have disabled all the repository files in /etc/yum.repos.d but I can still get out to the internet and update my system. so there must be a repository file I am not finding that is enabled.

John VV 11-12-2012 02:46 PM

if you did not reboot
rebuild the database
then the enabled repos are STILL in ram and still being used

normally the database IS automatically rebuilt on any change to the *.repo files
unless you disabled that


su -
rpm --rebuilddb
yum update

steinz 11-13-2012 07:23 AM

not the same
I do not want to rebuild the database.
what I would like to do is find out how the os knows where to go for the updates.
I have disabled the files in /etc/yum.repos.d/ and yet when I run yum update, it knows where to go for the latest versions of the packages. I have also looked at /etc/yum.conf and there is nothing in there.

unSpawn 11-13-2012 09:01 AM

Then consult the manual and run yum in debug mode. Maybe that shows some clues.

malak33 11-13-2012 11:25 AM

my guess is that the repo is still in the cache. Why not try a

yum clean all
Then try to update and see if it still knows where to go

John VV 11-13-2012 01:13 PM

Post the output of this please

su -
yum repolist all

some ( almost all) of the text files in /etc/yum.repos.d
Have more than one section
the normal
the source
the update

but the normal very first thing to try with a yum erroris the normal everyday fix that works 90% of the time

su -
yum clean all
rpm --rebuilddb
yum update

for 5 % of the remaining 10% this dose it
reverse the yum and rpm command

su -
rpm --rebuilddb
yum clean all

All times are GMT -5. The time now is 11:29 AM.