LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-11-2012, 12:42 AM   #1
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 610

Rep: Reputation: 34
yum installing problem e2fsprogs-devel


Hi Can any one tell me how to fix this

[root@nod01 ocfs]# yum install e2fsprogs-devel.x86_64
Loaded plugins: katello, product-id, security, subscription-manager
Updating certificate-based repositories.
Unable to read consumer identity
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package e2fsprogs-devel.x86_64 0:1.39-23.el5 set to be updated
--> Processing Dependency: e2fsprogs-libs = 1.39-23.el5 for package: e2fsprogs-devel
--> Finished Dependency Resolution
e2fsprogs-devel-1.39-23.el5.x86_64 from Server has depsolving problems
--> Missing Dependency: e2fsprogs-libs = 1.39-23.el5 is needed by package e2fsprogs-devel-1.39-23.el5.x86_64 (Server)
Error: Missing Dependency: e2fsprogs-libs = 1.39-23.el5 is needed by package e2fsprogs-devel-1.39-23.el5.x86_64 (Server)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest

Thanks And Bestregards
 
Old 09-11-2012, 07:48 AM   #2
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,411

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
So, have you tries the suggestions there (although I'd avoid --skip-broken if possible).

Also try
Code:
rpm --rebuilddb
yum clean all
 
Old 09-12-2012, 12:26 AM   #3
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 610

Original Poster
Rep: Reputation: 34
Hi chrism01, yep but nothing worked of the suggestion, but it seems that the customer forgot to register the systems REDHAT

Will that have anything to do with this error? kind of strange message to give for something like that I think

Thanks for the reply

Best Regards
 
Old 09-12-2012, 06:15 AM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,225

Rep: Reputation: 2520Reputation: 2520Reputation: 2520Reputation: 2520Reputation: 2520Reputation: 2520Reputation: 2520Reputation: 2520Reputation: 2520Reputation: 2520Reputation: 2520
Quote:
Hi chrism01, yep but nothing worked of the suggestion, but it seems that the customer forgot to register the systems REDHAT

Will that have anything to do with this error?
i would say YES

that error looks like it might be do to incompatible el5 rpms installed
i am guessing from random places on the net

for a unregistered RHEL5.? something?
there is no real fix other than randomly trying different
e2fsprogs-libs
to find a match that will work for "e2fsprogs-devel.x86_64 0:1.39-23.el5"

or find a different version of "e2fsprogs-devel.x86_64" that dose work

can you post the output of
Code:
yum repolist all

Last edited by John VV; 09-12-2012 at 06:16 AM.
 
Old 09-12-2012, 06:22 AM   #5
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,411

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
Also post
Code:
cat /etc/*release*
If you/your customer is willing to pay RH for a subscription, you'll get updates & support.
Otherwise, replace with Centos; free rebuild of RHEL that includes updates but not support.

If JohnVV is right and someone has tried to manually add random rpms (without being registered), you really need to make one of the above choices and straighten this system out; it can only get worse if you don't.
 
Old 09-13-2012, 04:12 AM   #6
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 610

Original Poster
Rep: Reputation: 34
Hi All once the customer did the registration it was able to get the this sorted out and this is working against RHEL repository

Thanks for all the help

Best Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem in installing libX11-devel summit Linux - Newbie 8 11-28-2011 11:47 PM
Problem installing httpd-devel on RHEL5 using yum scabbage Red Hat 6 02-17-2011 06:21 PM
x264-devel and lame-devel cannot be installed by yum yzhang738@hotmail.com Linux - Software 3 12-09-2010 08:19 PM
Problems installing mozilla-devel, strange yum dependency error Fegenbush Linux - Software 1 02-01-2007 01:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration