LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-16-2008, 11:52 PM   #1
shivang
LQ Newbie
 
Registered: Aug 2008
Posts: 8

Rep: Reputation: 0
Question YUM installation problem


whenever i am trying to install any thing by YUM its giving the same message..
i tried to insatll samba and it gave the following output:


yum install samba
Loaded plugins: refresh-packagekit
livna | 2.1 kB 00:00
removing mirrorlist with no valid mirrors: //var/cache/yum/fedora/mirrorlist.txt
Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again


with audacious andvlc m getting the same thing

[root@localhost ~]# yum install audacious
Loaded plugins: refresh-packagekit
removing mirrorlist with no valid mirrors: //var/cache/yum/fedora/mirrorlist.txt
Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again


[root@localhost ~]# yum install vlc
Loaded plugins: refresh-packagekit
Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mir...ra-9&arch=i386 error was
[Errno 14] HTTP Error 503: Service Unavailable
Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again


help me sort out this problem
 
Old 08-17-2008, 12:12 AM   #2
/usr/darien
Member
 
Registered: Mar 2008
Location: Virginia
Distribution: RHEL 4/5, Fedora 6-9, SuSE 10.1-11, Open Solaris 10.8, WinXP,2003,Vista
Posts: 59

Rep: Reputation: 15
Take a look at your .repo files located under /etc/yum.repos.d. Also, ensure you have a good connection to the Internet. I will assume that you are posting from the same system that is experiencing the issue; therefore, that leads me to believe your connection is good.
 
Old 08-17-2008, 12:12 AM   #3
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Start with

yum clean all

and see what happens
 
Old 08-17-2008, 01:58 AM   #4
shivang
LQ Newbie
 
Registered: Aug 2008
Posts: 8

Original Poster
Rep: Reputation: 0
@billy

after doing yum clean

[root@localhost ~]# yum clean all
Loaded plugins: refresh-packagekit
Cleaning up Everything

After this i tried to yum install but again the sam problem....it sort of strted dis time but struct with the same problem again

[root@localhost ~]# yum install audacious
Loaded plugins: refresh-packagekit
livna | 2.1 kB 00:00
primary.sqlite.bz2 | 253 kB 00:41
http://rpm.livna.org/fedora/9/i386/r...ry.sqlite.bz2: [Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.sqlite.bz2 | 245 kB 00:56
Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mir...ra-9&arch=i386 error was
[Errno 14] HTTP Error 503: Service Unavailable
Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again

i am having the above output....

Last edited by shivang; 08-17-2008 at 02:03 AM.
 
Old 08-17-2008, 12:50 PM   #5
moazzam2k
LQ Newbie
 
Registered: Aug 2008
Posts: 2

Rep: Reputation: 0
refer to this thread there is a problem with the servers
http://www.linuxquestions.org/questi...tadata-663305/

Last edited by moazzam2k; 08-17-2008 at 12:52 PM.
 
Old 08-17-2008, 09:16 PM   #6
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 6/7
Posts: 1,375

Rep: Reputation: 217Reputation: 217Reputation: 217
Just before this gets writen off as a general bug, ensure that your nameservers are correct in resolv.conf. It's a possibility... if those are wrong then yum will probably only be checking your local machine and you'll get problems like you are experiencing where yum is actually failing to find most of the repositories all together. If your not sure then paste the nameservers you have in resolv.conf here.

Last edited by r3sistance; 08-17-2008 at 09:18 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem in yum installation shivanrathore Linux - Newbie 3 07-30-2008 06:28 AM
Installation problem in yum bindu99 Linux - Software 1 12-26-2007 09:00 PM
problem with yum installation saak.stepi Linux - Software 26 12-14-2007 04:33 PM
YUM Download and Installation problem Altstatten Linux - Software 7 06-28-2006 07:14 AM
amarok installation yum problem TranceDude Linux - Software 5 08-27-2005 11:26 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration