-   Linux - Newbie (
-   -   yum hangs; unresponsive; problem with yum (

slingshot-dave 04-22-2010 11:11 AM

yum hangs; unresponsive; problem with yum
Hello everyone,

I have a bit of experience using linux, but I'm still a newbie when it comes to server administration.

Here's the story. I'm configuring a completely fresh install of "Red Hat Enterprise Linux Server release 5.3 (Tikanga)". This was installed by my host, but I've been assigned the task of administering it. The most simple of tasks is to install new software, but YUM doesn't want to play nice.

Whenever I run yum as root (install, update, repolist, fubar, ANYTHING) it displays:

[user@server-name ~]$ sudo yum update
Loaded plugins: rhnplugin

...and I get a blinking cursor. I have to hit <CTRL>-C a few times to get out of it. After I kill it, it displays some output, as if it was TRYING to do what I wanted. The common element seems to be this:


There was an error communicating with RHN.
RHN support will be disabled.
Error communicating with server. The message was:
Operation already in progress

I've never had this problem before. I can ping other servers, so I know it's not the connection. The only command I've tried that won't hang it is "yum clean all".

The only thread that comes close to my problem is this one:

I'm drawing a blank, and Google hasn't helped much either. I rarely post to forums, but I sure could use a hand. Any help would be appreciated. Thanks in advance! :)

-Dave T.

smoker 04-22-2010 07:01 PM

You have to wait.

If you have to wait too long, (I mean several minutes) complain to your hosts.
They probably have a local update server that is a bit slow when under load.

yum clean all is a local command that doesn't need a server connection.

chrism01 04-22-2010 07:25 PM

Try to login as root to save time, then

1. check if yum is actually running eg

ps -ef|grep yum

2. check for a lock file eg

ls /var/lock

If you killed it via ctrl-c, it may not have deleted the lock file, so the next run sees that and waits for the prev one to complete (which it it obviously won't)..

3. make sure rpm db is good

rpm --rebuilddb

4. yum clean all

5. Is the system registered with Redhat? If not, it should say so when you do

yum update

6. if you need to register


7. By default, there is a daemon rhnsd that polls Redhat every 4 hrs /etc/sysconfig/rhn/rhnsd

slingshot-dave 04-26-2010 09:43 AM

Thanks for all the input. I have a meeting with our hosts later today, so I'll follow up when this issue is resolved. It very well could be a hosting-side configuration issue, as I'm suddenly having trouble SSH-ing in.

slingshot-dave 04-27-2010 09:39 AM


Originally Posted by smoker (Post 3944531)
You have to wait.

If you have to wait too long, (I mean several minutes) complain to your hosts.
They probably have a local update server that is a bit slow when under load.

Thanks, smoker. I waited a while, and eventually it timed out.


[user@box ~]$ sudo yum update
Loaded plugins: rhnplugin
There was an error communicating with RHN.
RHN support will be disabled.
Error communicating with server. The message was:
timed out
Setting up Update Process
No Packages marked for Update

I'll have another talk with my hosts today.

Thanks for the tips, chrism01. Here's my results:

[user@box ~]$ ps -ef | grep yum
root      2341    1  0 08:06 ?        00:00:00 /usr/bin/python -tt /usr/sbin/yum-updatesd
root      3602  3564  0 08:44 pts/0    00:00:00 /usr/bin/python /usr/bin/yum update
502      3900  3861  0 08:53 pts/1    00:00:00 grep yum

python? Why would yum be running through python? (maybe I'm misreading that)


[user@box ~]$ ls /var/lock
dmraid  irqbalance  lvm  subsys

(not sure what I'm looking for here...)


[user@box ~]$ rpm --rebuilddb
(no response; I assume this is normal behavior)


[user@box ~]$ yum clean all
Loaded plugins: rhnplugin
Cleaning up Everything

Makes sense.

"yum update" times out, as previously mentioned

The system says that it has already been registered with my hosts information.

I'll see if my hosts can figure out what's going on. They spent all day yesterday resolving a networking issue. Finally, they had to completely shut-down and start-up the virtual server to get the network interfaces working again... More later.

smoker 04-27-2010 03:28 PM

My old hosts had similar issues.

They basically redirected rhn requests to their machines, but if their machines were down, you would get an error as if the redhat network was down. Using a caching server or something.

BYW, yum uses python.

so the rhn network is down is not neccessarily true.

frndrfoe 04-27-2010 03:36 PM

Perhaps you are using the location-aware update service and your firewall is not open to *all* the appropriate servers?

fpmurphy 04-27-2010 03:44 PM

Here is a pointer to the RHN client configuration guide:

slingshot-dave 04-28-2010 08:48 AM

Thanks again for all the replies.

I talked with my hosts last evening. It turns out that the Red Hat Network was not included with the package we bought from them... This makes it very confusing, because their configuration information and RHN are the default settings...

The support person I'm in contact with said he would investigate this. I think the answer is that we're not part of RHN. I would have thought that the RHN yum plug-in would return something to the effect of "you're not subscribed" and exited, rather than hanging for 3-5min.


As it turns out, there was some sort of miscommunication. We should be able to update through the RHN, but for some reason our server can't connect to the RHN.


...we are still not able to get a response from from RedHat when we try to register. We have been looking at the network aspects of this issue from several angles. The traffic looks good coming from (our server), but RedHat is not responding to the packets that we are sending to them...
Has anyone else had similar problems?

slingshot-dave 05-05-2010 04:38 PM

Solution; Solved; Issue Resolved
Thanks again to everyone for their contributions. As it turns out, my host was using an IP address that was blacklisted (or so I'm told). After numerous phone calls, we believe this to be the issue. If there is no other explanation for this, then we shall label this as the cause. If I hear anything else, I'll post that as well.

Thanks again!

All times are GMT -5. The time now is 01:14 PM.