LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   YUM finds 4 updates while up2date finds 29? (https://www.linuxquestions.org/questions/linux-newbie-8/yum-finds-4-updates-while-up2date-finds-29-a-301757/)

guest 03-15-2005 02:54 AM

YUM finds 4 updates while up2date finds 29?
 
I ran YUM and it updated about 4 apps.. while up2date still says 29...

i did DRIES and DAG YUM RPMs.... something i'm doing wrong?

Komakino 03-15-2005 09:39 AM

Do they each have a separate catalogue of what they've installed? If that's the case then they may only know about the apps/libraries that they have each installed, and not those installed by the other updater.

guest 03-15-2005 02:08 PM

hmm i dunno.. i just downloaded duke's yum.. and ran yum -y update... i used Dag's and Dries' repository... one of it has 633 and the other 1500+ files...

guest 03-15-2005 09:01 PM

RedHat's up2date found 39 updates for me today..

I ran yum update.. and here's the output:
Code:

[root@localhost ~]# yum -y update
Setting up Update Process
Setting up Repos
base                      100% |=========================|  951 B    00:00
updates                  100% |=========================|  951 B    00:00
Reading repository metadata in from local files
base      : ################################################## 635/635
updates  : ################################################## 635/635
No Packages marked for Update/Obsoletion
[root@localhost ~]#

here's my yum.conf file:
Code:

[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
retries=20
exactarch=1
obsoletes=1

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
[base]
name=Extra Fedora rpms dries - $releasever - $basearch
baseurl=http://apt.sw.be/dries/redhat/el4/en/i386/dries/RPMS

[updates]
name=xtra Fedora rpms dries - $releasever - $basearch
baseurl=http://apt.sw.be/dries/redhat/el4/en/i386/dries/RPMS

anyone have any ideas why this isn't working? :confused:


All times are GMT -5. The time now is 05:44 AM.