LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-29-2009, 07:36 AM   #1
redhat5
Member
 
Registered: Jul 2009
Posts: 50

Rep: Reputation: 15
Unhappy YUM error in installing vlc


When i used

yum install xine

it worked well(as it seemed to me) , though xine had errors.

After that i used

yum install vlc

it gave errors.

What i did in total was


[root@localhost ~]# yum install xine
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for xine to pack into transaction set.
xine-0.99.5-6.el5.i386.rp 100% |=========================| 29 kB 00:00
---> Package xine.i386 0:0.99.5-6.el5 set to be updated
--> Running transaction check
--> Processing Dependency: libxine.so.1 for package: xine
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for xine-lib to pack into transaction set.
xine-lib-1.1.16.3-2.el5.1 100% |=========================| 34 kB 00:01
---> Package xine-lib.i386 0:1.1.16.3-2.el5.1 set to be updated
--> Running transaction check
--> Processing Dependency: libwavpack.so.1 for package: xine-lib
--> Processing Dependency: libmodplug.so.0 for package: xine-lib
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for libmodplug to pack into transaction set.
libmodplug-0.8.7-1.el5.i3 100% |=========================| 4.4 kB 00:00
---> Package libmodplug.i386 1:0.8.7-1.el5 set to be updated
---> Downloading header for wavpack to pack into transaction set.
wavpack-4.50.1-2.el5.i386 100% |=========================| 4.4 kB 00:00
---> Package wavpack.i386 0:4.50.1-2.el5 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Installing:
xine i386 0.99.5-6.el5 rpmfusion-free-updates-testing 1.5 M
Installing for dependencies:
libmodplug i386 1:0.8.7-1.el5 epel 166 k
wavpack i386 4.50.1-2.el5 epel 126 k
xine-lib i386 1.1.16.3-2.el5.1 epel 2.7 M

Transaction Summary
=============================================================================
Install 4 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 4.5 M
Is this ok [y/N]: y
Downloading Packages:
(1/4): libmodplug-0.8.7-1 100% |=========================| 166 kB 00:04
(2/4): wavpack-4.50.1-2.e 100% |=========================| 126 kB 00:04
(3/4): xine-lib-1.1.16.3- 100% |=========================| 2.7 MB 01:45
(4/4): xine-0.99.5-6.el5. 100% |=========================| 1.5 MB 04:54
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: wavpack ######################### [1/4]
Installing: libmodplug ######################### [2/4]
Installing: xine-lib ######################### [3/4]
Installing: xine ######################### [4/4]

Installed: xine.i386 0:0.99.5-6.el5
Dependency Installed: libmodplug.i386 1:0.8.7-1.el5 wavpack.i386 0:4.50.1-2.el5 xine-lib.i386 0:1.1.16.3-2.el5.1
Complete!
[root@localhost ~]# yum install vlc
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Setting up repositories
Could not retrieve mirrorlist http://mirrors.rpmfusion.org/mirrorl...ng-5&arch=i386 error was
[Errno 4] IOError: <urlopen error (-3, 'Temporary failure in name resolution')>
Error: Cannot find a valid baseurl for repo: rpmfusion-nonfree-updates-testing
[root@localhost ~]# yum check-update
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up repositories
Could not retrieve mirrorlist http://mirrors.rpmfusion.org/mirrorl...ed-5&arch=i386 error was
[Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Error: Cannot find a valid baseurl for repo: rpmfusion-nonfree-updates
[root@localhost ~]# yum update yum
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Update Process
Setting up repositories
Could not retrieve mirrorlist http://mirrors.rpmfusion.org/mirrorl...ng-5&arch=i386 error was
[Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Error: Cannot find a valid baseurl for repo: rpmfusion-nonfree-updates-testing
[root@localhost ~]#




I cannot understand what this all means!

Is yum not well?
 
Old 07-29-2009, 09:09 AM   #2
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
Well, it's clear that yum couldn't find/set up the repositories. Anyway, it looks like you did it all wrong, because you are using RHEL, right?

It's explained on the RPM Fusion site like this;

Quote:
RHEL5 or compatible like CentOS:

Code:
su -c 'rpm -Uvh http://download1.rpmfusion.org/free/el/updates/testing/5/i386/rpmfusion-free-release-5-0.1.noarch.rpm http://download1.rpmfusion.org/nonfree/el/updates/testing/5/i386/rpmfusion-nonfree-release-5-0.1.noarch.rpm'
You need to enable EPEL on RHEL5 or compatible distributions like CentOS before you enable RPM Fusion for EL. See the fedoraproject wiki for instruction how to enable EPEL.

The RPM Fusion for EL repositories are still in the early testing stages; hence you (for now) need to enable epel-testing as well, as some of the RPM Fusion packages depend on packages that are currently in epel-testing.
Please go here and read it very carefuly. Also, download instructions.

That said, I'm not sure if VLC is in the repos, but at least you'll have things set up right. If it's not, have a look here.

Last edited by alan_ri; 07-29-2009 at 09:13 AM.
 
Old 08-08-2009, 06:04 AM   #3
redhat5
Member
 
Registered: Jul 2009
Posts: 50

Original Poster
Rep: Reputation: 15
[root@localhost ~]# yum install vlc
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Could not retrieve mirrorlist http://mirrors.rpmfusion.org/mirrorl...ng-5&arch=i386 error was
[Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Error: Cannot find a valid baseurl for repo: rpmfusion-nonfree-updates-testing
[root@localhost ~]# yum install vlc
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for vlc to pack into transaction set.
vlc-0.9.9a-2.el5.rf.i386. 100% |=========================| 151 kB 00:03
---> Package vlc.i386 0:0.9.9a-2.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: libfaad.so.0 for package: vlc
--> Processing Dependency: libmpeg2.so.0 for package: vlc
--> Processing Dependency: libQtGui.so.4 for package: vlc
--> Processing Dependency: liba52.so.0 for package: vlc
--> Processing Dependency: libswscale.so.0 for package: vlc
--> Processing Dependency: libdvbpsi.so.4 for package: vlc
--> Processing Dependency: libcvaux.so.1 for package: vlc
--> Processing Dependency: libmad.so.0 for package: vlc
--> Processing Dependency: libshout.so.3 for package: vlc
--> Processing Dependency: libid3tag.so.0 for package: vlc
--> Processing Dependency: libportaudio.so.2 for package: vlc
--> Processing Dependency: liblirc_client.so.0 for package: vlc
--> Processing Dependency: libavutil.so.49 for package: vlc
--> Processing Dependency: libvga.so.1 for package: vlc
--> Processing Dependency: libpostproc.so.51 for package: vlc
--> Processing Dependency: libmodplug.so.0 for package: vlc
--> Processing Dependency: libavcodec.so.52 for package: vlc
--> Processing Dependency: libx264.so.68 for package: vlc
--> Processing Dependency: libavformat.so.52 for package: vlc
--> Processing Dependency: libdirac_decoder.so.0 for package: vlc
--> Processing Dependency: libQtCore.so.4 for package: vlc
--> Processing Dependency: libaa.so.1 for package: vlc
--> Processing Dependency: libcaca.so.0 for package: vlc
--> Processing Dependency: libmpcdec.so.5 for package: vlc
--> Processing Dependency: libtwolame.so.0 for package: vlc
--> Processing Dependency: libcucul.so.0 for package: vlc
--> Processing Dependency: libebml.so.0 for package: vlc
--> Processing Dependency: libdirac_encoder.so.0 for package: vlc
--> Processing Dependency: libtag.so.1 for package: vlc
--> Processing Dependency: libzvbi.so.0 for package: vlc
--> Processing Dependency: libcxcore.so.1 for package: vlc
--> Processing Dependency: libXvMCW.so.1 for package: vlc
--> Processing Dependency: libixml.so.2 for package: vlc
--> Processing Dependency: libdvdnav.so.4 for package: vlc
--> Processing Dependency: libml.so.1 for package: vlc
--> Processing Dependency: libcddb.so.2 for package: vlc
--> Processing Dependency: libdvdread.so.3 for package: vlc
--> Processing Dependency: libmatroska.so.0 for package: vlc
--> Processing Dependency: libcv.so.1 for package: vlc
--> Processing Dependency: libxosd.so.2 for package: vlc
--> Processing Dependency: libSDL_image-1.2.so.0 for package: vlc
--> Processing Dependency: libhighgui.so.1 for package: vlc
--> Processing Dependency: libupnp.so.3 for package: vlc
--> Processing Dependency: libvgagl.so.1 for package: vlc
--> Processing Dependency: libdca.so.0 for package: vlc
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for libmodplug to pack into transaction set.
libmodplug-0.8.7-1.el5.i3 100% |=========================| 4.4 kB 00:00
---> Package libmodplug.i386 1:0.8.7-1.el5 set to be updated
---> Downloading header for lirc to pack into transaction set.
lirc-0.6.6-4.el5.rf.i386. 100% |=========================| 26 kB 00:00
---> Package lirc.i386 0:0.6.6-4.el5.rf set to be updated
---> Downloading header for libdvbpsi to pack into transaction set.
libdvbpsi-0.1.5-2.el5.rf. 100% |=========================| 4.0 kB 00:00
---> Package libdvbpsi.i386 0:0.1.5-2.el5.rf set to be updated
---> Downloading header for ffmpeg to pack into transaction set.
ffmpeg-0.5-2.el5.rf.i386. 100% |=========================| 12 kB 00:01
---> Package ffmpeg.i386 0:0.5-2.el5.rf set to be updated
---> Downloading header for ffmpeg-libs to pack into transaction set.
ffmpeg-libs-0.4.9-0.52.20 100% |=========================| 15 kB 00:00
---> Package ffmpeg-libs.i386 0:0.4.9-0.52.20080908.el5 set to be updated
---> Downloading header for opencv to pack into transaction set.
opencv-1.0.0-1.el5.rf.i38 100% |=========================| 8.2 kB 00:00
---> Package opencv.i386 0:1.0.0-1.el5.rf set to be updated
---> Downloading header for faad2 to pack into transaction set.
faad2-2.6.1-1.el5.rf.i386 100% |=========================| 4.8 kB 00:00
---> Package faad2.i386 0:2.6.1-1.el5.rf set to be updated
---> Downloading header for libdca to pack into transaction set.
libdca-0.0.5-3.el5.i386.r 100% |=========================| 4.4 kB 00:00
---> Package libdca.i386 0:0.0.5-3.el5 set to be updated
---> Downloading header for taglib to pack into transaction set.
taglib-1.5-2.el5.i386.rpm 100% |=========================| 6.1 kB 00:00
---> Package taglib.i386 0:1.5-2.el5 set to be updated
---> Downloading header for libmad to pack into transaction set.
libmad-0.15.1b-8.el5.i386 100% |=========================| 5.5 kB 00:00
---> Package libmad.i386 0:0.15.1b-8.el5 set to be updated
---> Downloading header for libupnp to pack into transaction set.
libupnp-1.6.6-1.el5.rf.i3 100% |=========================| 4.9 kB 00:00
---> Package libupnp.i386 0:1.6.6-1.el5.rf set to be updated
---> Downloading header for aalib to pack into transaction set.
aalib-1.4.0-5.el5.rf.i386 100% |=========================| 6.1 kB 00:00
---> Package aalib.i386 0:1.4.0-5.el5.rf set to be updated
---> Downloading header for a52dec to pack into transaction set.
a52dec-0.7.4-13.el5.i386. 100% |=========================| 6.2 kB 00:00
---> Package a52dec.i386 0:0.7.4-13.el5 set to be updated
---> Downloading header for libcaca to pack into transaction set.
libcaca-0.99-0.5.beta16.e 100% |=========================| 6.2 kB 00:00
---> Package libcaca.i386 0:0.99-0.5.beta16.el5 set to be updated
---> Downloading header for portaudio to pack into transaction set.
portaudio-19-8.el5.i386.r 100% |=========================| 5.7 kB 00:00
---> Package portaudio.i386 0:19-8.el5 set to be updated
---> Downloading header for libid3tag to pack into transaction set.
libid3tag-0.15.1b-5.el5.i 100% |=========================| 5.2 kB 00:00
---> Package libid3tag.i386 0:0.15.1b-5.el5 set to be updated
---> Downloading header for x264 to pack into transaction set.
x264-0.0.0-0.4.20090708.e 100% |=========================| 4.4 kB 00:00
---> Package x264.i386 0:0.0.0-0.4.20090708.el5.rf set to be updated
---> Downloading header for xosd to pack into transaction set.
xosd-2.2.14-1.el5.rf.i386 100% |=========================| 5.7 kB 00:00
---> Package xosd.i386 0:2.2.14-1.el5.rf set to be updated
---> Downloading header for libcddb to pack into transaction set.
libcddb-1.3.1-1.el5.rf.i3 100% |=========================| 4.0 kB 00:00
---> Package libcddb.i386 0:1.3.1-1.el5.rf set to be updated
---> Downloading header for libshout to pack into transaction set.
libshout-2.2.2-1.el5.rf.i 100% |=========================| 6.5 kB 00:00
---> Package libshout.i386 0:2.2.2-1.el5.rf set to be updated
---> Downloading header for twolame to pack into transaction set.
twolame-0.3.12-1.el5.rf.i 100% |=========================| 4.1 kB 00:00
---> Package twolame.i386 0:0.3.12-1.el5.rf set to be updated
---> Downloading header for libmpeg2 to pack into transaction set.
libmpeg2-0.5.1-3.el5.i386 100% |=========================| 3.7 kB 00:00
---> Package libmpeg2.i386 0:0.5.1-3.el5 set to be updated
---> Downloading header for libebml to pack into transaction set.
libebml-0.7.8-1.el5.rf.i3 100% |=========================| 3.4 kB 00:00
---> Package libebml.i386 0:0.7.8-1.el5.rf set to be updated
---> Downloading header for dirac to pack into transaction set.
dirac-1.0.2-1.el5.rf.i386 100% |=========================| 9.4 kB 00:00
---> Package dirac.i386 0:1.0.2-1.el5.rf set to be updated
---> Downloading header for libmpcdec to pack into transaction set.
libmpcdec-1.2.6-1.el5.rf. 100% |=========================| 4.2 kB 00:00
---> Package libmpcdec.i386 0:1.2.6-1.el5.rf set to be updated
---> Downloading header for libmatroska to pack into transaction set.
libmatroska-0.8.1-1.el5.r 100% |=========================| 4.0 kB 00:00
---> Package libmatroska.i386 0:0.8.1-1.el5.rf set to be updated
---> Downloading header for libdvdread to pack into transaction set.
libdvdread-0.9.7-1.el5.rf 100% |=========================| 4.2 kB 00:00
---> Package libdvdread.i386 0:0.9.7-1.el5.rf set to be updated
---> Downloading header for libdvdnav to pack into transaction set.
libdvdnav-4.1.3-1.el5.i38 100% |=========================| 5.9 kB 00:00
---> Package libdvdnav.i386 0:4.1.3-1.el5 set to be updated
---> Downloading header for svgalib to pack into transaction set.
svgalib-1.9.25-3.el5.i386 100% |=========================| 17 kB 00:01
---> Package svgalib.i386 0:1.9.25-3.el5 set to be updated
---> Downloading header for SDL_image to pack into transaction set.
SDL_image-1.2.5-4.el5.i38 100% |=========================| 6.2 kB 00:00
---> Package SDL_image.i386 0:1.2.5-4.el5 set to be updated
---> Downloading header for zvbi to pack into transaction set.
zvbi-0.2.33-1.el5.rf.i386 100% |=========================| 17 kB 00:01
---> Package zvbi.i386 0:0.2.33-1.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: libImlib2.so.1 for package: ffmpeg-libs
--> Processing Dependency: libjack.so.0 for package: portaudio
--> Processing Dependency: libQtGui.so.4 for package: vlc
--> Processing Dependency: libxvidcore.so.4 for package: ffmpeg-libs
--> Processing Dependency: libcdio.so.7 for package: libcddb
--> Processing Dependency: libdvdcss >= 1.2.5 for package: libdvdread
--> Processing Dependency: libmp3lame.so.0 for package: ffmpeg
--> Processing Dependency: libsndfile.so.1 for package: twolame
--> Processing Dependency: faad2-libs >= 1:2.6.1 for package: ffmpeg-libs
--> Processing Dependency: libcppunit-1.12.so.0 for package: dirac
--> Processing Dependency: libcucul.so.0 for package: vlc
--> Processing Dependency: libgsm.so.1 for package: ffmpeg-libs
--> Processing Dependency: libsndfile.so.1(libsndfile.so.1.0) for package: twolame
--> Processing Dependency: libfaac.so.0 for package: ffmpeg
--> Processing Dependency: libdc1394.so.22 for package: ffmpeg-libs
--> Processing Dependency: libfaac.so.0 for package: ffmpeg-libs
--> Processing Dependency: libXvMCW.so.1 for package: vlc
--> Processing Dependency: libImlib2.so.1 for package: ffmpeg
--> Processing Dependency: libmp3lame.so.0 for package: ffmpeg-libs
--> Processing Dependency: libQtCore.so.4 for package: vlc
--> Processing Dependency: libcdio.so.7(CDIO_7) for package: libcddb
--> Processing Dependency: libx264.so.60 for package: ffmpeg-libs
--> Processing Dependency: libamrwb.so.3 for package: ffmpeg
--> Processing Dependency: libamrnb.so.3 for package: ffmpeg
--> Processing Dependency: libdvdread.so.4 for package: libdvdnav
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for gsm to pack into transaction set.
gsm-1.0.13-1.el5.rf.i386. 100% |=========================| 4.6 kB 00:00
---> Package gsm.i386 0:1.0.13-1.el5.rf set to be updated
---> Downloading header for jack-audio-connection-kit to pack into transaction set.
jack-audio-connection-kit 100% |=========================| 9.7 kB 00:01
---> Package jack-audio-connection-kit.i386 0:0.103.0-4.el5 set to be updated
---> Downloading header for lame to pack into transaction set.
lame-3.98.2-1.el5.rf.i386 100% |=========================| 6.4 kB 00:00
---> Package lame.i386 0:3.98.2-1.el5.rf set to be updated
---> Downloading header for libcdio to pack into transaction set.
libcdio-0.78.2-5.el5.i386 100% |=========================| 9.8 kB 00:01
---> Package libcdio.i386 0:0.78.2-5.el5 set to be updated
---> Downloading header for libdc1394 to pack into transaction set.
libdc1394-2.0.2-1.el5.i38 100% |=========================| 5.0 kB 00:00
---> Package libdc1394.i386 0:2.0.2-1.el5 set to be updated
---> Downloading header for libdvdcss to pack into transaction set.
libdvdcss-1.2.10-1.el5.rf 100% |=========================| 4.1 kB 00:00
---> Package libdvdcss.i386 0:1.2.10-1.el5.rf set to be updated
---> Downloading header for amrnb to pack into transaction set.
amrnb-7.0.0.2-1.el5.rf.i3 100% |=========================| 4.7 kB 00:00
---> Package amrnb.i386 0:7.0.0.2-1.el5.rf set to be updated
---> Downloading header for libsndfile to pack into transaction set.
libsndfile-1.0.17-2.el5.i 100% |=========================| 6.6 kB 00:00
---> Package libsndfile.i386 0:1.0.17-2.el5 set to be updated
---> Downloading header for faac to pack into transaction set.
faac-1.28-1.el5.i386.rpm 100% |=========================| 5.8 kB 00:00
---> Package faac.i386 0:1.28-1.el5 set to be updated
---> Downloading header for cppunit to pack into transaction set.
cppunit-1.12.0-4.el5.1.i3 100% |=========================| 4.8 kB 00:00
---> Package cppunit.i386 0:1.12.0-4.el5.1 set to be updated
---> Downloading header for amrwb to pack into transaction set.
amrwb-7.0.0.3-1.el5.rf.i3 100% |=========================| 3.5 kB 00:00
---> Package amrwb.i386 0:7.0.0.3-1.el5.rf set to be updated
---> Downloading header for libdvdread to pack into transaction set.
libdvdread-4.1.3-1.el5.i3 100% |=========================| 5.3 kB 00:00
---> Package libdvdread.i386 0:4.1.3-1.el5 set to be updated
---> Downloading header for x264-libs to pack into transaction set.
x264-libs-0.0.0-0.15.2008 100% |=========================| 5.6 kB 00:00
---> Package x264-libs.i386 0:0.0.0-0.15.20080613.el5 set to be updated
---> Downloading header for xvidcore to pack into transaction set.
xvidcore-1.2.2-1.el5.rf.i 100% |=========================| 4.2 kB 00:00
---> Package xvidcore.i386 0:1.2.2-1.el5.rf set to be updated
---> Downloading header for imlib2 to pack into transaction set.
imlib2-1.4.0-1.el5.rf.i38 100% |=========================| 18 kB 00:01
---> Package imlib2.i386 0:1.4.0-1.el5.rf set to be updated
---> Downloading header for faad2-libs to pack into transaction set.
faad2-libs-2.6.1-5.el5.i3 100% |=========================| 6.8 kB 00:00
---> Package faad2-libs.i386 1:2.6.1-5.el5 set to be updated
--> Running transaction check
--> Processing Dependency: libQtGui.so.4 for package: vlc
--> Processing Dependency: libgif.so.4 for package: imlib2
--> Processing Dependency: libmp4v2.so.0 for package: faac
--> Processing Dependency: libdvdread.so.3 for package: vlc
--> Processing Dependency: libXvMCW.so.1 for package: vlc
--> Processing Dependency: libcucul.so.0 for package: vlc
--> Processing Dependency: libQtCore.so.4 for package: vlc
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for libmp4v2 to pack into transaction set.
libmp4v2-1.5.0.1-6.el5.i3 100% |=========================| 4.8 kB 00:00
---> Package libmp4v2.i386 0:1.5.0.1-6.el5 set to be updated
---> Package libdvdread.i386 0:0.9.7-1.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: libQtGui.so.4 for package: vlc
--> Processing Dependency: libgif.so.4 for package: imlib2
--> Processing Dependency: libdvdread.so.3 for package: vlc
--> Processing Dependency: libXvMCW.so.1 for package: vlc
--> Processing Dependency: libcucul.so.0 for package: vlc
--> Processing Dependency: libQtCore.so.4 for package: vlc
--> Finished Dependency Resolution
Error: Missing Dependency: libQtGui.so.4 is needed by package vlc
Error: Missing Dependency: libQtCore.so.4 is needed by package vlc
Error: Missing Dependency: libcucul.so.0 is needed by package vlc
Error: Missing Dependency: libXvMCW.so.1 is needed by package vlc
Error: Missing Dependency: libgif.so.4 is needed by package imlib2
Error: Missing Dependency: libdvdread.so.3 is needed by package vlc


What to do now?
 
Old 08-08-2009, 01:45 PM   #4
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
You need to have a base repo AND a repo that carries the rpm you need (rpmforge in this case).

Quote:
This system is not registered with RHN.
RHN support will be disabled.
In order access the RHEL base repo you have to pay the subscription fee. If you do not wish to pay that fee or cannot afford it, you should not run RHEL. Centos is RHEL with the logos removed. It is free to download/update(unlike RHEL).
 
Old 08-10-2009, 07:19 AM   #5
redhat5
Member
 
Registered: Jul 2009
Posts: 50

Original Poster
Rep: Reputation: 15
As you say, i have already configured yum to use cent os repo.

Will it suffice?

Thank You

One more question:

When i leave my system ON and UNATTENDED for some longer period of time ( as during some Heavy Downloads CENTOS5 LIVE CD 691 MBs), it goes to SLEEp like condition and the download stops and sometimes even, the MOUSE POINTER stops working(it fixes to the place it was left at).

How can i configure the system so that it does not go to sleep.

I cannot find the POWER DOCUMENTATION.

I am using RHEL5 Desktop.

Thanks
 
Old 04-27-2010, 10:57 AM   #6
antonio.sequela
LQ Newbie
 
Registered: Apr 2010
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by redhat5 View Post
As you say, i have already configured yum to use cent os repo.

Will it suffice?

Thank You

One more question:

When i leave my system ON and UNATTENDED for some longer period of time ( as during some Heavy Downloads CENTOS5 LIVE CD 691 MBs), it goes to SLEEp like condition and the download stops and sometimes even, the MOUSE POINTER stops working(it fixes to the place it was left at).

How can i configure the system so that it does not go to sleep.

I cannot find the POWER DOCUMENTATION.

I am using RHEL5 Desktop.

Thanks
Go to root account, open the menu --> system --> Preferences --> More Preferences --> Power Management -->

1 - running on AC --> adjust timing of laptop to sleep if inactive when running on power..

2 - running on battery --> adjust timing of laptop to sleep if inactive when running on battery (make "put computer to sleep when it is inactive for" maximum) under Actions "when laptop lid is closed --> select "Do Nothing".

3 - General --> Under General menu "Sleep type when inactive select this to "Do Nothing" "

Regards,
.................just reply a thanks if this is useful for you
 
Old 04-27-2010, 11:52 AM   #7
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,363

Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by redhat5 View Post


What to do now?
Goto the site rpm.pbone.net and search for the missing dependencies ..

or use the respository from that site ..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error in installing VLC-0.8.6 sumeet inani Linux - Newbie 3 07-28-2009 03:22 AM
VLC error: VLC could not open the file "/usr/share/vlc/skins2/text.bmp". brjoon1021 Ubuntu 1 01-14-2009 11:48 PM
Problem installing VLC player through yum in FC4...Help Plz mahesh_infinity Linux - Newbie 3 11-04-2007 12:27 PM
simple vlc yum install error alabamaman Linux - Software 1 09-11-2007 02:33 PM
yum problem while installing vlc in RedHat FC4 g_srinivas Linux - Software 1 07-20-2005 11:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration