-   Linux - Newbie (
-   -   Yum and Fedora 5 (

thammerlund 07-13-2006 03:08 AM

Yum and Fedora 5
I'm in the process of learning how to use Fedora 5, and I'm using yum to install my files. However, yum installs them without telling me where they are, so is there a way to have the installation path displayed, a flag or switch or something?

Also, when I run the yum command, such as:

yum install gdal


yum install gdal-1.3.1-2.i386.rpm

it will run through it, and then say "There is nothing to do." Does that mean that the file (in this case gdal) is already installed on my machine and doesn't need to be updated/installed? I try to find where it is using the locate command, but it doesn't say anything. Does anyone have any tips/advice/ideas?

Thank you,

cdhgee 07-13-2006 03:20 AM

You can't get yum to tell you the path to the file, but you can work it out with a little bit of effort. First of all, when you 'yum install' a package, note which repository it comes from (the right-most column) when it prompts you 'Is this ok [y/n]?'

Then go to the directory /etc/yum.repos.d/. In one of the files in this directory, there will be a definition for that repository name which will list either the URL for the repository, or a number of mirror URLs for that repository. Follow the path (substituting in i386 for $arch and things like that) and you should find the path.

"There is nothing to do" generally means it can't find the package you want to install. It will generally say something like "xxx is already installed" if it's already installed, but you can manually check. For example, to see if the package you mention gdal is already installed, issue the following command:


rpm -q gdal
If it is installed, it will come back and say something like:


Otherwise, it won't.

thammerlund 07-13-2006 03:28 AM

Thank you very much for your help. You were right, I did have the filename wrong when I used yum. But the same thing happens with apache. I tried yum install apache, and it said nothing to do. I know apache is already installed, but I also read somewhere else that "yum install apache" was the proper way to get apache. Have you seen that?

cdhgee 07-13-2006 03:44 AM

If you try to yum install something that is already installed, it won't do anything - unless of course it can find a more up-to-date version available online, in which case it'll prompt you to download the update.

The name that yum requires is the name of the package - if indeed it is called apache (which I think it is), and you can check this with

rpm -q apache
If it doesn't do anything that's because it can't find any updates.

thammerlund 07-13-2006 04:12 AM

Thank you again!

ethics 07-13-2006 05:24 AM


yum search <package>
also find matches for that package, and it'll show if it's installed or not, rpm-q is quicker though. Primary use of yum search is to query the repos (something to bear in mind if you cant find exact package)

schneidz 07-13-2006 11:44 AM

my yum on fc5 is acting kinda weird:


yum install <package>
will download the package and dependacies to /var/yum/cache and ask me 'Is this ok [y/n]?' but it won't install.

i have to go to /var/yum/cache and manually rpm -Uvh package which traps me in dependancy hell.

cdhgee 07-13-2006 03:27 PM

Obvious I know, but you are actually typing y and hitting enter, are you?

schneidz 07-13-2006 10:45 PM

i'm not sure, the power is out and its hard to see if the computer is plugged in.

just kidding, yes i am hitting 'y' when prompted

cdhgee 07-14-2006 03:01 AM

Does it give any error message or does it just exit gracefully?

schneidz 07-14-2006 11:30 AM

no error messages.

very weird?

schneidz 07-17-2006 03:15 PM

yum downloading but not installing
anybody know why it wouldn't install packages even if i'm root?

billymayday 07-17-2006 04:27 PM

A bity late in the piece, but on my fc5 box, apache is called httpd - hence yum install httpd rather than yum install apache should work

thammerlund 07-17-2006 11:58 PM

How can you see what the programs are called in the repository? in other words, how did you see that apache is called "httpd" on your system?

All times are GMT -5. The time now is 04:00 AM.