-   Linux - Newbie (
-   -   YPBINDPROC_DOMAIN: Domain not bound (

Destrey 01-31-2008 01:29 AM

YPBINDPROC_DOMAIN: Domain not bound
Hello everyone, I have recently inherited a network of Ubuntu 6.06 clients connecting to an SME Server 7.2 host via a 24 port switch (using NIS). Everything is on the same subnet. One of the clients has just started rejecting all attempts at logging on to the network. As far as I can tell nothing has been changed on the client;-)
I pinged and got a reply so assume the NIC is OK. But can't ping anything else. I tried going into the Networking screen in Ubuntu while logged in as adminstrator but the cursor just spins for a while then disappears and it will not display the screen for me to check the NIC status through the gui. Any attempt to run YP commands comes back with YPBINDPROC_DOMAIN: Domain not bound. I have tried different NICs, replaced the Cat 5 cable (which was OK) and tried different ports on the switch. However I cannot contact the server. I have also compared the yp.conf and host files etc with other clients (and the documentation I have been left) and can't see anything untoward. The Hosts and domains settings on the SME server are OK. Is there something on the server that needs to be purged or unlocked somehow? Or where else should I be focussing my attention?
Many thanks,

waelaltaqi 02-01-2008 10:21 AM

Have you tried to ping the server's IP address from the client? If you can't ping the server the you might have a problem with the server. Check on network card and see if there is a firewall turned on on the server.

If you could ping the IP address then try to pint the host name of the server. If you can't ping the hostname then you got a problem with DNS.

If you can ping both ip and hostname then there is something wrong with NIS service...

How about you post some output?

Destrey 02-02-2008 11:35 PM

Thanks for the reply. But no, I can't ping the server (or any other machine on the network) from this machine. And I can't ping it from the server. I have several other Windows and Ubuntu machines on the network and they don't have problems.
However, to make matters worse, another PC on the same switch has just gone the same way. I will try plugging it into the network somewhere else to see what happens. But I suspect it is something software-related on the server e.g. a locked file or something?
The reason I say this is that (although this is probably not directly related) I have frequent problems with Firefox (on all the Ubuntu PCs) showing a message saying it is already running when a user tries to log in. I then (following the instructions I have been left) have to go and delete the profiles.ini file in the users .mozille/firefox directory. I am just wondering if there is a similar solution to the login problem.

Destrey 02-08-2008 01:19 AM

Couldn't find any help on this anywhere on the web. So if anyone else has the problem, do what I did and reconfigure the NIC to have a Fixed IP address. At least it works!

All times are GMT -5. The time now is 07:22 AM.