LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-18-2012, 07:16 AM   #1
uk.engr
Member
 
Registered: Apr 2012
Posts: 131

Rep: Reputation: Disabled
You don't have permission to access /Assignment/ on this server


Assalam o Alaikum. I am doing virtual hosting and done successfully. But when I make link from index.html to my folder then it gives message "You don't have permission to access /Assignment/ on this server".

Here are detail of configuration
[root@test1 test1.exp1.com]# pwd
/var/www/vhosts/test1.exp1.com
[root@test1 test1.exp1.com]# ls -l
total 8
drwxrwxrwx. 3 apache apache 4096 May 18 05:22 html
drwxrwxrwx. 4 apache apache 4096 May 17 01:37 logs
[root@test1 test1.exp1.com]# cd html
[root@test1 html]# ls -l
total 8
drwxrwxrwx. 2 apache apache 4096 May 17 04:20 Assignment
-rwxrwxrwx. 1 apache apache 75 May 17 04:25 index.html
[root@test1 Assignment]# ls -l
total 8
-rwxrwxrwx. 1 apache apache 0 May 17 04:20 Applications.doc
-rwxrwxrwx. 1 apache apache 3 May 17 04:19 Essays.doc
-rwxrwxrwx. 1 apache apache 7 May 17 04:20 Letters.doc
[root@test1 Assignment]# vim /etc/httpd/conf/httpd.conf
<VirtualHost *:80>
ServerAdmin webmaster@test1.exp1.com
DocumentRoot /var/www/vhosts/test1.exp1.com/html
ServerName test1.exp1.com
</VirtualHost>

I have also attached httpd.conf in txt format.
Thanks
Attached Files
File Type: txt httpd.txt (34.2 KB, 4 views)
 
Old 05-18-2012, 07:58 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,801

Rep: Reputation: 1590Reputation: 1590Reputation: 1590Reputation: 1590Reputation: 1590Reputation: 1590Reputation: 1590Reputation: 1590Reputation: 1590Reputation: 1590Reputation: 1590
Hi,

You need an index page in Assignment subdir, or else you should refer directly the file you want, e.g. <a href=Assignment/Applications.doc>blah</a>
Another possibility is to to enable Indexes in apache config:
Code:
<Directory /var/www/vhosts/test1.exp1.com/html/Assignment>
Options +Indexes
Allow from all
</Directory>
Regards
 
Old 05-18-2012, 08:18 AM   #3
uk.engr
Member
 
Registered: Apr 2012
Posts: 131

Original Poster
Rep: Reputation: Disabled
Yes it works thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
You don't have permission to access /phpmyadmin/ on this server. jonaskellens Linux - Newbie 5 12-19-2009 02:25 PM
You don't have permission to access /~username on this server. sijolinux Linux - Newbie 5 01-03-2008 05:19 PM
you don't have permission to access / on this server dus3d Linux - Software 5 04-18-2006 11:43 PM
You don't have permission to access / on this server. jkpalmer52 Linux - General 4 01-27-2004 04:05 PM
You don't have permission to access / on this server jaydave Linux - Networking 1 03-15-2003 06:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration