LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 02-08-2006, 04:46 PM   #1
wEvil
LQ Newbie
 
Registered: Feb 2006
Posts: 4

Rep: Reputation: 0
Yet another windows/Linux dual boot issue


Hi,

I know this general theme pops up again and again but I seem to be having trouble finding and working out the correct partitions, and right now I can't access either of my windows drives.

To start with I had two windows installations on seperate partitions on one serial ATA drive.

Win2k (primary partition)
WinXP-64 (secondary partition)

I'd been wanting to mess with Linux for a while so I decided to download a distro and try it out.

I've installed Fedora 4 on a seperate 14gb drive out of an old system, as to not mess up my windows installations. However, after installation it appears that it HAS in fact messed up my windows installs, which leaves me with a big problem.

Win2k and xp64 don't even play nice together!

I'm assuming nothing has been overwritten except what was required to install GRUB, however I get the standard failure to load, the system just displays the last few lines of grub.conf and nothing happens.

i've tried editing it around and keep getting the " Error 1 : Filename must be either an absolute pathname or blocklist" and i'm more or less at my wit's end here. It's not that I feel anything is particularly broken - just way too fiddly!

Quote:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/Linux_Volume_Grp/Root
# initrd /initrd-version.img
#boot=/dev/hdb
default=1
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.11-1.1369_FC4)
root (hd0,0)
kernel /vmlinuz-2.6.11-1.1369_FC4 ro root=/dev/Linux_Volume_Grp/Root rhgb quiet
initrd /initrd-2.6.11-1.1369_FC4.img
title Windows
rootnoverify (hd1,0)
chainloader (hd1,0)
Here is my grub.conf

and here is the results of fdisk -l

Quote:
Disk /dev/hdb: 15.3 GB, 15393079296 bytes
255 heads, 63 sectors/track, 1871 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 522 4192933+ 83 Linux
/dev/hdb2 523 1871 10835842+ 8e Linux LVM

Disk /dev/sda: 200.0 GB, 200048565760 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 15397 123676371 7 HPFS/NTFS
/dev/sda2 15398 24320 71673997+ f W95 Ext'd (LBA)
/dev/sda5 15398 24320 71673966 7 HPFS/NTFS
Basically, I need to work out where /dev/sda1 is as far as GRUB is concerned, correct?

Many thanks in advance, and i'm sorry to ask for help on such a well-covered topic.
 
Old 02-08-2006, 04:49 PM   #2
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 46
chainloader +1

is the correct syntax.
 
Old 02-08-2006, 05:03 PM   #3
wEvil
LQ Newbie
 
Registered: Feb 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Well, i made the edit, rebooted and no joy. after selecting "windows" as the boot option i just see the last two lines of grub.conf and then nothing happens :-/

Quote:
rootnoverify (hd1,0)
chainloader +1
 
Old 02-08-2006, 05:18 PM   #4
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
can you post your /boot/grub/device.map
 
Old 02-08-2006, 05:26 PM   #5
wEvil
LQ Newbie
 
Registered: Feb 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
# this device map was generated by anaconda
(fd0) /dev/fd0
(hd0) /dev/hdb
(hd1) /dev/sda
so i assume it was pointing to the correct place..

thanks for taking the time to look it over

Last edited by wEvil; 02-08-2006 at 05:29 PM.
 
Old 02-08-2006, 05:30 PM   #6
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Try adding:

map (hd0) (hd1)
map (hd1) (hd0)

before chainloader +1
 
Old 02-08-2006, 05:32 PM   #7
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Or try this:

title Windows
rootnoverify (hd1,0)
makeactive
chainloader (hd1,0)+1
 
Old 02-08-2006, 05:36 PM   #8
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 11,806

Rep: Reputation: 923Reputation: 923Reputation: 923Reputation: 923Reputation: 923Reputation: 923Reputation: 923Reputation: 923
Add the following to the Windows stanza before the chainload
Code:
map (hd0) (hd1)
map (hd1) (hd0)
Watch the blanks between parameters.
 
Old 02-08-2006, 05:49 PM   #9
wEvil
LQ Newbie
 
Registered: Feb 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Excellent - it all works perfectly!

Now what you suggested was simply telling GRUB to swap the HDD mapping over? I'd just like to know what I just did and why, that's all

Many thanks
 
Old 02-08-2006, 05:52 PM   #10
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Yup. Windows prefers to be the first HD. So you just fake it out by telling grub to pass on a bit (or byte?) that says it is indeed the first HD...

Linux doesn't care which drive it is which is why typically in dual boot setups you'll find people recommend you install windows on the first partition of the first drive and then install linux after...
 
Old 02-08-2006, 06:13 PM   #11
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 46
You can try to get into the grub command mode and

rootnoverify (hd1,<tab>)
Hitting tab will show you the partitions
chainloader +1
boot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Solution Dual Boot Windows & Linux [ALL DONE IN WINDOWS] No Linux terminology DSargeant Linux - Newbie 35 02-07-2006 03:29 PM
Solution Dual Boot Windows & Linux [ALL DONE IN WINDOWS] No Linux terminology DSargeant Linux - Newbie 4 11-10-2005 11:37 AM
Suse 9.1 & Windows XP dual boot issue gqstud79 Suse/Novell 7 02-16-2005 03:04 AM
How do I dual boot Linux and Windows XP from Windows boot file andyri Linux - Newbie 4 08-04-2004 10:09 PM
2hd Windows / Linux dual boot issue zdavis Linux - Hardware 3 02-14-2004 12:27 PM


All times are GMT -5. The time now is 01:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration