LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Yet another NTFS mounting problem (https://www.linuxquestions.org/questions/linux-newbie-8/yet-another-ntfs-mounting-problem-183543/)

david_annable 05-19-2004 11:17 PM

Yet another NTFS mounting problem
 
I'm running Red Hat 9, kernel version 2.4.20-31.9. I have installed the correct RPM to allow mounting of NTFS partitions. I have verified that the module is loaded and that NTFS shows up when I do a "cat /proc/filesystems" command. I ran fdisk -l and verified that I was attempting to mount the appropriate device (/dev/hdg2 in my case... it's a SATA drive and I'm not entirely sure why RH gave it the designation hdg).

I run the mount command: mount -t ntfs /dev/hdg2 /mnt/windrv
Output is: mount: wrong fs type, bad option, bad superblock on /dev/hdg2, or too many mounted file systems

Not sure where to go next.

Help!

vdogvictor 05-20-2004 12:03 AM

I just mounted an NTFS drive in fedora...I didn't use the -t ntfs part...what happens if you do that. you also may want to add this partition to your /etc/fstab if you want it to load every time. Other than that I would guess that you either have way too many things mounted or that /dev/hdg2 is not correct.

Also are you sure this partition is not corrupt?

david_annable 05-20-2004 10:40 AM

Here is the entire output from my fdisk -l command:

Quote:

Disk /dev/hdg: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdg1 * 1 3187 25599546 42 SFS
/dev/hdg2 3188 14593 91618695 42 SFS

Disk /dev/hdb: 8455 MB, 8455200768 bytes
255 heads, 63 sectors/track, 1027 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 13 104391 83 Linux
/dev/hdb2 14 144 1052257+ 82 Linux swap
/dev/hdb3 145 1027 7092697+ 83 Linux
So you can see that the first drive listed (my SATA drive) is indeed hdg1 and 2. I don't think hdg2 is corrupt since Windows has no problem reading and writing to it. If I try mounting without using the "-t ntfs" parameter, I get: mount: you must specify the filesystem type

Here is the output of a straight mount command:

Quote:

/dev/hdb3 on / type ext3 (rw)
none on /proc type proc (rw)
usbdevfs on /proc/bus/usb type usbdevfs (rw)
/dev/hdb1 on /boot type ext3 (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
none on /dev/shm type tmpfs (rw)
As you can see, I don't have all that many filesystems mounted at all!

Any other ideas? Please help!

Thymox 05-20-2004 07:05 PM

I, too, am confused as to why fdisk should report the wrong drive name (hdg), unless it is attached to another controller? I know that my brother-in-law's "C" drive is actually hde1 because it is on his SATA controller. I am also confused as to why it shows SFS at the filesystem rather than HPFS/NTFS. Do you have logical volumes under Windows?

If you're sure your harddrive is the Primary Master, then have you tried explicitly mounting /dev/hda2 instead of hdg2?

ChillyWilly 05-22-2004 04:16 PM

Hi david_annable,

I'm not sure if you've resolved this issue or not, but I'm getting the exact same error, though nothing about our specs are the same (I have a regular IDE drive identified as hda1). Were you able to mount it after all? I'd love to know how you did it.


All times are GMT -5. The time now is 04:21 AM.