LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-29-2005, 03:36 PM   #1
Sparky1
Member
 
Registered: Apr 2005
Location: Montreal, Canada
Distribution: Suse 10, 9.3 Pro, FC 3
Posts: 36

Rep: Reputation: 15
Question yast update causes display to revert to stoneage


Hey all, I just did a yast update on my Suse 9.3 Pro installation and it knocked me back to a Irix look. i.e. minimalistic graphics with 4 colors. I have a Konsole and I can enter commands. If I type Firefox it launches the browser, but I do not have my snazzy KDE desktop. Do you have any ideas what happened and how to get the desktop back? Thanks.
 
Old 04-29-2005, 03:40 PM   #2
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
It sounds like you have a minimal install; probably your terminal is an xterm rather than a konsole?

You can check if KDE is actually working by running
Code:
startkde
Some default setting somewhere has changed. You might have to log out and log back in to select KDE.

Alternatively, add this line to your ~/.xsession file (create the file if you need to):
Code:
startkde &> .xsession-errors
 
Old 04-29-2005, 05:39 PM   #3
Sparky1
Member
 
Registered: Apr 2005
Location: Montreal, Canada
Distribution: Suse 10, 9.3 Pro, FC 3
Posts: 36

Original Poster
Rep: Reputation: 15
Thanks rjlee,

I had a .xsession-errors file but no .xsession file. I created an .xsession file with startkde in it. When I rebooted it came up fine.

Here is what was in the error file, is there anything else I need to fix?

xset: bad font path element (#64), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax
startkde: Starting up...
kbuildsycoca running...
Reusing existing ksycoca
kbuildsycoca: WARNING: Property 'X-KDE-Weight' is defined multiple times (KOffic
eFilter)
kio (KService*): WARNING: Invalid Service : /opt/kde3/share/applications/kde/kba
rcode-label.desktop
kio (KService*): WARNING: Invalid Service : /opt/kde3/share/applications/kde/kba
rcode-label.desktop
kio (KService*): WARNING: Invalid Service : /opt/kde3/share/applications/kde/kba
rcode-label.desktop
kio (KMimeType): WARNING: 'kbearimportfilter.desktop' specifies undefined mimety
pe/servicetype 'KParts/Plugin'
libhal.c 911 : Error sending msg: No property info.category on device with id /o rg/freedesktop/Hal/devices/computer
libhal.c 911 : Error sending msg: No property info.category on device with id /o rg/freedesktop/Hal/devices/ide_0_0
libhal.c 1205 : Error sending msg: No property volume.disc.has_audio on device with id /org/freedesktop/Hal/devices/block_3_2
libhal.c 911 : Error sending msg: No property info.category on device with id /o rg/freedesktop/Hal/devices/ide_0_0
libhal.c 1205 : Error sending msg: No property volume.disc.has_audio on device with id /org/freedesktop/Hal/devices/block_3_65
libhal.c 911 : Error sending msg: No property info.category on device with id /o rg/freedesktop/Hal/devices/ide_0_1
libhal.c 911 : Error sending msg: No property info.category on device with id /o rg/freedesktop/Hal/devices/ide_0_1
libhal.c 1205 : Error sending msg: No property volume.disc.has_audio on device with id /org/freedesktop/Hal/devices/block_3_71
libhal.c 911 : Error sending msg: No property info.category on device with id /o rg/freedesktop/Hal/devices/ide_0_1
kdecore (KLibLoader): WARNING: KLibrary: /opt/kde3/lib/kde3/kcm_kdnssd.so: undefined symbol: init_kdnssd
Thanks again.
 
Old 04-29-2005, 05:54 PM   #4
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
The .xsession file is only used if it exists; it overrides the desktop selection for the login manager (KDM, GDM or XDM).

The bad font path isn't a problem unless you have font-related issues; it just means that it's looking for a font package that you don't have installed.

The other warnings I wouldn't personally worry about (I don't actually know what they mean), but the message about /opt/kde3/lib/kde3/kcm_kdnssd.so implies that something is broken.

Run
Code:
rpm -qf /opt/kde3/lib/kde3/kcm_kdnssd.so
to find out which package this file belongs to, then run
Code:
rpm --verify package
to validate the package. You might also get more information from this command, which lists missing dependencies:
Code:
ldd /opt/kde3/lib/kde3/kcm_kdnssd.so
 
Old 04-30-2005, 12:49 PM   #5
HarshPlanet5
LQ Newbie
 
Registered: Apr 2005
Posts: 4

Rep: Reputation: 0
I found this in the Novell forums. I had the same problem after the YAST update on a new dell 700m. I found that after the yast update, my defaults had changed.

This link might work, but I'll include the text.




Thomas Schneider adjusted his/her tin foil beanie and asbestos underwear
to write:

> Hi,
>
> if installed sucessfully the 9.3 and and it works perfekt until i did
> a YOU update and installed the "Nvidia Display" driver via YOU.
> After insalling it and rebooting the KDE doesn`t come up. I only get
> now the xserver with this terrible gray background and after login i
> can start via xterm the kde (with startkde).
>
> if i run down to init leve 3 and starting Sax2 erverything is working
> perfekt and it displayes the right card "nvidia 5600 ultra".
>
> how can i get this kde working again? any idea?
>
>
> lg,
> Thomas

This is from another user:-

If you configure your Monitor, Display, Graphics Card using YAST/SAX,
config files in /etc/sysconfig will be reset from kdm/kde to xdm/twm:
1)
/etc/sysconfig/displaymanager Line 9:
DISPLAYMANAGER="xdm", should be
DISPLAYMANAGER="kdm"
2)
/etc/sysconfig/windowmanager Line 9:
DEFAULT_WM="twm", should be
DEFAULT_WM="kde"

After changing these entries back to kdm/kde,
reset your xserver [ctrl-alt-backspace] and you'll get the kde login
screen.

SuSE is working on this issue, but I've not set a patch yet.


HTH

--
Mark
Novell Support Forums SysOp
Twixt hill and high water
N. Wales, UK.


Legal | Privacy | AccessibilitNovell Forum
 
Old 05-02-2005, 09:25 PM   #6
Sparky1
Member
 
Registered: Apr 2005
Location: Montreal, Canada
Distribution: Suse 10, 9.3 Pro, FC 3
Posts: 36

Original Poster
Rep: Reputation: 15
HarshPlanet5,


1)
/etc/sysconfig/displaymanager Line 9:
DISPLAYMANAGER="xdm", should be
DISPLAYMANAGER="kdm"
2)
/etc/sysconfig/windowmanager Line 9:
DEFAULT_WM="twm", should be
DEFAULT_WM="kde"



Bingo!! that did the trick. Nice find.

In addition, it corrected another problem I had. When I selected log out from the menu and the log out box came up, all that was available was "end session". Now the other choices are back.

Last edited by Sparky1; 05-02-2005 at 10:01 PM.
 
Old 05-27-2005, 11:51 AM   #7
POMvR
LQ Newbie
 
Registered: May 2005
Posts: 2

Rep: Reputation: 0
Hey folks. This is my first post here at LinuxQuestions.org. I was glad to find this thread, as it helped me to force KDE 3.4 to load after I ran into this exact same problem using Yast2 to upgrade my KDE with SuSE 9.2.

However, the difference in my case was that I DID have the correct displaymanager and windowmanager settings, but KDE still wouldn't load. My screen would flash black a couple of times after a login, and then I would get the FVWM startup screen. It looked like it was trying to start KDE, but failed and reverted to FVWM. I tried deleting my .kde* folders in my home directory, reconfiguring the window and display mangers to use gnome, rebooted, then switched back to KDE. No luck. I looked at my .xsession-errors file after I added the .xsession file, and I get the same undefined symbol warning, but no major errors that would prevent it from loading based on the settings in /etc/sysconfig.

The library with the undefined symbol, /opt/kde3/lib/kde3/kcm_kdnssd.so belongs to the kdebase3-3.4.0-30 package. I ran the rpm verify against that package and got nothing back on the command line, so I'm assuming all is well with this package.

I read through a bunch of other posts on related issues, and one person suggested examining the /opt/kde3/share/config/kdm/Xsession file. However, I don't even have an /opt/kde3/share/config/kdm directory. Could that be part of the problem?

Any suggestions would be much appreciated. I'm up and running using the .xsession file in my user root directory. Unfortunately, other users still wind up in FVWM Thanks.

-Phil
 
Old 05-27-2005, 01:47 PM   #8
POMvR
LQ Newbie
 
Registered: May 2005
Posts: 2

Rep: Reputation: 0
Well, I think I figured this one out on my own. I realized that I didn't even have the xdm binary on my system, which is really odd, so I went into Yast2 and checked to see if it was installed. Sure enough, the kdm module was not selected by default for whatever reason. Odd. I installed it and everything seems to be going smoothly now. I still get the undefined symbol error for init_kdnssd in kcm_kdnssd.so, but it doesn't appear to cause any problems. If anyone figures that one out, let me know. Thanks for listening.

-Phil
 
Old 01-23-2006, 09:18 AM   #9
djrbaer@hotmail.com
LQ Newbie
 
Registered: Jan 2006
Location: Ontario, Canada
Distribution: OpenSuSE, Fedora Core, Xubuntu
Posts: 7

Rep: Reputation: 0
Solution #2

Well I had a similar problem and in the past had simply deleted my entire profile. this time I experimented with deleting the .kde folder in my profile and finally the best solution I ahve come up with is:

> rm .kde/share/config/kdesktop*

(the "*" because I have dual desktops/monitors because I can't get xinerama to work)

I don't even use my desktop (icons hidden) so I didn't bother to troubleshoot the files, just deleted them and all was good on next login.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with NVIDIA drivers after kernel update with yast online update Sheytan Linux - Software 4 05-06-2007 10:27 AM
YaST Online Update(YOU) Kernel Update? batorma Linux - Newbie 9 10-30-2005 03:17 AM
YAST Update apocolpse SUSE / openSUSE 2 10-27-2004 08:08 PM
Problems with NVIDIA drivers after kernel update with yast online update Sheytan Linux - Distributions 0 10-13-2004 11:01 AM
Yast Online Update Soulful93 Linux - Newbie 6 03-23-2004 09:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration