-   Linux - Newbie (
-   -   YaST problems, can't install ANY .exe files whatsoever. (

InfinitePalindrome 06-18-2008 03:41 PM

YaST problems, can't install ANY .exe files whatsoever.
No idea what's going on. Tried it thousands of times, made sure I have all the software
I need and not missing anything... got updates, looked through administrator settings..... etc.
I give it my root password, it says its scanning the installed packages, then it goes
homo on me. Just freezes up and that's that. NOTHING I do helps. *sobs*

{BBI}Nexus{BBI} 06-18-2008 04:22 PM

Considering GNU/Linux does not use .exe files, it comes as no surprise you can't install them natively! You need wine or to be running a virtualisation app such as vmware or virtualbox etc.

Galaxy_Stranger 06-18-2008 04:44 PM


Considering GNU/Linux does not use .exe files, it comes as no surprise you can't install them natively! You need wine or to be running a virtualisation app such as vmware or virtualbox etc.
I'm not quite sure that's what his problem is. He may just be wanting to say "executables" for Linux and abrieviated.

@InfinitePalindrome - What are you trying to install with Yast?

InfinitePalindrome 06-18-2008 05:45 PM

I'm trying to install .exe files. And I'm worried because since I can't install ANYTHING, how am I supposed to get things like wine?

InfinitePalindrome 06-18-2008 05:46 PM

P.S. I'm a girl.

Galaxy_Stranger 06-18-2008 06:06 PM

Ok - there is a difference between Windows executables and UNIX executables. The ".exe" file extension is a Windows convention. Windows executables will not run on a UNIX based system and vise-versa. What you look for is the Linux equivalent package for your system.

In your case, it sounds like you're just trying to run a Windows application in WINE.

Now, is it that WINE isn't working? Or are you trying to click on the .exe file to get it to run?

yancek 06-18-2008 06:17 PM

You shouldn't need to "get" anything like wine as almost every Linux distribution has wine included. Open your file manager in your /home directory and click on "view" and click "show hidden files". The look for the .wine folder. Should be there.

As Galaxy_Stranger said, wine is a Linux program designed to run windows programs on a Linux machine.

Here's their website with all the information you could possibly need.

lazlow 06-18-2008 06:22 PM

While I would agree that almost every Linux distro has wine available, I have not seen that many that install it by default. So I believe she will have to use yast to install wine and then install the exe via wine.

billymayday 06-18-2008 06:39 PM


Originally Posted by InfinitePalindrome (Post 3188647)
P.S. I'm a girl.

Last time you made a statement like that you were a woman. What happened?

Now, what have you tried to install and how. Leave out the exaggerations and be specific.

InfinitePalindrome 06-18-2008 06:54 PM

yancek: Checked it and it's not there.

Galaxy_Stranger: I just tried to install wine [in a .rpm file form] and it didn't work because I checked my hidden files again like yancek told me to and it's still not there. This happens with everything I attempt to download. If it's .exe, YaST freezes. If it's any other kind of file, it appears as though I've installed it, but I look further and realize that nothing happened. Just a little blue load bar in a "Downloads" window, which apparently does nothing except look pretty and give you the illusion that you changed something on your computer. ....

billymayday: o_o Woman/girl whatever. I'm female, you get it. -_-

Galaxy_Stranger 06-18-2008 07:05 PM

Ok - what version of Linux are you using? OpenSuse?

I don't know what packaging system Suse uses. RPM might not work.


$yum install wine
at the command line. Might not hurt to be root.

InfinitePalindrome 06-18-2008 07:47 PM

install: missing destination file operand after `wine'
Try `install --help' for more information.

Also, I'm using opensuse 10.3, and it should work for rpm
because whenever I try to use YaST it says
"RPM - scanning installed packages" then freezes shortly after.
I think it usually freezes after something like 'scanning caches'.

billymayday 06-18-2008 07:57 PM

yast can take ages. How long are you giving it? Is your opensuse internet connection OK?

Galaxy_Stranger 06-18-2008 08:13 PM


InfinitePalindrome 06-18-2008 08:22 PM

YaST isn't just loading a long time, I know. Whenever I've felt it's been too long and I try to x-out, I get a little window that says "program isn't responding", just like what happens all the time when you watch youtube on firefox. Except you can't reopen it, of course.

All times are GMT -5. The time now is 02:32 PM.