-   Linux - Newbie (
-   -   Xubuntu Hard Disk not Detected--Cannot Boot (

Kallaste 04-19-2012 11:36 AM

Xubuntu Hard Disk not Detected--Cannot Boot
Hello All,

My main, bootable disk just completely disappeared and I am at a loss what to do. I mean, how can I run anything on it to try to repair it if it's just gone?

I have been having a continual problem where every couple of weeks the superblocks get corrupted for some unknown reason (I ALWAYS shut down properly), and have to be restored from backups. Lately, though, this seems to be happening less frequently.

Also, sometimes, while the computer is on for a couple of hours, it will suddenly lose the ability to do any sort of task. Whatever program I'm running (VLC or Firefox usually) will just stop working, and when I close it, I won't be able to open anything again, because all the application menus have gone nuts. There will be no wording on the menus--just symbols like squares, circles, and lines. The terminal will not be accessible at all. Come to think of it, when this happens I actually do shut the computer down improperly by just flicking the switch, because there is no other way to do it. When I reboot after this, everything is usually fine.

However, today I had a problem where the external hard drive I store movies on could not be read. This has also happened before. I just rebooted the computer, but it would not boot back up. I got the Xubuntu screen telling me that disk errors had been found, and to press "F" to attempt to fix. I did so, and the screen stayed that way for about two hours without any change, until finally I just turned off the computer.

I booted with a Parted Magic CD, but when I try to run e2fsck or testdisk, my primary disk is just gone. My external hard drive is now reading as sda1.

Can anyone help?


Well, it showed back up again, but I still can't boot. Am starting a new thread.

SandsOfArrakis 04-20-2012 05:27 AM

I had a similar situation a few years ago. In my case it was the hard disk dying.

Satyaveer Arya 04-20-2012 06:59 AM

As the problem you described it seems that your harddisk has been corrupted. You need to get a new one. Once I also faced such kinda problems, later I came to know that the disk got corrupted and finally replaced with a new one..

Kallaste 04-20-2012 07:38 AM


Originally Posted by SandsOfArrakis (Post 4658176)
I had a similar situation a few years ago. In my case it was the hard disk dying.

Do you mean the superblock thing or the hard disk disappearing and coming back thing? Just wondering what the warning signs are. :)

SandsOfArrakis 04-20-2012 07:54 AM


Originally Posted by BloomingNutria (Post 4658277)
Do you mean the superblock thing or the hard disk disappearing and coming back thing? Just wondering what the warning signs are. :)

The hard disk died. It wouldn't boot and I wasn't able to access it from any computer I hooked it up in.
I've ended up replacing it with a new one. Started with Windows crashing, files I couldn't access even though Explorer showed them. After that Windows didn't want to boot anymore. BIOS no longer detecting the hard disk etc.

Looks like you're currently in a very similar situation. I fear you may have to look out for a new hard disk.

Kallaste 04-21-2012 11:38 AM

Well, I have been trying to get my data off this drive so that I can reinstall and start checking into my disk health (have not been able to figure out how to do this yet), but my computer just keeps going blank while I am running off the live cds and performing the copy operation (I have tried several cds, and they are all good disks that have worked on this pc before).

The live cds will boot up fine, but while I am copying my data off the hard drive, the screen goes blank, the monitor goes into sleep mode, and nothing I do will bring it back. Is this maybe a RAM problem instead of the disk?


Kallaste 04-21-2012 11:49 AM

By the way, I know it is not the cd drive because one of live cds it has done this with is Parted Magic, which loads completely into RAM and ejects the disk when the desktop loads. No disk in the drive while it is running at all.

Kallaste 04-21-2012 12:25 PM

Memtest86 says the memory's fine. I don't know what to do at this point, if I can't even get a live cd to run long enough to get my data. This is really frustrating. :|

TobiSGD 04-21-2012 03:15 PM

Things I would try, in this order:
1. Open the machine and re-seat the data and power cables of the disk and also on the motherboard.
2. If that doesn't help, replace the data cable for that disk.
3. Download the disk manufacturer's tool and test the disk.

Kallaste 04-28-2012 09:17 AM

Thanks for the reply. I'm still working on getting the manufacturer's tool to check the hard disk. It's Samsung, and they are giving me a hard time. In the meantime though, I reinstalled on an old disk and everything is running fine.

TobiSGD 04-29-2012 02:41 AM

Samsung has sold their disk manufacturing branch to Seagate, so nowadays the Seagate tool (Seatools) can be used to test Samsung HDDs.
Use the for DOS version, it comes as botable CD image.

Kallaste 04-29-2012 07:38 AM

Thank you. I knew about the Seagate involvement, but I wasn't sure if Seatools would work or if there was more to it than that (like maybe different versions for the Samsung drives or something weird like that). The online chat representative gave me an 800 number to call between the hours of 9:00 and 4:00 on weekdays, and made it sound like it would be a big process of pointing me toward the right tool for my model number, etc.

Anyway, I think I actually have a copy of Seatools on disk around here somewhere already. I'll give it a try, and then call them on Monday anyway if it comes up clean.

Thanks again!

Kallaste 04-29-2012 08:18 AM

Quick question. I can't find my Seatools for DOS disk, so I went to download it. In the download section, though, there is a drop down box that requires you to select an operating system (even though it's Seatools for DOS), and only different versions of Windows are listed.

Which one should I choose? Does it matter? Since presumably the computer's OS isn't even loaded in the bootable DOS version of this software, why are they even giving the choice?


TobiSGD 04-29-2012 08:57 AM

I just gave it a try and whatever choice you make it gives you the same ISO for download, so it doesn't matter which OS you choose. I don't know why they even ask.

Kallaste 04-29-2012 10:10 AM

Thanks. I should have thought of that. :)

All times are GMT -5. The time now is 02:23 PM.