LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Xubuntu 11.10 trouble with sound (https://www.linuxquestions.org/questions/linux-newbie-8/xubuntu-11-10-trouble-with-sound-920282/)

Georgia boy 12-23-2011 10:27 PM

Xubuntu 11.10 trouble with sound
 
Here's the short cap of what I'm experiencing. When using Ubuntu 10.04LTS, I can use my web cam and hear/see in Skype, also use the web cam mic for Sound Recorder. However, when in Xubuntu 11.10 when trying to use the web cam and web cam mic in Skype I can get a good video on the test but when using the sound test I only get static. Same when trying out the Sound Recorder. But, if I connect a hand held mic in Xubuntu 11.10 I can hear myself on the Sound test in Skype and also with the Sound Recorder. Is this a common issue in the 11.10 versions? I mean, with Ubuntu 10.04 I can use the web cam and web cam mic with no problems at all. It's only when I try to do that in Xubuntu 11.10 will I get static and have to use the old hand held mic to hear myself in the Sound Test in Skype and with the Sound Recorder.
Was wondering if anyone else had the same problem. Submitted a bug in Launch Pad but no results.

Thanks

fair_is_fair 12-23-2011 11:13 PM

Its a bug with alsa and 3.0 kernels. Lots of reports of similiar problems and I've had the same. I cannot run the new kernels on one machine at all despite upgrading alsa dkms, editing alsa config, etc. And this is not just with buntus - anything with 3.0 kernels.

The dkms fix did work on one machine. Give it a try.

https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS

Georgia boy 12-24-2011 10:57 AM

I kept wondering if it was a problem with the version of Xubuntu I have. I know that someone who had tried an earlier version had no problems with it in that area. So, because it's using a 3.0 kernel series, the Alsa and Kernel aren't learning to dance together right. Wonder if that problem will be addressed and solved when an updated kernel comes out for it. Did you remove the DKMs from the one that didn't work when you installed it? At least the old trusty hand held mic is still working. Hope that they get the Asla and Kernel to play together with updated Kernels that come out. Don't have any lower Kernels for Xubuntu to fall back on either. This is my first install of Xubuntu. Actually like it except for the issue we're having with Alsa not playing nice.
Glad to see that it's not the distro but that others have had the same issue. That didn't come out right. By that I meant it's narrowed down to the 3.0 Kernel and not a particular distro or version of a distro. That way hopefully the kernel will be actively hit with an update that will fix the problem. Thanks for the information. I even had set my Alsa with what I have in my Ubuntu 10.04 LTS to try and see if that would work. Of course as you know it didn't. At least I know that it's not me screwing up something or my computer screwed.

Thanks for the info. Maybe it'll get fixed soon and the Kernel updated for us.

fair_is_fair 12-24-2011 03:22 PM

I had reinstalled ubuntu 10.04 to get my sound working but ended up borking the installation later on.
I am now running Chakra on it. Chakra has a LTS kernel that works well. So, I ended up with a current OS with current software. I also get to play with a bright and shiny new Kde which is quite nice compared to Unity and Gnome 3.


All times are GMT -5. The time now is 01:28 AM.