-   Linux - Newbie (
-   -   xterm not recognizing files (

wiliamvw 03-22-2010 06:36 PM

xterm not recognizing files
openSUSE 10.2 KDE GoBook III zsh (but same with bash)

Well, I'm not really a newbie, but problem seems so impossible that must be something very fundamental that I'm overlooking.

As root and in xterm and in home directory, key-in:
ls Documents [gives: .directory (in black) and LA1b222.odt (in green)]
then: cat LA1b222.odt (gives: "No such file or directory")

Have tried various combinations and also cat on files listed in ~/Desktop and with same results ("No such file or directory")
As the file it says doesn't exist, it had just previously displayed on the very line above, I assume I'm overlooking something very basic, but can't determine what it is.

I am able to pull-up files from the computer's own system (proc, etc, so-forth), but NOTHING from my home directories whether /root or /user.

Some insight appreciated as wish to invoke vim and it (vi filename) won't come up for vi either.

Tinkster 03-22-2010 06:45 PM

Ummm ... you don't really want to cat an odt file; but that aside:
it *should* be
cat Documents/LA1b222.odt
if it's not in the current working directory but in Documents (as you
suggested yourself just one line above) ... ;}


wiliamvw 03-23-2010 03:53 PM

tried that as well
Appreciate your taking time to reply Tink, but that was one of the combinations that I had tried -- as well as full path on both the ~/Documents and the ~/Desktop entries when I tried to call-up each of the listed files, and constantly was checking that I was in home directory as my working directory (the use of cat was only a convenience after trying head and less and some others). I suppose it may be an OS problem in tieing in to the xterm, but 10.2 has always been reliable which why I went back to it.

Tinkster 03-23-2010 05:05 PM

The fact that you're talking about "root and user" makes me wonder whether you're
maybe sitting in a users home (e.g., /home/wiliam) as the user root, and issuing
ls ~/Documents or ~/Desktop ... that would certainly explain why you're not seeing
the file if wiliam downloaded or created the file, and root is trying to cat it.

I very much doubt that this problem has to do with xterm or with the version of
SuSE you're using, but rather is a user behaviour thing.


wiliamvw 03-27-2010 01:13 PM

tried various statuses
Thanks again Tink for thoughtful input. After installing more file handling programs, including locate, I tried again as simple user (prompt sign indicates am considered to be plain user) and still no access to files in home directories. I had also put a copy of my chief file of interest into /root home, but still no good even when did switch to being root (indeed, there is lock symbol on /root listing on directory options when am operating as simple user).
Am going through the book "Bash to Z Shell" to try to find-out just what I can do to solve this, but so far no real progress (well, I am learning some long delayed instructions).
Any additional thoughts greatly appreciated -- test and eliminate is my most operative strategy at the moment.

Tinkster 03-27-2010 02:30 PM

William, I still don't think that what you're facing is a
problem of bash or the xterm. Next thing I'd think of is
having a filesystem check performed on the partitions/
volumes in question ...

wiliamvw 03-29-2010 02:32 PM

filesystem check on PARTITIONS?
Am not sure how to check partitions relative to the filesystem except that the default file system is listed in the partition menu as being the one used.
Did fix a setting for home directory that was on "no" put it back to the default/recommended "yes" -- but made no difference.
Checking why "autofs" wasn't enabled (though doubt it would change much if was enabled) got message that it not configured and "files nis" does not provide a mount point. Paging though /etc/init.d/autofs shows nis at only two locations and both read the same:
function getmounts ()
for scheme in $(getschemes) ; do
case "$scheme" in

I recognize the C++ programing but not familiar with the syntax to be used here to change some line to what required to give "nis" the necessary mount point. This definitely is getting complicated, but will try to work through any suggestions provided.
Am attemting to install odt2txt program from freshmeat which wasn't available on the OS for some reason. Not sure what is meant by run make "in source directory" so trying couple things since won't install directly.

All times are GMT -5. The time now is 05:43 AM.