LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   XP NOT Loading after passing LILO in suse 9.1 (https://www.linuxquestions.org/questions/linux-newbie-8/xp-not-loading-after-passing-lilo-in-suse-9-1-a-229544/)

kirazo 09-11-2004 10:24 PM

XP NOT Loading after passing LILO in suse 9.1
 
Hi ppl,
i have just installed suse on my pc, i already had a previous partition for windows and made a new one for linux while i was installing it. The prob is that after the Lilo screen windows r not loaded and i get black screen with the following msg on top:

Windows Loading.................................................

and nothing happen. I can still load linux and i have already run the lilo command but still the same! Do u have any idea why is this happening and how i can correct it???:confused:

Thanx!

Tuvok 09-11-2004 10:43 PM

The kernel that come with SuSE 9.1 probably altered the geometry of your HD. I had the same problem, and the short fix is to access your BIOS, look for "LBA" and change it.

kirazo 09-12-2004 07:52 AM

Tuvok

thank u for ur reply. You were right about the geometry. Bios recognised only the 20g from my 80g hd. I have changed that but again the same. I found out that i had to add lba32 in the lilo.conf i did that and runned again lilo comand. Then again i had to fix the geometry but still the same result:

windows loading
_

Do you think there is something else i should check??
I've had both OS before on my PC but never had this prob.

Tuvok 09-12-2004 09:12 PM

kirazo,

My suggestion is to make a bootdisk (to boot SuSE) using Yast2, then use your Windows cd to restore the mbr (FIXMBR). Enable the "LBA" option in your BIOS. If Windows boots OK, then boot to SuSE and let Yast2 write SuSE to the mbr. Use the bootloader grub, as it's better than lilo. At any rate, you will need to enable "LBA" in order to boot Windows.

Good luck.

kirazo 09-13-2004 06:53 PM

thanx for replying again :)

Quote:

Originally posted by Tuvok
kirazo,

My suggestion is to make a bootdisk (to boot SuSE) using Yast2, then use your Windows cd to restore the mbr (FIXMBR).

i have used a boot disk and runned : fdisk/mbr

this removed lilo but it still doesn't boot into windows..message:
Operating system missing..

i have also tried to recover windows and still when it needed to reboot again there was the same message.
do u think there might be an incompatibility with the 80gb hd (the 1st partition is 60gb for windows, the 2nd 1024mb swap and 3rd the rest gb for linux)?:confused:

Tuvok 09-13-2004 10:30 PM

Quote:

Originally posted by kirazo
Operating system missing..
kirazo, enable "LBA" in your BIOS.

Standard CMOS Feature
IDE Primary Master
ACCESS MODE

use +- and choose LBA

kirazo 09-14-2004 07:16 AM

Quote:

Originally posted by Tuvok
kirazo, enable "LBA" in your BIOS.

tuvok sorry for not saying before...here's what happens when i enable LBA in BIOS:
it recognises my 80gb hd and it despalys it as it should be in Standard CMOS Feature
BUT....
after bios and before loading windows thats what it says:

.......
Primary Master Disk: LBA, UDMA 66, 2139MB (instead of 80gb)
Primary Slave : none
Sec Slave :CDROM, UDMA 33
......etc
Verifying DMI Pool Data...Update Success
Missing Operating System...

Then i go back to bios in Standard CMOS Feature and the hd is changed to 2139MB... :o

As u can see for some reason BIOS doesn't like the win partition. Think i just put the hd in another pc save the data if i can and reinstall everything from scratch...i hope this doesn't happen again...the only thing i am wondering now is when i do the partition should i make smaller partitions, is it possible that grub or lilo have problem of recognising big hd partitions?

thanx for all ur help, i'd love to find the solution of this prob but sometimes it gets tooo confusing.:confused:


All times are GMT -5. The time now is 08:28 AM.