LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   xine dvd (https://www.linuxquestions.org/questions/linux-newbie-8/xine-dvd-178166/)

Riichard 05-05-2004 09:45 AM

xine dvd
 
I'm having problems playing dvd on my SuSE 9 Kde3.2.2.
Ive followed these articles
http://www.linuxquestions.org/questi...ticle&artid=28
and this
http://www.linuxquestions.org/questi...ight=xine+suse
This is the Xine output
inux:~> xine -p dvd:/
This is xine (X11 gui) - a free video player v0.99.1.
(c) 2000-2003 The xine Team.
libdvdnav: Using dvdnav version 1-rc4 from http://xine.sf.net
libdvdread: Using libdvdcss version 1.2.8 for DVD access
libdvdread: Could not open /dev/dvd with libdvdcss.
libdvdread: Can't open /dev/dvd for reading
libdvdnav: vm: faild to open/read the DVD

Caeda 05-05-2004 09:59 AM

Sounds like you don't have a /dev/dvd Did you actually check to see if this link existed or if suse named it something else? like /dev/cdrom or cdrecorder or dvdrecorder?

franzfranz 05-05-2004 10:21 AM

you've mounted your dvd?

Riichard 05-05-2004 10:22 AM

My fstab looks like this
/dev/cdrecorder /media/cdrecorder
/dev/cdrom /media/cdrom
In xine settup 'device used for dvd playback' Ive tried
/dev/dvd
/dev/cdrom
/dev/cdrecorder
All of which give the same error 'vm: faild to open/read the DVD'

urka58 05-05-2004 11:02 AM

It could be a permission problem of such device.
First make sure your /dev/dvd is actually pointing to the proper device by
ls -l /dev/dvd
then include yourself as normal user (login name) into disk group.
Not sure disk group actually exist on Suse, may be such device is included in a different group.
Hope this helps

ciao

Riichard 05-05-2004 11:32 AM

It doesnt look like dev/dvd points to the right device
apollo@linux:~> ls -l /dev/dvd
lrwxrwxrwx 1 root root 8 2004-05-01 18:10 /dev/dvd -> /dev/hdc

Since my fstab is like this
/dev/cdrecorder /media/cdrecorder
/dev/cdrom /media/cdrom

Theres no dev/dvd in fstab or am i totally confused :confused:

franzfranz 05-05-2004 11:45 AM

i think that's what it's supposed to look like. xine plays dvds for me and that's where my /dev/dvd points to, but i also have /dev/dvd in my fstab. maybe the problem is that suse's mountpoints are /media/xxx?

Caeda 05-05-2004 05:01 PM

Ah. Yours should be set to /dev/cdrom as that is your dvd drive. Suse does that to me... but /dev/cdrom works fine. If you are mounting the dvd, don't. As a dvd doesnt need to be mounted to be played and this might be whats screwing it up.

urka58 05-05-2004 05:07 PM

It is not necessary you have an entry of /dev/dvd in your fstab.
As you can see from ls -l output this link exist and points to /dev/hdc that i guess is your dvd player or combo drive.
Please also note /dev/hdc is owned by root and is included in root group.
So unless you are included into root group you do not have any permission on such file.
A temporary fix while you do some search could be you create a group by
(be root first)
addgroup dvd_users
chown root.dvd_users /dev/hdc
chmod g+rx /dev/hdc
chmod g+rx /dev/dvd ( not strictly necessary, just to make sure)
Add yourself to dvd_users group
At this point you should have the necessary permissions on your /dev/hdc /dev/dvd
Also make sure you have libdvdccs correctly installed (it seems they are, but you never know)
Hope this helps
Ciao

Riichard 05-06-2004 07:19 AM

I've got it working, thanks, my permissions are sorted out.

But there still seems to be a problem with dma.
I turn the computer on and do this
/sbin/hdparm -d /dev/hdc
it tells me dma is on and a dvd plays fine.
However if I eject that dvd (using the eject in xine) and try to play another xine hangs
if I do this again
/sbin/hdparm -d /dev/hdc
the terminal sort of hangs, the only thing I can do is reboot if I want to watch another dvd.
I'm nearly there....


All times are GMT -5. The time now is 08:10 AM.