LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   xhost and DISPLAY error (https://www.linuxquestions.org/questions/linux-newbie-8/xhost-and-display-error-495280/)

miguelchagas 10-24-2006 08:46 PM

xhost and DISPLAY error
 
I searched all posts regarding this issue and couldn't find any answer that completely satisfied me. My problem: being a Linux newbie, I followed a tutorial on preparing Linux (Fedora Core 5) for an Oracle database install. I started linux graphically (gnome) logging in as root and started a gterm. Then I issued a xhost +<machinename.domain_name> command, still logged in as root. Then, I su to oracle (user to be used for Oracle database installation) and issued a
DISPLAY=<machine_name.domain_name:0.0; export DISPLAY command. Since then, every time I su to oracle user, I cannot open any text file using, by example, gedit. As soon as I try, an error related to display returns. The same error happens if I'm logged as root.
I tried to command xhost -<machine_name.domain_name> but same error occurs.
I'm looking for some help on where are the configuration files so I can edit them and remove the commands that leads to mentioned errors.
Any help would be very much appreciated. Thanks

uselpa 10-25-2006 02:10 PM

I'd suggest the following: as root,
Code:

xhost +local:
and then, as any local user:
Code:

export DISPLAY=:0.0
Now you should be able to run any X client.

miguelchagas 10-25-2006 05:16 PM

It worked! Many thanks!!!


All times are GMT -5. The time now is 07:40 AM.