LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 03-29-2013, 11:04 AM   #1
tissam89
Member
 
Registered: Mar 2013
Posts: 47

Rep: Reputation: Disabled
xfs is needed


hi,

I don't find the package xfs on my system

Code:
# rpm -Uvh chkfontpath-1.10.1-1.1.x86_64.rpm
warning: chkfontpath-1.10.1-1.1.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 37017186
error: Failed dependencies:
        xfs is needed by chkfontpath-1.10.1-1.1.x86_64
I have install those, but i have the same error

Code:
# rpm -qa | grep xfs
kmod-xfs-0.4-2
xfsprogs-2.9.4-4.el5
Your help please
 
Old 03-29-2013, 11:15 AM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 13,827

Rep: Reputation: 2369Reputation: 2369Reputation: 2369Reputation: 2369Reputation: 2369Reputation: 2369Reputation: 2369Reputation: 2369Reputation: 2369Reputation: 2369Reputation: 2369
Quote:
Originally Posted by tissam89 View Post
hi,
I don't find the package xfs on my system
Code:
# rpm -Uvh chkfontpath-1.10.1-1.1.x86_64.rpm
warning: chkfontpath-1.10.1-1.1.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 37017186
error: Failed dependencies:
        xfs is needed by chkfontpath-1.10.1-1.1.x86_64
I have install those, but i have the same error
Code:
# rpm -qa | grep xfs
kmod-xfs-0.4-2
xfsprogs-2.9.4-4.el5
As said in your other thread, you should use yum to install packages, since it would then resolve dependencies for you. So, type in "yum install chkfontpath", and press enter.
 
Old 03-29-2013, 04:44 PM   #3
tissam89
Member
 
Registered: Mar 2013
Posts: 47

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TB0ne View Post
As said in your other thread, you should use yum to install packages, since it would then resolve dependencies for you. So, type in "yum install chkfontpath", and press enter.
Thanks for your reply, but this is the result :

Code:
# yum install chkfontpath
Loaded plugins: security
Setting up Install Process
No package chkfontpath available.
Nothing to do
That's why i have try to do it by downloading the package
 
Old 03-30-2013, 02:21 AM   #4
Captain Pinkeye
Member
 
Registered: Oct 2012
Location: The Czech Republic
Posts: 162

Rep: Reputation: Disabled
Well, quick search on rpms.org shows that the 'xfs' is provided by 'xorg-x11-xfs' package.

 
Old 03-30-2013, 02:46 AM   #5
tissam89
Member
 
Registered: Mar 2013
Posts: 47

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Captain Pinkeye View Post
Well, quick search on rpms.org shows that the 'xfs' is provided by 'xorg-x11-xfs' package.
oh , that's right, thank you so much .

But there is also a problem . when i try to install xfs :

Code:
# rpm -Uvh xorg-x11-xfs-1.0.2-5.el5_6.1.x86_64.rpm
warning: xorg-x11-xfs-1.0.2-5.el5_6.1.x86_64.rpm: Header V3 DSA signature: NOKEY       , key ID e8562897
error: Failed dependencies:
        /usr/sbin/chkfontpath is needed by xorg-x11-xfs-1.0.2-5.el5_6.1.x86_64
So now when i try to install chkfontpath :

Code:
# rpm -Uvh chkfontpath-1.10.1-1.1.x86_64.rpm
warning: chkfontpath-1.10.1-1.1.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 37017186
error: Failed dependencies:
        xfs is needed by chkfontpath-1.10.1-1.1.x86_64
evry one is needed by the other . How to fix it please ?
 
Old 03-30-2013, 02:53 AM   #6
tissam89
Member
 
Registered: Mar 2013
Posts: 47

Original Poster
Rep: Reputation: Disabled
Thank you ,this command works :

Code:
rpm -Uvh chkfontpath-1.10.1-1.1.x86_64.rpm xorg-x11-xfs-1.0.2-5.el5_6.1.x86_64.rpm
warning: chkfontpath-1.10.1-1.1.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 37017186
warning: xorg-x11-xfs-1.0.2-5.el5_6.1.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID e8562897
Preparing...                ########################################### [100%]
   1:xorg-x11-xfs           ########################################### [ 50%]
   2:chkfontpath            ########################################### [100%]
 
Old 12-20-2013, 03:21 AM   #7
webtom
LQ Newbie
 
Registered: Dec 2013
Posts: 1

Rep: Reputation: Disabled
i don't install

[root@Tom Downloads]# rpm -Uvh chkfontpath-1.10.1-1.1.x86_64.rpm xorg-x11-xfs-1.0.2-5.el5_6.1.x86_64.rpm
warning: chkfontpath-1.10.1-1.1.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID e8562897: NOKEY
error: Failed dependencies:
libFS.so.6()(64bit) is needed by xorg-x11-xfs-1:1.0.2-5.el5_6.1.x86_64
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NAS on btrfs (possibly zfs/xfs) advice/help needed (software-getting started) rmk0610 Linux - Server 3 07-06-2010 05:06 AM
XGL needed for Beryl is conflicting with OpenGL needed for Cedega chunkeydelight Linux - Desktop 2 07-18-2007 05:50 AM
kdebase not recognizing XFree86-xfs package as xfs mikeyt_333 Linux - Software 1 08-17-2004 01:50 PM
2.4.22+xfs BedriddenTech Linux - Software 0 09-01-2003 06:30 AM
Xfs mikeshn Linux - Newbie 1 02-18-2002 07:29 PM


All times are GMT -5. The time now is 08:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration