LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-26-2004, 01:00 AM   #1
Qucho
Member
 
Registered: Mar 2004
Location: Colorado, US
Distribution: Debian "Sarge"
Posts: 228

Rep: Reputation: 30
XFree86 error (no screens found)


I am using Debian Woody. Kernel ver 2.4.18-bf2.4
My vid card is nVida GForce MMX 440
Optical USB Logitech mouse

Error message:
________________________________
(--) Assigning device section with no busID to primary device.
(EE) No devices detected.

Fatal error:
no screens found

XIO fatal IO error 104 (Connection reset by peer) on Xserver ":0.0" after 0 requests(0 known processes) 0 events remaining
__________________________________


is the meaning of this error that the X server can't 'see' my vid card, or is a mouse/keyboard issue ?

Do I have to install new nVidia drivers to solve it? if so, what version of the drivers should I get (Linux IA32 or Linux IA64)?

Trying to install the 'Linux IA32' drivers the installation program was unable to find the kernel-source files.

I used dselect to install the source files.

dselect will not list the kernel version I have installed by default in bf24 debian installation (Kernel ver 2.4.18-bf2.4).

I have installed the kernel-source-2.4.18 (notice is NOT bf2.4), and nvidia driver inslation program still complains about not finding the source files.

P.S. I have trying to fix this for the last 7 days. <desperated>

[edit]

Can this be due to font files and dirs misconfigured?

I added these lines to XF86Config-4 as indicated in the Debian installation procces:

FontPath: /va/lib/defoma/x-ttcidfont-conf.d/dirs/CID
FontPath: /va/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType

I noticed these two dirs are empty.
I also modified the font server port as instructed by Debian config.

Last edited by Qucho; 03-26-2004 at 01:05 AM.
 
Old 03-26-2004, 01:42 AM   #2
Brane Ded
Member
 
Registered: Nov 2003
Location: over there
Distribution: Debian Testing
Posts: 191

Rep: Reputation: 30
The device it refers to is your graphics card, which is appearently configured incorrectly. I'd actually recommend that you change your sources to testing, or even unstable, and update your system. Woody's great if you're trying to set up a server, but for a desktop, its software is a bit dated. And yeah, installing the nVidia drivers would be a good idea as well.

As for your configuration file, the easiest way I know of to fix that problem is to run /usr/X11R6/bin/xf86config, and give it all the information it asks for. After that, open the file and change it according to the instructions located on nVidia's download site.
 
Old 03-26-2004, 01:46 AM   #3
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
The most likely cause of your problem is refresh rates for your monitor. You will be able to detremine this by doing ;
$su
$password:
#cat /var/log/XFree86.0.log | more (or less)
and look for the relevant error
If this is the cause the first thing to do is to get the manufacturers refresh rates specifically the hsync and vsync either from the manual or via the internet. Having got this info do;

#dpkg-reconfigure xserver-xfree86

select nv (nvidia) and go into advanced settings for your monitor and use the refresh rates you obtained.
 
Old 03-26-2004, 02:05 AM   #4
Qucho
Member
 
Registered: Mar 2004
Location: Colorado, US
Distribution: Debian "Sarge"
Posts: 228

Original Poster
Rep: Reputation: 30
-------------------XFree86.0.log-----------


XFree86 Version 4.1.0.1 / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: 21 December 2001
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/FAQ)
Build Operating System: Linux 2.6.3-bk2 i686 [ELF]
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Fri Mar 26 00:41:07 2004
(==) Using config file: "/etc/X11/XF86Config-4"
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Generic Monitor"
(**) | |-->Device "Generic Video Card"
(**) |-->Input Device "Generic Keyboard"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc101"
(**) XKB: model: "pc101"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Configured Mouse"
(WW) The directory "/usr/lib/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/Speedo" does not exist.
Entry deleted from font path.
(**) FontPath set to "unix/:7110,/usr/lib/X11/fonts/misc,/usr/lib/X11/fonts/100dpi/:unscaled,/usr/lib/X11/fonts/75dpi/:unscaled,/usr/lib/X11/fonts/Type1,/usr/lib/X11/fonts/100dpi,/usr/lib/X11/fonts/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(++) using VT number 7

(WW) Cannot open APM
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.1
XFree86 Video Driver: 0.4
XFree86 XInput driver : 0.2
XFree86 Server Extension : 0.1
XFree86 Font Renderer : 0.2
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,1a30 card 0000,0000 rev 03 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 8086,1a31 card 0000,0000 rev 03 class 06,04,00 hdr 01
(II) PCI: 00:1e:0: chip 8086,244e card 0000,0000 rev 12 class 06,04,00 hdr 01
(II) PCI: 00:1f:0: chip 8086,2440 card 0000,0000 rev 12 class 06,01,00 hdr 80
(II) PCI: 00:1f:1: chip 8086,244b card 107b,3600 rev 12 class 01,01,80 hdr 00
(II) PCI: 00:1f:2: chip 8086,2442 card 107b,3600 rev 12 class 0c,03,00 hdr 00
(II) PCI: 00:1f:3: chip 8086,2443 card 107b,3600 rev 12 class 0c,05,00 hdr 00
(II) PCI: 00:1f:4: chip 8086,2444 card 107b,3600 rev 12 class 0c,03,00 hdr 00
(II) PCI: 00:1f:5: chip 8086,2445 card 107b,3600 rev 12 class 04,01,00 hdr 00
(II) PCI: 01:00:0: chip 10de,0171 card 1545,0039 rev a3 class 03,00,00 hdr 00
(II) PCI: 02:08:0: chip 8086,2449 card 8086,3013 rev 03 class 02,00,00 hdr 00
(II) PCI: 02:0a:0: chip 14e4,4212 card 14e4,0001 rev 00 class 07,03,00 hdr 00
(II) PCI: 02:0b:0: chip 1274,1371 card 1274,1371 rev 09 class 04,01,00 hdr 00
(II) PCI: End of PCI scan
(II) LoadModule: "scanpci"
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(II) UnloadModule: "scanpci"
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(II) Host-to-PCI bridge:
(II) PCI-to-ISA bridge:
(II) PCI-to-PCI bridge:
(II) PCI-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (-1,0,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x0a (VGA_EN is set)
(II) Bus 1 I/O range:
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xfc900000 - 0xfe9fffff (0x2100000) MX[B]
(II) Bus 1 prefetchable memory range:
[0] -1 0 0xe4500000 - 0xf46fffff (0x10200000) MX[B]
(II) Bus 2: bridge is at (0:30:0), (0,2,2), BCTRL: 0x02 (VGA_EN is cleared)
(II) Bus 2 I/O range:
[0] -1 0 0x0000d000 - 0x0000dfff (0x1000) IX[B]
(II) Bus 2 non-prefetchable memory range:
[0] -1 0 0xfea00000 - 0xfeafffff (0x100000) MX[B]
(II) Bus 2 prefetchable memory range:
[0] -1 0 0xf4700000 - 0xf47fffff (0x100000) MX[B]
(II) Bus -1: bridge is at (0:31:0), (0,-1,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus -1 I/O range:
(II) Bus -1 non-prefetchable memory range:
(II) Bus -1 prefetchable memory range:
(--) PCI:*(1:0:0) NVidia unknown chipset (0x0171) rev 163, Mem @ 0xfd000000/24, 0xe8000000/27, 0xf4680000/19, BIOS @ 0xfe9e0000/17
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) Active PCI resource ranges:
[0] -1 0 0xfeafe000 - 0xfeafefff (0x1000) MX[B]
[1] -1 0 0xfeaff000 - 0xfeafffff (0x1000) MX[B]
[2] -1 0 0xf8000000 - 0xfbffffff (0x4000000) MX[B]
[3] -1 0 0xfe9e0000 - 0xfe9fffff (0x20000) MX[B](B)
[4] -1 0 0xf4680000 - 0xf46fffff (0x80000) MX[B](B)
[5] -1 0 0xe8000000 - 0xefffffff (0x8000000) MX[B](B)
[6] -1 0 0xfd000000 - 0xfdffffff (0x1000000) MX[B](B)
[7] -1 0 0x0000de80 - 0x0000debf (0x40) IX[B]
[8] -1 0 0x0000df80 - 0x0000df8f (0x10) IX[B]
[9] -1 0 0x0000df00 - 0x0000df3f (0x40) IX[B]
[10] -1 0 0x0000ef00 - 0x0000ef3f (0x40) IX[B]
[11] -1 0 0x0000e800 - 0x0000e8ff (0x100) IX[B]
[12] -1 0 0x0000ef80 - 0x0000ef9f (0x20) IX[B]
[13] -1 0 0x0000efa0 - 0x0000efaf (0x10) IX[B]
[14] -1 0 0x0000ef40 - 0x0000ef5f (0x20) IX[B]
[15] -1 0 0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0 0xfeafe000 - 0xfeafefff (0x1000) MX[B]
[1] -1 0 0xfeaff000 - 0xfeafffff (0x1000) MX[B]
[2] -1 0 0xf8000000 - 0xfbffffff (0x4000000) MX[B]
[3] -1 0 0xfe9e0000 - 0xfe9fffff (0x20000) MX[B](B)
[4] -1 0 0xf4680000 - 0xf46fffff (0x80000) MX[B](B)
[5] -1 0 0xe8000000 - 0xefffffff (0x8000000) MX[B](B)
[6] -1 0 0xfd000000 - 0xfdffffff (0x1000000) MX[B](B)
[7] -1 0 0x0000de80 - 0x0000debf (0x40) IX[B]
[8] -1 0 0x0000df80 - 0x0000df8f (0x10) IX[B]
[9] -1 0 0x0000df00 - 0x0000df3f (0x40) IX[B]
[10] -1 0 0x0000ef00 - 0x0000ef3f (0x40) IX[B]
[11] -1 0 0x0000e800 - 0x0000e8ff (0x100) IX[B]
[12] -1 0 0x0000ef80 - 0x0000ef9f (0x20) IX[B]
[13] -1 0 0x0000efa0 - 0x0000efaf (0x10) IX[B]
[14] -1 0 0x0000ef40 - 0x0000ef5f (0x20) IX[B]
[15] -1 0 0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xfeafe000 - 0xfeafefff (0x1000) MX[B]
[6] -1 0 0xfeaff000 - 0xfeafffff (0x1000) MX[B]
[7] -1 0 0xf8000000 - 0xfbffffff (0x4000000) MX[B]
[8] -1 0 0xfe9e0000 - 0xfe9fffff (0x20000) MX[B](B)
[9] -1 0 0xf4680000 - 0xf46fffff (0x80000) MX[B](B)
[10] -1 0 0xe8000000 - 0xefffffff (0x8000000) MX[B](B)
[11] -1 0 0xfd000000 - 0xfdffffff (0x1000000) MX[B](B)
[12] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[13] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[14] -1 0 0x0000de80 - 0x0000debf (0x40) IX[B]
[15] -1 0 0x0000df80 - 0x0000df8f (0x10) IX[B]
[16] -1 0 0x0000df00 - 0x0000df3f (0x40) IX[B]
[17] -1 0 0x0000ef00 - 0x0000ef3f (0x40) IX[B]
[18] -1 0 0x0000e800 - 0x0000e8ff (0x100) IX[B]
[19] -1 0 0x0000ef80 - 0x0000ef9f (0x20) IX[B]
[20] -1 0 0x0000efa0 - 0x0000efaf (0x10) IX[B]
[21] -1 0 0x0000ef40 - 0x0000ef5f (0x20) IX[B]
[22] -1 0 0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) LoadModule: "bitmap"
(II) Reloading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Loading font Bitmap
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "dri"
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading sub module "drm"
(II) LoadModule: "drm"
(II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension XFree86-DRI
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.1.9
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.1
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Reloading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Loading extension GLX
(II) LoadModule: "int10"
(II) Loading /usr/X11R6/lib/modules/linux/libint10.a
(II) Module int10: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "pex5"
(II) Loading /usr/X11R6/lib/modules/extensions/libpex5.a
(II) Module pex5: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension X3D-PEX
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.13.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension RECORD
(II) LoadModule: "speedo"
(II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
(II) Module speedo: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Speedo
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "vbe"
(II) Loading /usr/X11R6/lib/modules/libvbe.a
(II) Module vbe: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "xie"
(II) Loading /usr/X11R6/lib/modules/extensions/libxie.a
(II) Module xie: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension XIE
(II) LoadModule: "nv"
(II) Loading /usr/X11R6/lib/modules/drivers/nv_drv.o
(II) Module nv: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.1
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.2
(II) NV: driver for NVIDIA chipsets: RIVA128, RIVATNT, RIVATNT2,
RIVATNT2 (A), RIVATNT2 (B), RIVATNT2 (Ultra), RIVATNT2 (Vanta),
RIVATNT2 M64, RIVATNT2 (Integrated), GeForce 256, GeForce DDR,
Quadro, GeForce2 GTS, GeForce2 GTS (rev 1), GeForce2 ultra,
Quadro 2 Pro, GeForce2 MX, GeForce2 MX DDR, Quadro 2 MXR,
GeForce 2 Go, GeForce3, GeForce3 (rev 1), GeForce3 (rev 2),
GeForce3 (rev 3)
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(EE) No devices detected.

Fatal server error:
no screens found
 
Old 03-26-2004, 02:09 AM   #5
Qucho
Member
 
Registered: Mar 2004
Location: Colorado, US
Distribution: Debian "Sarge"
Posts: 228

Original Poster
Rep: Reputation: 30
--------- kdm.log -----------


XFree86 Version 4.1.0.1 / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: 21 December 2001
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/FAQ)
Build Operating System: Linux 2.6.3-bk2 i686 [ELF]
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Fri Mar 26 00:41:07 2004
(==) Using config file: "/etc/X11/XF86Config-4"
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Generic Monitor"
(**) | |-->Device "Generic Video Card"
(**) |-->Input Device "Generic Keyboard"
(**) XKB: rules: "xfree86"
(**) XKB: model: "pc101"
(**) XKB: layout: "us"
(**) |-->Input Device "Configured Mouse"
(WW) The directory "/usr/lib/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/Speedo" does not exist.
Entry deleted from font path.
(**) FontPath set to "unix/:7110,/usr/lib/X11/fonts/misc,/usr/lib/X11/fonts/100dpi/:unscaled,/usr/lib/X11/fonts/75dpi/:unscaled,/usr/lib/X11/fonts/Type1,/usr/lib/X11/fonts/100dpi,/usr/lib/X11/fonts/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(++) using VT number 7

(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.1.0
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.1.0
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(--) PCI:*(1:0:0) NVidia unknown chipset (0x0171) rev 163, Mem @ 0xfd000000/24, 0xe8000000/27, 0xf4680000/19, BIOS @ 0xfe9e0000/17
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.1.9
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/linux/libint10.a
(II) Module int10: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/libpex5.a
(II) Module pex5: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.13.0
(II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
(II) Module speedo: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/libvbe.a
(II) Module vbe: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/extensions/libxie.a
(II) Module xie: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) Loading /usr/X11R6/lib/modules/drivers/nv_drv.o
(II) Module nv: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.1
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
(II) NV: driver for NVIDIA chipsets: RIVA128, RIVATNT, RIVATNT2,
RIVATNT2 (A), RIVATNT2 (B), RIVATNT2 (Ultra), RIVATNT2 (Vanta),
RIVATNT2 M64, RIVATNT2 (Integrated), GeForce 256, GeForce DDR,
Quadro, GeForce2 GTS, GeForce2 GTS (rev 1), GeForce2 ultra,
Quadro 2 Pro, GeForce2 MX, GeForce2 MX DDR, Quadro 2 MXR,
GeForce 2 Go, GeForce3, GeForce3 (rev 1), GeForce3 (rev 2),
GeForce3 (rev 3)
(--) Assigning device section with no busID to primary device
(EE) No devices detected.

Fatal server error:
no screens found
 
Old 03-26-2004, 03:53 AM   #6
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
That is really strange. Confirm this is a GForce 2 card. I have the same card and have never had a problem. Basically the error is that it cannot identify the card. Perhaps you need to incorporate more support. Do modconf and insert apgart and nvidia agp support modules.
 
Old 03-26-2004, 06:59 AM   #7
angustia
Member
 
Registered: Apr 2003
Location: chile
Posts: 58

Rep: Reputation: 15
use dpkg-reconfigure xserver-xfree86
use driver nv
if doesn't work, in the XFree86Config try these:

- deleting the depth 1 4 15 from Screen section
- $ lspci # look for pci number of the radeon an put in Device section:
BusID "PCI:XX:XX:XX" or use dpk-reconfigure xserver-xfree86.

i recommend to setup the X with nv driver before download from nvidia
 
Old 03-26-2004, 07:08 AM   #8
angustia
Member
 
Registered: Apr 2003
Location: chile
Posts: 58

Rep: Reputation: 15
for the kernel :
apt-get kernel-headers-2.4.18-bf2.4
then in /usr/src make a "ln -s kernel-headers-2.4.18-bf2.4 linux" and then recompile the drivers (they look for /usr/src/linux/includes directory), else try NVIDIA-Linux......pkg.run -A and use the option --Kernel-source-path=/usr/src/linux
 
Old 03-26-2004, 02:30 PM   #9
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,584

Rep: Reputation: 94
Re: XFree86 error (no screens found)

Quote:
Originally posted by Qucho
I am using Debian Woody. Kernel ver 2.4.18-bf2.4
My vid card is nVida GForce MMX 440
Optical USB Logitech mouse


is the meaning of this error that the X server can't 'see' my vid card, or is a mouse/keyboard issue ?


That card is unsupported by the nv driver in xfree86 4.1 which is included in Woody.

Quote:
Do I have to install new nVidia drivers to solve it? if so, what version of the drivers should I get (Linux IA32 or Linux IA64)?

Trying to install the 'Linux IA32' drivers the installation program was unable to find the kernel-source files.

I used dselect to install the source files.

dselect will not list the kernel version I have installed by default in bf24 debian installation (Kernel ver 2.4.18-bf2.4).

I have installed the kernel-source-2.4.18 (notice is NOT bf2.4), and nvidia driver inslation program still complains about not finding the source files.
You need the IA32 version and installing the kernel source is not enough you need either a fully configured source tree for your running kernel or the kernel headers for said kernel. Try this since you have the source already, go here and look at the guide to compiling the kernel the Debian way. When you start to compile use the /boot/config-2.4.18-bf2.4 as an imported config (the option is near the bottom in the opening screen) in menuconfig just import from another file then quit the menuconfig saying yes to save the config. Then you would fakeroot make-kpkg clean and fakeroot make-kpkg kernel_image kernel_headers to compile both the kernel headers and a kernel image. Then you would change up a directory to the /usr/src (assuming you compiled in the /usr/src/linux having made the proper symbolic link) and use dpkg -i kernel_image......deb kernel_headers.....deb say no to making the boot floppy and yes to use your existing LILO now reboot and choose the new kernel from the lilo menu (should be Linux not LinuxOLD) once booted to the command line /etc/init.d/kdm stop stop kdm if it is running change to gdm or xdm if you are using these. Now you have to run the Nvidia installer you should decline the offer to get a precompiled version and say yes to compile your own let it do it's job and compile then install module. In the /etc/X11XF86Config-4 file change these sections.

Code:
Section "Module"
#       Load  "GLcore"    <-- Comment out
#       Load  "dri"          <-- Comment out
        Load  "ddc"
        Load  "int10"
        Load  "bitmap"
        Load  "dbe"
        Load  "vbe"
        Load  "extmod"
        Load  "glx"           <-- Add if not present 
        Load  "record"
        Load  "xtrap"
        Load  "speedo"
        Load  "freetype"
        Load  "type1"
EndSection
Code:
Section "Device"
        Identifier  "Card0"
        Driver      "nvidia"           <-- Changed from nv to nvidia
        Option      "NoLogo" "on"   <-- Gets rid of the Nvidia logo
        Option      "NvAgp"  "1"    <-- Sometimes necessary to make it use the nvidia agpgart
        Option      "RenderAccel" "On"  <--  Turns on 2D acceleration
        Option      "NoBandWidthTest" "1"  <-- Stops the bandwidth test every time you start X
        VendorName  "nVidia Corporation"
        BoardName   "NV17 [GeForce4 MX 440-SE]"
        BusID       "PCI:1:0:0"
EndSection
Then in the /etc/modutils/aliases file you need to add this line near the bottom of the file.
Code:
# Added by me for Nvidia card

alias char-major-195 nvidia
Then you have to run update-modules as root to have the new information entered into the /etc/modules.conf for use on the next boot which you may as well do now to try the changes made.


Quote:
P.S. I have trying to fix this for the last 7 days. <desperated>

[edit]

Can this be due to font files and dirs misconfigured?

I added these lines to XF86Config-4 as indicated in the Debian installation procces:

FontPath: /va/lib/defoma/x-ttcidfont-conf.d/dirs/CID
FontPath: /va/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType

I noticed these two dirs are empty.
I also modified the font server port as instructed by Debian config.
I believe that actually installing some truetype fonts maybe the ttf-bitstream-vera or msttcorefonts packages should take care of that problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xserver xfree86 no screens found libglcore libspeedo _tomMmy_ Linux - Software 0 09-09-2004 04:18 PM
no screens found...error abhay7182 Linux - Hardware 2 08-20-2004 07:50 AM
no screens found, XFree86 with nvidia and 17" gateway monitor nbn792 Linux - Software 6 01-10-2004 01:37 AM
NO SCREENS FOUND while starting XFree86 with S3 vid card nbn792 Linux - Hardware 2 12-29-2003 10:23 PM
XFree86: "Fatal server error: no screens found" warkrime Linux - Newbie 9 09-23-2003 07:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration