LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   XFree86 4.2.1 screw up (https://www.linuxquestions.org/questions/linux-newbie-8/xfree86-4-2-1-screw-up-38510/)

Oppy 12-16-2002 10:41 AM

XFree86 4.2.1 screw up
 
I was updating from XFree86 4.2.0 to 4.2.1 on my SuSE 8.0 distribution. I thought that all the need files were saved away but after the update I lost the KDE login screen (console style login appears) and I need to manually start X windows (startx). How do I reenable the graphical login? Also the logout does not log out to the system login prompt but rather to the console prompt. I assume all this is connected. Any ideas as to the fix?

Thanks,

Oppy

trickykid 12-16-2002 10:44 AM

Make sure your runlevel specified at boot time is set to 5 instead of 3 in your /etc/inittab file.

Oppy 12-16-2002 01:27 PM

I checked the inittab and it seems to be set correctly. Here is the line.

# The default runlevel is defined here
id:5:initdefault:


I think that's correct.

Any other ideas?

Thanks

Oppy

crashmeister 12-16-2002 02:11 PM

This might be a long shot but xfree-4.2.1 has or had some trouble with kde-3.1.x fonts when you compile it.

Oppy 12-16-2002 04:14 PM

I am using 3.0.5 (most of the files are 3.0.4). Are there any 3.1 fonts in 3.0.5?

Thanks,

Oppy

crashmeister 12-16-2002 04:20 PM

Nah - that shouldn't be a problem.There is a thread at http://gentoo.org under forum-desktop that covers the whole malaise.You should be ok there though.

Oppy 12-16-2002 06:23 PM

Here is another another possible hint. When the xdm login screen should show up, the screen jumps and then the regular console prompt shows up. It strikes me that xdm is not starting. Is there a way to force xdm to start. As an aside putting startx in .login causes X windows and KDE to start properly but the graphical login and exit are still not working.

Does anyone have a cure?

Thanks,

Oppy


All times are GMT -5. The time now is 06:28 AM.