LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-30-2017, 05:10 PM   #1
CoureurDesBois
LQ Newbie
 
Registered: Mar 2017
Posts: 5

Rep: Reputation: Disabled
xfce trisquel


Hello I have recently installed trisquel and I can't install xfce4 when I start the installation with sudo apt-get install xfce4 I get this:
Code:
Des erreurs ont été rencontrées pendant l'exécution*:
 /var/cache/apt/archives/xfce4-session_4.12.1-1ubuntu1~14.04_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
I'm still not used to linux so if somebody could help me I would be gratefull. Thanks in advance.
 
Old 03-30-2017, 06:21 PM   #2
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,277
Blog Entries: 3

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Hi...

Could you please post the entire output from the initial command to the last lines you showed above? It might give us more to go on.

I did find this page, which might give you a rough model to go on in resolving this error.

Regards...
 
Old 03-30-2017, 07:44 PM   #3
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Quote:
Originally Posted by CoureurDesBois View Post
Hello I have recently installed trisquel and I can't install xfce4 when I start the installation with sudo apt-get install xfce4 I get this:
Code:
Des erreurs ont été rencontrées pendant l'exécution*:
 /var/cache/apt/archives/xfce4-session_4.12.1-1ubuntu1~14.04_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
I'm still not used to linux so if somebody could help me I would be gratefull. Thanks in advance.
Download the pkg and use dpkg -i <name of pkg> to install it:-

http://packages.ubuntu.com/precise/x11/xfce4

Here's the .deb pkg:-
https://packages.debian.org/jessie/xfce4

-::::-Both pkg's will work because Trisquel is based on Debian and Ubuntu.-::::-
 
Old 03-31-2017, 01:52 AM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,393
Blog Entries: 10

Rep: Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212
Quote:
Originally Posted by Ztcoracat View Post
Download the pkg and use dpkg -i <name of pkg> to install it:-
wouldn't it be better to first find out WHY there's an error?
also, apt-get says that dpkg caused the error in the first place.

CoureurDesBois, better use the '--simulate' switch and show us the output, i.e.
Code:
sudo dpkg --simulate -i <nameofpackage>
 
Old 03-31-2017, 06:17 AM   #5
CoureurDesBois
LQ Newbie
 
Registered: Mar 2017
Posts: 5

Original Poster
Rep: Reputation: Disabled
Here is the full output I'm going to try to download the pkg
Code:
vincent@vincent-desktop:~$ sudo apt-get install xfce4
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés*: 
  exo-utils gtk2-engines-xfce libexo-1-0 libexo-common libexo-helpers libfs6
  libgarcon-1-0 libgarcon-common libkeybinder0 libthunarx-2-0 libtumbler-1-0
  libunique-1.0-0 libxfce4ui-utils libxfce4util7 orage thunar thunar-data
  thunar-volman tumbler tumbler-common x11-apps x11-session-utils
  x11-xfs-utils xfce4-appfinder xfce4-mixer xfce4-panel xfce4-session
  xfce4-settings xfce4-volumed xfdesktop4 xfdesktop4-data xinit xorg
Paquets suggérés*:
  sox thunar-archive-plugin thunar-media-tags-plugin tumbler-plugins-extra
  xfce4-goodies xfce4-power-manager gtk3-engines-xfce fortunes-mod xorg-docs
  xfonts-100dpi xfonts-75dpi
Paquets recommandés*:
  greybird-gtk-theme xubuntu-icon-theme
Les NOUVEAUX paquets suivants seront installés*:
  exo-utils gtk2-engines-xfce libexo-1-0 libexo-common libexo-helpers libfs6
  libgarcon-1-0 libgarcon-common libkeybinder0 libthunarx-2-0 libtumbler-1-0
  libunique-1.0-0 libxfce4ui-utils libxfce4util7 orage thunar thunar-data
  thunar-volman tumbler tumbler-common x11-apps x11-session-utils
  x11-xfs-utils xfce4 xfce4-appfinder xfce4-mixer xfce4-panel xfce4-session
  xfce4-settings xfce4-volumed xfdesktop4 xfdesktop4-data xinit xorg
0 mis à jour, 34 nouvellement installés, 0 à enlever et 651 non mis à jour.
Il est nécessaire de prendre 0 o/6 858 ko dans les archives.
Après cette opération, 35,7 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Extraction des modèles depuis les paquets*: 100%
Sélection du paquet libxfce4util7 précédemment désélectionné.
(Lecture de la base de données... 198339 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libxfce4util7_4.12.1-1~14.04_amd64.deb ...
Dépaquetage de libxfce4util7 (4.12.1-1~14.04) ...
Sélection du paquet libexo-common précédemment désélectionné.
Préparation du dépaquetage de .../libexo-common_0.10.6-1~14.04_all.deb ...
Dépaquetage de libexo-common (0.10.6-1~14.04) ...
Sélection du paquet libexo-helpers précédemment désélectionné.
Préparation du dépaquetage de .../libexo-helpers_0.10.6-1~14.04_amd64.deb ...
Dépaquetage de libexo-helpers (0.10.6-1~14.04) ...
Sélection du paquet libexo-1-0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libexo-1-0_0.10.6-1~14.04_amd64.deb ...
Dépaquetage de libexo-1-0:amd64 (0.10.6-1~14.04) ...
Sélection du paquet libfs6:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libfs6_2%3a1.0.5-1_amd64.deb ...
Dépaquetage de libfs6:amd64 (2:1.0.5-1) ...
Sélection du paquet libgarcon-common précédemment désélectionné.
Préparation du dépaquetage de .../libgarcon-common_0.4.0-1~14.04_all.deb ...
Dépaquetage de libgarcon-common (0.4.0-1~14.04) ...
Sélection du paquet libgarcon-1-0 précédemment désélectionné.
Préparation du dépaquetage de .../libgarcon-1-0_0.4.0-1~14.04_amd64.deb ...
Dépaquetage de libgarcon-1-0 (0.4.0-1~14.04) ...
Sélection du paquet thunar-data précédemment désélectionné.
Préparation du dépaquetage de .../thunar-data_1.6.10-1~14.04_all.deb ...
Dépaquetage de thunar-data (1.6.10-1~14.04) ...
Sélection du paquet libthunarx-2-0 précédemment désélectionné.
Préparation du dépaquetage de .../libthunarx-2-0_1.6.10-1~14.04_amd64.deb ...
Dépaquetage de libthunarx-2-0 (1.6.10-1~14.04) ...
Sélection du paquet libtumbler-1-0 précédemment désélectionné.
Préparation du dépaquetage de .../libtumbler-1-0_0.1.31-1~14.04_amd64.deb ...
Dépaquetage de libtumbler-1-0 (0.1.31-1~14.04) ...
Sélection du paquet exo-utils précédemment désélectionné.
Préparation du dépaquetage de .../exo-utils_0.10.6-1~14.04_amd64.deb ...
Dépaquetage de exo-utils (0.10.6-1~14.04) ...
Sélection du paquet xfce4-panel précédemment désélectionné.
Préparation du dépaquetage de .../xfce4-panel_4.12.0-0ubuntu1~14.04_amd64.deb ...
Dépaquetage de xfce4-panel (4.12.0-0ubuntu1~14.04) ...
Sélection du paquet xfce4-settings précédemment désélectionné.
Préparation du dépaquetage de .../xfce4-settings_4.12.0-0ubuntu1~14.04_amd64.deb ...
Dépaquetage de xfce4-settings (4.12.0-0ubuntu1~14.04) ...
Préparation du dépaquetage de .../xfce4-session_4.12.1-1ubuntu1~14.04_amd64.deb ...
Dépaquetage de xfce4-session (4.12.1-1ubuntu1~14.04) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/xfce4-session_4.12.1-1ubuntu1~14.04_amd64.deb (--unpack)*:
 tentative de remplacement de «*/etc/xdg/autostart/xscreensaver.desktop*», qui appartient aussi au paquet trisquel-desktop-common-data 7.0-15
dpkg-deb*: erreur*:*le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Sélection du paquet gtk2-engines-xfce précédemment désélectionné.
Préparation du dépaquetage de .../gtk2-engines-xfce_3.0.1-2_amd64.deb ...
Dépaquetage de gtk2-engines-xfce (3.0.1-2) ...
Sélection du paquet libkeybinder0 précédemment désélectionné.
Préparation du dépaquetage de .../libkeybinder0_0.3.0-2_amd64.deb ...
Dépaquetage de libkeybinder0 (0.3.0-2) ...
Sélection du paquet libunique-1.0-0 précédemment désélectionné.
Préparation du dépaquetage de .../libunique-1.0-0_1.1.6-4ubuntu2_amd64.deb ...
Dépaquetage de libunique-1.0-0 (1.1.6-4ubuntu2) ...
Sélection du paquet libxfce4ui-utils précédemment désélectionné.
Préparation du dépaquetage de .../libxfce4ui-utils_4.12.1-1~14.04_amd64.deb ...
Dépaquetage de libxfce4ui-utils (4.12.1-1~14.04) ...
Sélection du paquet orage précédemment désélectionné.
Préparation du dépaquetage de .../orage_4.10.0-2~14.04_amd64.deb ...
Dépaquetage de orage (4.10.0-2~14.04) ...
Sélection du paquet thunar précédemment désélectionné.
Préparation du dépaquetage de .../thunar_1.6.10-1~14.04_amd64.deb ...
Dépaquetage de thunar (1.6.10-1~14.04) ...
Sélection du paquet thunar-volman précédemment désélectionné.
Préparation du dépaquetage de .../thunar-volman_0.8.1-1~14.04_amd64.deb ...
Dépaquetage de thunar-volman (0.8.1-1~14.04) ...
Sélection du paquet tumbler-common précédemment désélectionné.
Préparation du dépaquetage de .../tumbler-common_0.1.31-1~14.04_all.deb ...
Dépaquetage de tumbler-common (0.1.31-1~14.04) ...
Sélection du paquet tumbler précédemment désélectionné.
Préparation du dépaquetage de .../tumbler_0.1.31-1~14.04_amd64.deb ...
Dépaquetage de tumbler (0.1.31-1~14.04) ...
Sélection du paquet x11-apps précédemment désélectionné.
Préparation du dépaquetage de .../x11-apps_7.7+2_amd64.deb ...
Dépaquetage de x11-apps (7.7+2) ...
Sélection du paquet x11-session-utils précédemment désélectionné.
Préparation du dépaquetage de .../x11-session-utils_7.7+1_amd64.deb ...
Dépaquetage de x11-session-utils (7.7+1) ...
Sélection du paquet x11-xfs-utils précédemment désélectionné.
Préparation du dépaquetage de .../x11-xfs-utils_7.7+1_amd64.deb ...
Dépaquetage de x11-xfs-utils (7.7+1) ...
Sélection du paquet xfdesktop4-data précédemment désélectionné.
Préparation du dépaquetage de .../xfdesktop4-data_4.12.2-1ubuntu1~14.04_all.deb ...
Dépaquetage de xfdesktop4-data (4.12.2-1ubuntu1~14.04) ...
Sélection du paquet xfdesktop4 précédemment désélectionné.
Préparation du dépaquetage de .../xfdesktop4_4.12.2-1ubuntu1~14.04_amd64.deb ...
Dépaquetage de xfdesktop4 (4.12.2-1ubuntu1~14.04) ...
Sélection du paquet xfce4-appfinder précédemment désélectionné.
Préparation du dépaquetage de .../xfce4-appfinder_4.12.0-1~14.04_amd64.deb ...
Dépaquetage de xfce4-appfinder (4.12.0-1~14.04) ...
Sélection du paquet xfce4-mixer précédemment désélectionné.
Préparation du dépaquetage de .../xfce4-mixer_1%3a4.11.0-1ubuntu2~14.04_amd64.deb ...
Dépaquetage de xfce4-mixer (1:4.11.0-1ubuntu2~14.04) ...
Sélection du paquet xfce4 précédemment désélectionné.
Préparation du dépaquetage de .../archives/xfce4_4.10.1_all.deb ...
Dépaquetage de xfce4 (4.10.1) ...
Sélection du paquet xfce4-volumed précédemment désélectionné.
Préparation du dépaquetage de .../xfce4-volumed_0.2.0-0ubuntu2~14.04_amd64.deb ...
Dépaquetage de xfce4-volumed (0.2.0-0ubuntu2~14.04) ...
Sélection du paquet xinit précédemment désélectionné.
Préparation du dépaquetage de .../xinit_1.3.2-1_amd64.deb ...
Dépaquetage de xinit (1.3.2-1) ...
Sélection du paquet xorg précédemment désélectionné.
Préparation du dépaquetage de .../xorg_1%3a7.7+1ubuntu8.1_amd64.deb ...
Dépaquetage de xorg (1:7.7+1ubuntu8.1) ...
Traitement des actions différées («*triggers*») pour hicolor-icon-theme (0.13-1)*...
Traitement des actions différées («*triggers*») pour man-db (2.6.7.1-1ubuntu1)*...
Traitement des actions différées («*triggers*») pour desktop-file-utils (0.22-1ubuntu1+7.0trisquel1)*...
Traitement des actions différées («*triggers*») pour gnome-menus (3.10.1-0ubuntu2+7.0trisquel8)*...
Traitement des actions différées («*triggers*») pour mime-support (3.54ubuntu1)*...
Traitement des actions différées («*triggers*») pour menu (2.1.46ubuntu1)*...
Des erreurs ont été rencontrées pendant l'exécution*:
 /var/cache/apt/archives/xfce4-session_4.12.1-1ubuntu1~14.04_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
Old 03-31-2017, 09:49 AM   #6
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,393
Blog Entries: 10

Rep: Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212
please prepend your commands with
Code:
LANG=C
could you also post the output requested in post #4.
 
Old 03-31-2017, 04:37 PM   #7
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
If I'm not mistaken this is french:

Code:
Des erreurs ont été rencontrées pendant l'exécution*:
Which means that errors where encountered during the execution.

Quote:
wouldn't it be better to first find out WHY there's an error?
Yes. I'm not entirely sure why dpkg is complaining.
-:::- I suspect it could be a 'followup error' from a 'previous failure'.-:::-

These cmds should reveal what's going on.

Code:
sudo dpkg --configure -a
sudo apt-get install -f
cat /etc/apt/sources.list
Knowing what repo's Trisquel is getting it's updates from will help:-

Maybe the server for the repo is down and <or> the sources list may have become misconfigured.

https://ubuntuforums.org/showthread.php?t=1642173
 
Old 03-31-2017, 04:52 PM   #8
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec and Dartmouth, Nova Scotia CANADA
Distribution: Arch
Posts: 1,253

Rep: Reputation: 467Reputation: 467Reputation: 467Reputation: 467Reputation: 467
Salut CoureurDesBois ...

The error seems to be here:

Code:
Dépaquetage de xfce4-session (4.12.1-1ubuntu1~14.04) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/xfce4-session_4.12.1-1ubuntu1~14.04_amd64.deb (--unpack)*:
 tentative de remplacement de «*/etc/xdg/autostart/xscreensaver.desktop*», qui appartient aussi au paquet trisquel-desktop-common-data 7.0-15
dpkg-deb*: erreur*:*le sous-processus coller a été tué par le signal (Relais brisé (pipe))
.. It is saying that the installation of the package xfce4-session is attempting to replace/overwrite a file:

Code:
/etc/xdg/autostart/xscreensaver.desktop
that is also required by the package:

Code:
trisquel-desktop-common-data 7.0-15
... perhaps this package needs to be removed before installation of xfce4 ?

Cheers / Bonne chance :-)

Last edited by Rickkkk; 03-31-2017 at 04:54 PM.
 
Old 04-01-2017, 01:30 AM   #9
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,393
Blog Entries: 10

Rep: Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212Reputation: 5212
Quote:
Originally Posted by Rickkkk View Post
Code:
trisquel-desktop-common-data 7.0-15
... perhaps this package needs to be removed before installation of xfce4 ?
i think you nailed it.
my french surely wasn't up to it.
 
Old 04-01-2017, 09:50 AM   #10
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec and Dartmouth, Nova Scotia CANADA
Distribution: Arch
Posts: 1,253

Rep: Reputation: 467Reputation: 467Reputation: 467Reputation: 467Reputation: 467
Quote:
Originally Posted by ondoho View Post
i think you nailed it.
my french surely wasn't up to it.
Thanks ondoho - hope it helps.

Cheers :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Kleopatra 2.1.1 on Trisquel 6.0 nuxxun Linux - Software 0 07-19-2013 08:44 AM
LXer: Trisquel to focus on LTS versions with Trisquel 6.0 release LXer Syndicated Linux News 0 03-14-2013 07:30 AM
LXer: Trisquel 5.5 Review LXer Syndicated Linux News 0 04-25-2012 04:30 AM
How to install a driver in trisquel jnetzel77 Linux - Newbie 1 10-10-2011 02:26 AM
Trisquel post installation pravlin Linux - Software 4 10-01-2009 06:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration