LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   XEmacs Install Issue (https://www.linuxquestions.org/questions/linux-newbie-8/xemacs-install-issue-728685/)

deibertine 05-26-2009 05:11 PM

XEmacs Install Issue
 
Hi there,
I'm running an install of xemacs on RHEL 4 64bit and ran into this issue when doing a ./configure --with-gcc (i've also used ./configure with not --with-gcc parameters, same error).

make[1]: Entering directory `/root/xemacs-21.4.22/man'
makeinfo -o ../info/cl.info cl.texi
make[1]: makeinfo: Command not found
make[1]: *** [../info/cl.info] Error 127
make[1]: Leaving directory `/root/xemacs-21.4.22/man'
make: *** [info] Error 2

I'm installing XEmacs:
xemacs-21.4.22.tar.gz

Kernel version:
Linux x4500-1 2.6.9-42.ELsmp #1 SMP Wed Jul 12 23:32:02 EDT 2006 x86_64 x86_64 x86_64 GNU/Linux

gcc:
gcc (GCC) 4.2.1

Please let me know if you have any advise to this issue or anything that I might be missing?

Thank you!
DB

Vookimedlo 05-27-2009 03:11 AM

It looks like 'makeinfo' command is missing. Try to install 'texinfo' package. It should contain it.

deibertine 05-27-2009 12:18 PM

Is there a 64bit version of texinfo package around for RHEL4?
Google cant seem to find one...
Thanks.

Vookimedlo 05-27-2009 03:03 PM

It's definitely available in your distribution repository.

And here is a proof: https://rhn.redhat.com/errata/RHSA-2006-0727.html

deibertine 05-27-2009 05:20 PM

Will it allow me to dload even though I dont have a RHEL subscription?

Vookimedlo 05-28-2009 01:43 AM

I don't use Redhat, but as far as I know you can't.

deibertine 05-28-2009 05:02 PM

I stumbled upon a 64bit texinfo and tried installing but got this error:
[admin@bofasrv1@ ~]# rpm -ivh texinfo-4.7-5.el4.2.ia64.rpm
warning: texinfo-4.7-5.el4.2.ia64.rpm: V3 DSA signature: NOKEY, key ID 1d1e034b
error: Failed dependencies:
libc.so.6.1()(64bit) is needed by texinfo-4.7-5.el4.2.ia64
libc.so.6.1(GLIBC_2.2)(64bit) is needed by texinfo-4.7-5.el4.2.ia64
libc.so.6.1(GLIBC_2.3)(64bit) is needed by texinfo-4.7-5.el4.2.ia64

Then I ran this:
[admin@bofasrv1@ ~]# rpm -i glibc-common-2.2.4-33.ia64.rpm
warning: glibc-common-2.2.4-33.ia64.rpm: V3 DSA signature: NOKEY, key ID db42a60e
error: Failed dependencies:
glibc > 2.2.4 conflicts with glibc-common-2.2.4-33.ia64
glibc-common <= 2.3.2-63 conflicts with tzdata-2006a-2.EL4.noarch

Please help.

Thanks.

deibertine 05-28-2009 05:08 PM

Ok, forget about xemacs...

Anyone successful on installing a 64bit version of emacs?
Tried googling it but they were mostly defaulting me to xemacs.


Please advise.

Thanks,
DB


All times are GMT -5. The time now is 01:28 PM.