Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 07-14-2003, 10:58 PM   #1
LQ Newbie
Registered: Jul 2003
Location: Knoxville
Distribution: Redhat 7
Posts: 1

Rep: Reputation: 0
Xconfigurator failing, need advice

The problem: Xconfigurator fails when I press OK after the PCI Probe screen. Errors out with: "Server doesn't exist, can't continue. tried to use .../../usr/X11R6/bin/XF86_Mach64"

Details: I think the problem, for one, is that Xconfigurator is detecting the wrong video card. I have a Dell desktop computer with a built-in Rage card. I don't use this card at all, instead I have installed a PCI NVIDIA GeForce2 card. Xconfigurator seems to be detecting the ATI Rage card. How can I stop this? How do I make Xconfigurator detect my NVIDIA PCI card instead?

System details: Dual boot Win2k/RH 7. 256MB Ram. 32mb PCI NVIDIA card. 350MHZ.

Another side note: When I attempt to run startx, I get "Fatal server error: no screens found" - Of course, I don't expect it to work since Xconfigurator keeps bombing on me.

Any help is greatly appreciated, I've been tooling with this system for about 6 hours straight. : eye strain :


Old 07-15-2003, 12:17 AM   #2
Senior Member
Registered: Mar 2003
Location: Pittsburgh, PA
Distribution: Gentoo / NetBSD
Posts: 1,251

Rep: Reputation: 45
is there some way to disable the built-in video card (either thru the bios or with an on-board jumper)?

also, another way to configure X is by executing XFree86 -configure

using this, X will try to detect settings as best as possible. Then you can test the server with that config or you can edit the config file by hand to the proper video card settings.

hope that helps,
Old 07-15-2003, 08:56 AM   #3
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
Install the drivers from nvidia (, follow the instructions and you should be allright (no autodetection needed).
Old 07-15-2003, 10:18 AM   #4
Registered: Jun 2003
Posts: 132

Rep: Reputation: 15
You will need to go into your BIOS and turn off the onboard video controller. How to do this will depend on your BIOS type, but if its an award-type bios (many are these days) there should be a menu entry for builtin devices. The other choice you have is to use lspci to get the PCI bus ID for the nvidia card and enter it into X's configuration by hand. In Section "Device" add

BusID "PCI:x:y:z" where x is the bus number, y is the device number, and z is the subid (usually 0). lspci prints this out as "x:y.z"
Old 07-16-2003, 12:52 AM   #5
Senior Member
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874Reputation: 874
Two video cards could be rough to work around. Ordinarilly you would use "XFree86 -configure" to generate your XF86Config(-4) file. But with two cards you're probably better off using "xf86cfg" and/or "xf86config" to do the configuration.

Of course NVidia has closed source drivers. Or so the rumor goes. So you'll need to download the appropriate binaries from or where ever they keep them. At least they supply drivers I guess.

Worst case scenario, you can try compiling from source the xserver from But I wouldn't want to try that. You can also get binaries from there, which is what I've done on my HP 533W that has one of those troublesome Intel 810/845G jobs. Which seems to ONLY be supported under 4.3.0 or better.

Version 4 of xfree is supposed to use the XF86Config-4 file, but depending on where you get yours, you should probably place your config file as XF86Config and XF86Config-4, just to be safe. In the appropriate directory of course. Most times that is /etc/X11/.

If you just want X, you can try the Vesa drivers. They're supposed to be generic ones that should work on most cards. Bearing in mind that you're probably not gonna get much better than 640x480 under that driver. And performance will probably be poor.

Read the documentation that comes with the drivers and version of X you have. And also google for your card and problems/fixes that others have tried. The i845G driver for my HP integrated card requires extra options to function normally.

#Under Section "Device"
Option "XaaNoSolidFillRect" "On"

That's for my card, so that when you leave X and come back you'll still see something. Not that it applies to your card, but just to let you know that there might be some tricks to get yours working and hopefully working right. google is your friend. Or more specifically

Also bear in mind that future releases might correct some/most of these quirks. So check with your distro to see that you're using the most current(tested/stable) versions of stuff before you start tossing things and giving up.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
eth1 failing on boot, IEEE firewire card driver failing, help jackuss_169 Linux - Laptop and Netbook 5 03-05-2005 07:34 AM
Where is Xconfigurator? xailer Linux - Newbie 11 11-21-2003 06:24 PM
LILO install failing, Boot failing, but Installation fine. sramelyk Slackware 9 08-23-2003 02:37 PM
X failing to load; AddScreen/InitScreen failing for driver 0 weblion Linux - Software 1 08-01-2002 06:14 AM
Xconfigurator count_nikon Linux - Software 6 11-28-2001 02:53 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:54 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration