-   Linux - Newbie (
-   -   Xauth will not unlock a file at /home/username (

javpra 04-25-2004 01:46 PM

Xauth will not lock a file at /home/username
Good day to all,

I've been having an xauth problem. I recently installed slackware 9.1 and am running a Gnome 2.4.0. I just added a regular user account which for some reason defaulted to a home directory of "/" rather than "/home/username". When I attempt to run "startx" as this user I recieve an error saying "xauth: timeout in locking authority file //.Xauthority". I attempted "xauth merge ~user/.Xauthority" and am still not able to start X. I also recieved an error from Gnome saying it could not create a file in "/home/username". I attempted "useradd -d /home/username username" and it said "user already exists". I tried "useradd -D -b /home/username username" and still didn't work. I also used tried usermod and could not get the home directory transferred to /home/username. I am sure it is something I am doing any light on the situation would be appreciated. Would the home directory even be the cause for the xauth error? If this is the incorrect thread please advise me where a more appropriate place to post is.

Thanx in advance.

jailbait 04-26-2004 01:57 PM

I suggest that you use the userdel command to get rid of the problem user name. Then try to add it again. If worse comes to worse you can try again with a different user name (sorry Pete, you have to log in as Cinderella).

Be prepared. Create a LifeBoat CD.

Steve Stites

dkitt10 05-16-2004 10:52 AM

I know this was from a while ago but in case any one needs help do this (I just solved mine)

as root and using a username called dan for example:

cd .. (make sure ur in the very first folder)
cd etc (goes to etc)
vi passwd (edits passwd)

scroll down to dan and make sure its /home/dan
type ':' then wq too write and quit if you didn't change anything then just 'q'

and lastly and most importantly:

chown dan: /home/dan


Vincent_Vega 09-08-2004 07:36 PM

dkitt10 - thanks for posting that solution! I just had this problem, tried some stuff and thought the 'chown' just couldn't help me - but it did!!

Now, what the hell caused that??? Anyone have a clue?

All times are GMT -5. The time now is 10:39 PM.