LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Xandros, Suse installation/boot problems (https://www.linuxquestions.org/questions/linux-newbie-8/xandros-suse-installation-boot-problems-292324/)

Hokum 02-19-2005 01:47 PM

Xandros, Suse installation/boot problems
 
Hi,

First off, I'm a complete Linux newbie, so any instructions I get are going to have to be as simple as possible, sorry. :(

I've got the following hardware in my system:

Athlon 64 3200+
MSI K8T Neo mobo
Hercules 9800XT
Creative Audigy2
WD Raptor 74GB (primary disk, Windows XP, identified as SATA drive 1 on my Promise controller)
Samsung 120GB SATA (also attached to the Promise controller, ID'd as drive 0)
Samsung 120GB SATA (for Linux, on the secondary VIA controller)

I've got two distros: Xandros 3.0 Deluxe and Suse 9.2 Pro.

I've had Suse up and running perfectly on another machine, although I'm still no closer to understanding what I'm doing with it.
I decided to give Xandros a try on my home PC, as I'd heard it was really simple to use. It installs fine, but when I reboot and select Xandros from the boot loader, it just hangs at 'Initializing Kernel'. During the installation procedure, Xandros insisted on placing the boot loader on my first Samsung HDD, the one I use for data storage, rather than my primary boot disk.
I tried again. This time, I manually selected the Primary WD Raptor for the boot loader. Rebooted and it went straight into Windows, no sign of the OS selection screen.

I was pretty annoyed by this point, so I thought I'd give Suse a go. When I installed Suse on my other system, it allowed me to change the order of the boot menu so that Windows was the default OS and at the top of the list. This time, it doesn't even show Windows in the list. I don't want to install Suse only to find I can't get back into Windows, and have to trash the whole system.

Does anyone have any clue what's going on here?

Thanks!

musicman_ace 02-20-2005 07:45 AM

Assuming you didn't destroy the windows load when you partitioned it, edit the grub config which is /boot/grub/menu.lst

Add a sections like the one found here.
http://www.gnu.org/software/grub/man...#DOS%2fWindows


Hokum 02-21-2005 03:17 PM

Thanks. I haven't tried the above suggestion yet.
I'm giving Xandros another go, because I prefer the idea of using a GUI to install programs rather than having to piss about with a command line. However...I'm having the same problem as before. I tried selecting Expert startup option and I can see all the code and hardware initialisation stuff going on in the background, then it halts. The line it halts at is something about "Kernel Panic Unable to Mount Root FS"


Huh?


All times are GMT -5. The time now is 05:21 PM.