LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-16-2008, 09:03 AM   #1
gianpiero1978
LQ Newbie
 
Registered: Jan 2008
Posts: 3

Rep: Reputation: 0
X11.Org installation


Hi,
how can I install X11.org? I have my beautiful shell
environment working fine, but now I want to add X11.org to
run graphics environment.
I found these files in the Cd-rom installation.

xorg-x11-apps-7.1-4.SEL5.i386.rpm
xorg-x11-drivers-7.1-4.1.SEL5.i386.rpm
xorg-x11-drv-acecad-1.1.0-2.1.i386.rpm
xorg-x11-drv-aiptek-1.0.1-2.i386.rpm
xorg-x11-drv-apm-1.1.1-2.1.i386.rpm
xorg-x11-drv-ark-0.6.0-2.1.i386.rpm
xorg-x11-drv-ast-0.81.0-3.i386.rpm
xorg-x11-drv-ati-6.6.3-3.2.SEL5.i386.rpm
xorg-x11-drv-calcomp-1.1.0-1.1.i386.rpm
xorg-x11-drv-chips-1.1.1-2.1.i386.rpm
xorg-x11-drv-cirrus-1.1.0-2.SEL5.i386.rpm
xorg-x11-drv-citron-2.2.0-1.1.i386.rpm
xorg-x11-drv-cyrix-1.1.0-4.i386.rpm
xorg-x11-drv-digitaledge-1.1.0-1.1.i386.rpm
xorg-x11-drv-dmc-1.1.0-2.i386.rpm
xorg-x11-drv-dummy-0.2.0-2.1.i386.rpm
xorg-x11-drv-dynapro-1.1.0-2.i386.rpm
xorg-x11-drv-elo2300-1.1.0-1.1.i386.rpm
xorg-x11-drv-elographics-1.1.0-1.1.i386.rpm
xorg-x11-drv-evdev-1.0.0.5-2.SEL5.i386.rpm
xorg-x11-drv-fbdev-0.3.0-2.i386.rpm
xorg-x11-drv-fpit-1.1.0-1.1.i386.rpm
xorg-x11-drv-glint-1.1.1-4.1.i386.rpm
xorg-x11-drv-hyperpen-1.1.0-2.i386.rpm
xorg-x11-drv-i128-1.2.0-4.i386.rpm
xorg-x11-drv-i740-1.1.0-2.1.i386.rpm
xorg-x11-drv-i810-1.6.5-9.2.SEL5.i386.rpm
xorg-x11-drv-i810-devel-1.6.5-9.2.SEL5.i386.rpm
xorg-x11-drv-jamstudio-1.1.0-1.1.i386.rpm
xorg-x11-drv-joystick-1.1.0-1.1.i386.rpm
xorg-x11-drv-keyboard-1.1.0-2.1.i386.rpm
xorg-x11-drv-magellan-1.1.0-1.1.i386.rpm
xorg-x11-drv-magictouch-1.0.0.5-2.1.i386.rpm
xorg-x11-drv-mga-1.4.2-5.SEL5.i386.rpm
xorg-x11-drv-microtouch-1.1.0-1.1.i386.rpm
xorg-x11-drv-mouse-1.1.1-1.1.i386.rpm
xorg-x11-drv-mutouch-1.1.0-2.i386.rpm
xorg-x11-drv-neomagic-1.1.1-2.1.i386.rpm
xorg-x11-drv-nsc-2.8.1-2.1.i386.rpm
xorg-x11-drv-nv-1.2.0-4.SEL5.i386.rpm
xorg-x11-drv-palmax-1.1.0-1.1.i386.rpm
xorg-x11-drv-penmount-1.1.0-2.1.i386.rpm
xorg-x11-drv-rendition-4.1.0-3.1.i386.rpm
xorg-x11-drv-s3-0.4.1-2.1.i386.rpm
xorg-x11-drv-s3virge-1.9.1-2.1.i386.rpm
xorg-x11-drv-savage-2.1.1-5.SEL5.i386.rpm
xorg-x11-drv-siliconmotion-1.4.1-2.1.i386.rpm
xorg-x11-drv-sis-0.9.1-7.i386.rpm
xorg-x11-drv-sisusb-0.8.1-4.1.i386.rpm
xorg-x11-drv-spaceorb-1.1.0-1.1.i386.rpm
xorg-x11-drv-summa-1.1.0-1.1.i386.rpm
xorg-x11-drv-tdfx-1.2.1-3.1.i386.rpm
xorg-x11-drv-tek4957-1.1.0-1.1.i386.rpm
xorg-x11-drv-trident-1.2.1-3.SEL5.i386.rpm
xorg-x11-drv-tseng-1.1.0-3.1.i386.rpm
xorg-x11-drv-ur98-1.1.0-1.1.i386.rpm
xorg-x11-drv-v4l-0.1.1-4.i386.rpm
xorg-x11-drv-vesa-1.2.1-5.2.SEL5.i386.rpm
xorg-x11-drv-vga-4.1.0-2.1.i386.rpm
xorg-x11-drv-via-0.2.1-9.i386.rpm
xorg-x11-drv-via-devel-0.2.1-9.i386.rpm
xorg-x11-drv-vmmouse-12.4.0-2.1.i386.rpm
xorg-x11-drv-vmware-10.13.0-2.1.i386.rpm
xorg-x11-drv-void-1.1.0-3.1.i386.rpm
xorg-x11-drv-voodoo-1.1.0-3.1.i386.rpm
xorg-x11-filesystem-7.1-2.SEL5.noarch.rpm
xorg-x11-fonts-100dpi-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-75dpi-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-base-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-cyrillic-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-ethiopic-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-ISO8859-1-100dpi-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-ISO8859-14-100dpi-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-ISO8859-14-75dpi-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-ISO8859-15-100dpi-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-ISO8859-15-75dpi-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-ISO8859-1-75dpi-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-ISO8859-2-100dpi-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-ISO8859-2-75dpi-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-ISO8859-9-100dpi-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-ISO8859-9-75dpi-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-misc-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-syriac-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-truetype-7.1-2.1.SEL5.noarch.rpm
xorg-x11-fonts-Type1-7.1-2.1.SEL5.noarch.rpm
xorg-x11-font-utils-7.1-2.i386.rpm
xorg-x11-proto-devel-7.1-9.SEL5.i386.rpm
xorg-x11-resutils-7.1-2.SEL5.i386.rpm
xorg-x11-server-sdk-1.1.1-48.13.SEL5.i386.rpm
xorg-x11-server-utils-7.1-4.SEL5.i386.rpm
xorg-x11-server-Xdmx-1.1.1-48.13.SEL5.i386.rpm
xorg-x11-server-Xephyr-1.1.1-48.13.SEL5.i386.rpm
xorg-x11-server-Xnest-1.1.1-48.13.SEL5.i386.rpm
xorg-x11-server-Xorg-1.1.1-48.13.SEL5.i386.rpm
xorg-x11-server-Xvfb-1.1.1-48.13.SEL5.i386.rpm
xorg-x11-twm-1.0.1-3.1.i386.rpm
xorg-x11-util-macros-1.0.2-4.SEL5.i386.rpm
xorg-x11-utils-7.1-2.SEL5.i386.rpm
xorg-x11-xauth-1.0.1-2.1.i386.rpm
xorg-x11-xbitmaps-1.0.1-4.1.i386.rpm
xorg-x11-xfs-1.0.2-3.1.i386.rpm
xorg-x11-xfs-utils-1.0.2-3.1.i386.rpm
xorg-x11-xfwp-1.0.1-3.1.i386.rpm
xorg-x11-xinit-1.0.2-13.SEL5.i386.rpm
xorg-x11-xkb-utils-1.0.2-2.1.i386.rpm
xorg-x11-xsm-1.0.2-4.SEL5.i386.rpm
xorg-x11-xtrans-devel-1.0.1-1.1.SEL5.i386.rpm


If I try to install one of this, there are always dependencies
and I get the error:
error: Failed dependencies:
There is a way to install all packages in one shot? I'm going crazy...
 
Old 01-16-2008, 09:26 AM   #2
Uncle_Theodore
Member
 
Registered: Dec 2007
Location: Charleston WV, USA
Distribution: Slackware 12.2, Arch Linux Amd64
Posts: 896

Rep: Reputation: 69
What distribution are you running? Try using its package manager.
 
Old 01-16-2008, 09:53 AM   #3
gianpiero1978
LQ Newbie
 
Registered: Jan 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Uncle_Theodore View Post
What distribution are you running? Try using its package manager.
startcom

I tried to do so, but I had a similar problem:
error: Failed dependencies:



-bash-3.1# rpm -Uhv gnome-python2-2.16.0-1.SEL5.i386.rpm
warning: gnome-python2-2.16.0-1.SEL5.i386.rpm: Header V3 DSA signature: NOKEY, key ID 652e84dc
error: Failed dependencies:
gnome-python2-bonobo is needed by gnome-python2-2.16.0-1.SEL5.i386
gnome-python2-gnomevfs is needed by gnome-python2-2.16.0-1.SEL5.i386
libart_lgpl_2.so.2 is needed by gnome-python2-2.16.0-1.SEL5.i386
libbonobo-2.so.0 is needed by gnome-python2-2.16.0-1.SEL5.i386
libbonobo-activation.so.4 is needed by gnome-python2-2.16.0-1.SEL5.i386
libbonoboui-2.so.0 is needed by gnome-python2-2.16.0-1.SEL5.i386
libgnome-2.so.0 is needed by gnome-python2-2.16.0-1.SEL5.i386
libgnome-keyring.so.0 is needed by gnome-python2-2.16.0-1.SEL5.i386
libgnomecanvas-2.so.0 is needed by gnome-python2-2.16.0-1.SEL5.i386
libgnomeui-2.so.0 is needed by gnome-python2-2.16.0-1.SEL5.i386
libgnomevfs-2.so.0 is needed by gnome-python2-2.16.0-1.SEL5.i386


-bash-3.1# rpm -Uhv gnome-python2-bonobo-2.16.0-1.SEL5.i386.rpm
warning: gnome-python2-bonobo-2.16.0-1.SEL5.i386.rpm: Header V3 DSA signature: NOKEY, key ID 652e84dc
error: Failed dependencies:
bonobo-activation >= 1.0.0 is needed by gnome-python2-bonobo-2.16.0-1.SEL5.i386
gnome-python2 = 2.16.0-1.SEL5 is needed by gnome-python2-bonobo-2.16.0-1.SEL5.i386
libart_lgpl_2.so.2 is needed by gnome-python2-bonobo-2.16.0-1.SEL5.i386
libbonobo >= 2.0.0 is needed by gnome-python2-bonobo-2.16.0-1.SEL5.i386
libbonobo-2.so.0 is needed by gnome-python2-bonobo-2.16.0-1.SEL5.i386
libbonobo-activation.so.4 is needed by gnome-python2-bonobo-2.16.0-1.SEL5.i386
libbonoboui >= 2.0.0 is needed by gnome-python2-bonobo-2.16.0-1.SEL5.i386
libbonoboui-2.so.0 is needed by gnome-python2-bonobo-2.16.0-1.SEL5.i386
libgnome-2.so.0 is needed by gnome-python2-bonobo-2.16.0-1.SEL5.i386
libgnomecanvas-2.so.0 is needed by gnome-python2-bonobo-2.16.0-1.SEL5.i386
libgnomevfs-2.so.0 is needed by gnome-python2-bonobo-2.16.0-1.SEL5.i386
pyorbit >= 2.0.l is needed by gnome-python2-bonobo-2.16.0-1.SEL5.i386



gnome-python2-2.16.0-1.SEL5.i386.rpm needs gnome-python2-bonobo-2.16.0-1.SEL5.i386.rpm but
gnome-python2-bonobo-2.16.0-1.SEL5.i386.rpm needs gnome-python2-2.16.0-1.SEL5.i386.rpm

How can break the loop?
There isn't an easy (possible) way to add/remove packages from linux installation?

Last edited by gianpiero1978; 01-16-2008 at 10:25 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
MSI-M520 lcd and X.org-X11 7.1.1 slackster Linux - Laptop and Netbook 3 02-28-2007 09:14 PM
Ubuntu graphical login/gnome/x11 wont work because of OpenOffice.org ? penguinman99 Ubuntu 3 12-18-2006 04:02 AM
Core 4 - X11-devel complains about X11-libs which are installed Ephracis Fedora 3 09-05-2005 10:32 AM
X11.org and Xfree86.org question caps_phisto Linux - General 1 11-16-2004 06:42 PM
Openoffice.org 1.1 installation arun79 Linux - Software 1 01-14-2004 06:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration