-   Linux - Newbie (
-   -   X11 display problem (

diver1 06-09-2009 02:05 PM

X11 display problem
Hello all:
I am trying to run Oracle installer (runInstaller) and do not seem to get it to run.
Below is the error message I receive.
Some more info below:

1. I CAN run xclock as myself but not as 'oracle' user!
I check my 'env' and tried to replicate the same but still as Oracle can't run xclock.

2. # xhost +
X connection to localhost:10.0 broken (explicit kill or server shutdown).

I have read and tried to follow instructions on several recommendations on several online boards and all have failed.

I am using 'xmanager' from my Windows Xp machine to connect to the Linux server which is also my DB server with Oracle.
Xmanager seem to be working fine but the Oracle installer does not
start. Can anyone help, please.


Starting Oracle Universal Installer...

Checking installer requirements...

Checking operating system version: must be redhat-3, SuSE-9, SuSE-10, redhat-4, redhat-5, UnitedLinux-1.0, asianux-1, asianux-2 or asianux-3

All installer requirements met.

Preparing to launch Oracle Universal Installer from /tmp/OraInstall2009-06-09_11-54-16AM. Please wait ...[oracle@findb1 Disk1]$ Oracle Universal Installer, Version Production
Copyright (C) 1999, 2008, Oracle. All rights reserved.

Can't connect to X11 window server using '' as the value of the DISPLAY variable.
OUI-10025:Unable to start an interactive install session because of the following error:Can't connect to X11 window server using '' as the value of the DISPLAY variable. The DISPLAY environment variable should be set to <hostname or IP address>:<screen>, where the <screen> is usually '0.0'.
OUI-10026:Depending on the Unix Shell, you can use one of the following commands as examples to set the DISPLAY environment variable:
- For csh: % setenv DISPLAY
- For sh, ksh and bash: $ DISPLAY=; export DISPLAY
Use the following command to see what shell is being used:
echo $SHELL
Use the following command to view the current DISPLAY environment variable setting:
- Make sure that client users are authorized to connect to the X Server.
OUI-10027:To enable client users to access the X Server, open an xterm, dtterm or xconsole as the user that started the session and type the following command:
% xhost +
To test that the DISPLAY environment variable is set correctly, run a X11 based program that comes with the native operating system such as 'xclock':
% <full path to xclock... see below>
If you are not able to run xclock successfully, please refer to your PC-X Server or OS vendor for further assistance.
Typical path for 'xclock': '/usr/X11R6/bin/xclock'


MensaWater 06-09-2009 03:59 PM

Are you logging in directly as the Oracle user when you try this or are you doing su (or sudo su) to the Oracle user after you login as yourself?

If you're doing su (or sudo su) after login that along with the localhost:10.0 DISPLAY suggests you're doing ssh X tunneling. If so xhost has no effect unless you change the DISPLAY variable to the name or IP of the workstation from which you're attempting to do this.

However, rather than doing that you can do the following:
1) Login as yourself.
2) Type "echo $DISPLAY" and save the value (presumably localhost:10.0).
3) Type "ls -l .Xauthority" to verify a file named .Xauthority exists. If so it should show permisssions -rw-------.
4) Type "chmod 644 .Xauthority" so permissions change to -rw-r--r--
5) Do your su or sudo su to the Oracle user.
6) Type "export DISPLAY=<value from step 2>"
7) Type "export XAUTHORITY=<homedirectory of YOUR account>/.Xauthority

Test it with xclock or xterm.

P.S. Step 4 is a bit of a security hole so should only be done temporarily for this install. When you log out and log back in it should recreate .Xauthority with normal permissions.

All times are GMT -5. The time now is 12:03 PM.