LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-03-2002, 12:16 AM   #1
urinal cake
LQ Newbie
 
Registered: Feb 2002
Posts: 27

Rep: Reputation: 15
X won't start automatically


I compiled a custom 2.4.18, and set /etc/inittab go to runlevel 3, since my XF86Config-4 is uses my NVidia drivers, which weren't installed for the new kernel yet. All went well, and I installed the NVidias for the new kernel, then edited my /etc/inittab back to default to 5. The bootup messages say that it's entering runlevel 5, but it doesn't start X. X works fine when I 'startx'. Has level 5 been redefined somehow?? What else needs to be done to get X to start automatically?
 
Old 03-03-2002, 02:14 AM   #2
nikhiljosh
Member
 
Registered: Jun 2001
Posts: 126

Rep: Reputation: 16
hmm...
really interesting problem.
this may be a silly question but did you save ur changes ?
u must have since it iz saying it iz entering runlvl 5 . but chk it anywayz.
 
Old 03-03-2002, 06:52 AM   #3
urinal cake
LQ Newbie
 
Registered: Feb 2002
Posts: 27

Original Poster
Rep: Reputation: 15
Yes saved changes....

I'm pretty new at this, so I don't have a clue why changing inittab wouldn't do the trick. /shrug...
 
Old 03-04-2002, 09:09 PM   #4
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
IMO your better off leaving it at run level 3, that way it makes it easier to fix X problems.
 
Old 03-07-2002, 02:39 AM   #5
bkeating
Member
 
Registered: Mar 2002
Location: San Francisco, CA
Distribution: Open/FreeBSD, Gentoo, SuSE
Posts: 511

Rep: Reputation: 38
Yea, It's best to keep things at level 3 when you first boot up. Your left with more options juse in case something goes wrong...

Ben
 
Old 03-08-2002, 05:54 PM   #6
Sylhouette
Member
 
Registered: Oct 2001
Location: Beverwijk (Holland
Distribution: Red Hat 7.1
Posts: 132

Rep: Reputation: 15
Try runlevel 4 it sounds stupid but i had the same !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I automatically start a program at start up? victordh Linux - General 7 10-27-2013 06:02 AM
Xhost - How to start it automatically? shazam75 Linux - Software 3 10-17-2004 08:29 AM
start apps automatically on start up? chunlee Linux - Newbie 3 09-04-2004 12:58 PM
How to start x0rfbserver automatically? fraglord Linux - Software 7 06-20-2003 01:51 PM
how to start NIS automatically? keirobyn Linux - Networking 1 01-18-2003 08:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration