LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-12-2003, 06:09 PM   #1
seriv
Member
 
Registered: Jul 2003
Location: Oak Ridge, TN
Distribution: red hat 9.0
Posts: 35

Rep: Reputation: 15
X won't start!!!!!!


I tried to start x by typing startx after I logged in and I got these error messages:

Could not init font path element unix/:7100, removing form list!

Fata Server Error:
Could not open default font 'fixed'

and


XIO: fatal IO error 104 (connection reset by peer) on X server ":0:0"
After 0 requests (0 known processed) with 0 events remaining


I was playing around with WINE and I installed Bochs, but it didn't work.

Please Help!!!!!!!!!!!!!
-Seriv
 
Old 10-12-2003, 11:19 PM   #2
teknomage1
LQ Newbie
 
Registered: Aug 2003
Posts: 17

Rep: Reputation: 0
make sure the xfs X font server is running
 
Old 10-13-2003, 11:05 AM   #3
seriv
Member
 
Registered: Jul 2003
Location: Oak Ridge, TN
Distribution: red hat 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
how do I do that?
 
Old 10-13-2003, 03:51 PM   #4
alm
Member
 
Registered: Mar 2003
Location: Sweden
Distribution: RedHat
Posts: 32

Rep: Reputation: 15
Type in

ps ax | grep xfs
 
Old 10-13-2003, 04:00 PM   #5
seriv
Member
 
Registered: Jul 2003
Location: Oak Ridge, TN
Distribution: red hat 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
I get the same errors.
 
Old 10-13-2003, 04:17 PM   #6
alm
Member
 
Registered: Mar 2003
Location: Sweden
Distribution: RedHat
Posts: 32

Rep: Reputation: 15
When I type in that command I get the output:

1396 ? S 0:08 xfs -droppriv -daemon

Check if you get something a like.
If you don't, then you don't have the xfs font server running.

/alm
 
Old 10-13-2003, 04:33 PM   #7
seriv
Member
 
Registered: Jul 2003
Location: Oak Ridge, TN
Distribution: red hat 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
sorry, i saw the startx error above it:
2583 ? S 0:00 [xfs]
3626 tty1 s 0:00 grep xfs
 
Old 10-13-2003, 05:13 PM   #8
alm
Member
 
Registered: Mar 2003
Location: Sweden
Distribution: RedHat
Posts: 32

Rep: Reputation: 15
So the xfs should be in order.

Try running this: "chkfontpath" and post its output
 
Old 10-13-2003, 06:53 PM   #9
seriv
Member
 
Registered: Jul 2003
Location: Oak Ridge, TN
Distribution: red hat 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
current directores in font path:
1: /usr/x11R6/lib/X11/fonts/misc:unscaled
2: /usr/x11R6/lib/X11/fonts/75dpi:unscaled
3: /usr/x11R6/lib/X11/fonts/100dpi:unscaled
4: /usr/x11R6/lib/X11/fonts/misc
5: /usr/x11R6/lib/X11/fonts/Type1
6: /usr/x11R6/lib/X11/fonts/speedo
7: /usr/x11R6/lib/X11/fonts/cyrillic
8: /usr/x11R6/lib/X11/fonts/TTF
9: /usr/x11R6/lib/X11/fonts/OTF
10: /usr/share/fonts/default/Type1
11:
12: /usr/lib/openoffice/share/fonts/truetype
13: /usr/share/fonts/ISO8859-2/misc:unscaled
14: /usr/share/fonts/ISO8859-2/75dpi:unscaled
15: /usr/share/fonts/ISO8859-2/100dpi:unscaled
16: /usr/share/fonts/ISO8859-2/misc
17: /usr/share/fonts/ISO8859-2/75dpi
18: /usr/share/fonts/ISO8859-2/100dpi
19: /usr/share/fonts/ja/misc:unscaled
20: /usr/share/fonts/ja/misc
21: /usr/share/fonts/KOI8-R/misc:unscaled
22: /usr/share/fonts/KOI8-R/75dpi:unscaled
23: /usr/share/fonts/KOI8-R/100dpi:unscaled
24: /usr/share/fonts/KOI8-R/misc
25: /usr/share/fonts/KOI8-R/75dpi
26: /usr/share/fonts/KOI8-R/100dpi

Hope this helps, I had to copy it out by hand!
-Seriv
 
Old 10-14-2003, 12:04 PM   #10
alm
Member
 
Registered: Mar 2003
Location: Sweden
Distribution: RedHat
Posts: 32

Rep: Reputation: 15
That is the similar to the output I get too. Maybe it is irrelevant (sorry) anyways....

Type "service xfs status" and see if you get the output
xfs (pid: <pid>) running...
 
Old 10-14-2003, 12:55 PM   #11
Nimoy
Member
 
Registered: Jun 2003
Location: Currently Denmark
Distribution: Ubuntu 11.10
Posts: 334

Rep: Reputation: 30
If you just want X up and don't care too much about the truetypes it should be possible to rem the following line in the X86config file.

# FontPath "unix/:7100"

You can find it in etc/X11

Here is a list of common tools for configuring X:
Redhat 7.3 down - the setup utility leads to several config tools
Redhat 7.3 up - redhat-config-xfree86

You might have one or more of these tools/files on your system:
XF86SetupTricks and hints
XFree86 -configure
Xconfigurator
xf86cfg
xf86config
xconf

The redhat-config-xfree86 might just be what you need to run in order to get things back to normal...
 
Old 10-14-2003, 09:31 PM   #12
seriv
Member
 
Registered: Jul 2003
Location: Oak Ridge, TN
Distribution: red hat 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
it says xfs (pid 2583) is running.....

and redhat-config-xfree86 crashes!!!!!!!!
 
Old 10-14-2003, 09:41 PM   #13
seriv
Member
 
Registered: Jul 2003
Location: Oak Ridge, TN
Distribution: red hat 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
thanx, removing unix:7100 worked
 
Old 10-15-2003, 01:59 PM   #14
Nimoy
Member
 
Registered: Jun 2003
Location: Currently Denmark
Distribution: Ubuntu 11.10
Posts: 334

Rep: Reputation: 30
Now try the config tools might put things back the way they ought to be!
 
Old 10-15-2003, 04:05 PM   #15
seriv
Member
 
Registered: Jul 2003
Location: Oak Ridge, TN
Distribution: red hat 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
Thanx, I will, and Thank you so much to all that helped me!!!!!!
-Seriv
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
when i try to start samba pdc's smb service nmbd failed to start . sandeepchau123 Linux - Newbie 2 10-20-2007 02:59 PM
disable cold start and warm start snmp traps chkisco Linux - Newbie 0 10-28-2005 03:58 AM
fc2-gnome : Applications dont start / very slow to start nox104 Linux - Software 0 08-18-2004 09:53 PM
Can I gett KPPP to start when I start a browser on a network machine? duffboygrim Linux - Networking 0 03-25-2004 05:49 PM
cannot start kdeas user ,can start icewm,fluxbox jackren Debian 1 03-01-2004 12:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration