LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   X starts but won't start gnome.... (https://www.linuxquestions.org/questions/linux-newbie-8/x-starts-but-wont-start-gnome-151929/)

lsmith 02-29-2004 03:38 PM

X starts but won't start gnome....
 
I used

XFree84 -configure

to generate a config file. The X server starts up, but it stays on the black and white checker screen with the X cursor idefinitely, without starting gnome up.

What could be the problem? The resolution should be fine for the monitor.

I have read the XF86Config file and it successfully identifies the Vanta card and the monitor.

Slackware 9.1
16MB Nvidia Vanta video card
Philips 109S monitor


Thanks in advance

Lindsay

synaptical 02-29-2004 03:45 PM

if gnome is installed (? well, maybe you forgot :p it happens) add

exec gnome-session

to the bottom of your ~/.xinitrc file and try to launch it again.

lsmith 02-29-2004 04:08 PM

gnome is definitely installed (but fair call in checking). Haven't read the .xinitrc file (will do when I get nome), but using the default XF86Config (Vesa driver) gnome does start. Its just the file that XFree created with the correct drivers that won't start gnome.....


synaptical 02-29-2004 04:18 PM

if gnome starts otherwise, it's not the ~/.xinitrc but most likely your video drivers or XF86Config. can any other desktops/wm start? sorry, i don't have experience with that vanta card, so other than saying double check your config or your drivers this one is beyond me. gl :)

lsmith 02-29-2004 04:24 PM

I think I'm going to have to try one of the ncurses setup tools for X and see if I can get a working file with the nvidia driver....


All times are GMT -5. The time now is 01:17 PM.