LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   X server won't start (https://www.linuxquestions.org/questions/linux-newbie-8/x-server-wont-start-372200/)

pappsynz 10-12-2005 06:25 AM

X server won't start
 
Hi there.

I have an install of RH Enterprise WS release 3 running 2.4.21. All is working nicely with this, however when I build a new 2.4.21 (or 2.4.31 for that matter) kernel and boot X refuses to start.

I should point out that X runs nicely on the install kernel. And that I am using the install's config for the build of the new kernel.

Unfortunately I haven't found too many clues either. I have an ATI Rage 128 graphics card, and have made sure the DRM driver is built it. I have compared the /var/log/XFree86.0.log files for the working X and the not working X and they are identical down to a point. The last message that I see on the not working X log is

Code:

Loading /usr/X11R6/lib/modules/libvbe.a
No error messages have been logged. In the X log from the working kernel it then goes on the a bunch of messages starting with

Code:

(II) ATI(0): VESA BIOS detected
(II) ATI(0): VESA VBE Version 2.0
(II) ATI(0): VESA VBE Total Mem: 8128 kB
(II) ATI(0): VESA VBE OEM: ATI MACH64
(II) ATI(0): VESA VBE OEM Software Rev: 1.0
(II) ATI(0): VESA VBE OEM Vendor: ATI Technologies Inc.
(II) ATI(0): VESA VBE OEM Product: MACH64GM
(II) ATI(0): VESA VBE OEM Product Rev: 01.00
(II) ATI(0): VESA VBE DDC supported
(II) ATI(0): VESA VBE DDC Level 2
(II) ATI(0): VESA VBE DDC transfer in appr. 2 sec.
(II) ATI(0): VESA VBE DDC read successfully
(II) ATI(0): Manufacturer: HWP  Model: 2601  Serial#: 926111544
(II) ATI(0): Year: 2004  Week: 38
(II) ATI(0): EDID Version: 1.3

etc...

Has anyone come across this problem before??

Pappsynz

b0nd 10-12-2005 07:50 AM

Hello,
post the o/p of
#cat /etc/X11/xorg.conf ( in slackware its the path....check out in RedHat )

regards

pappsynz 10-12-2005 07:58 AM

There is no /etc/X11/xorg.conf in the RH, but I'm pretty sure that XF86Config is the equivalent that you're looking for? So...

Here you go, its the whole thing so apologies for the size...

Code:

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
        Identifier    "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath    "unix/:7100"
EndSection

Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
        Load  "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#        Option        "Xleds"                "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#        Option        "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#        Option        "XkbModel"        "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#        Option        "XkbModel"        "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#        Option        "XkbLayout"        "de"
# or:
#        Option        "XkbLayout"        "de"
#        Option        "XkbVariant"        "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#        Option        "XkbOptions"        "ctrl:swapcaps"
# Or if you just want both to be control, use:
#        Option        "XkbOptions"        "ctrl:nocaps"
#
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option            "XkbRules" "xfree86"
        Option            "XkbModel" "pc105"
        Option            "XkbLayout" "gb"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option            "Protocol" "IMPS/2"
        Option            "Device" "/dev/psaux"
        Option            "ZAxisMapping" "4 5"
        Option            "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
        Identifier  "DevInputMice"
        Driver      "mouse"
        Option            "Protocol" "IMPS/2"
        Option            "Device" "/dev/input/mice"
        Option            "ZAxisMapping" "4 5"
        Option            "Emulate3Buttons" "no"
EndSection

Section "Monitor"
        Identifier  "Monitor0"
        VendorName  "Monitor Vendor"
        ModelName    "hp L1702"
        DisplaySize  330        270
        HorizSync    30.0 - 81.0
        VertRefresh  56.0 - 76.0
        Option            "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "ati"
        VendorName  "Videocard vendor"
        BoardName  "ATI Mach64"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth    24
        SubSection "Display"
                Depth    24
                Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "DRI"
        Group        0
        Mode        0666
EndSection


b0nd 10-12-2005 09:53 AM

wat is yr monitors size.........15 inches or 17

regards

pappsynz 10-12-2005 10:12 AM

I've got a 17 inch LCD HP1702

b0nd 10-13-2005 01:45 AM

Quote:

Originally posted by pappsynz
I've got a 17 inch LCD HP1702
***********************************
Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "hp L1702"
DisplaySize 330 270
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 76.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "ati"
VendorName "Videocard vendor"
BoardName "ATI Mach64"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
****************************************

Hello,
i dont know how much helpful it may be..........but lets see.

make the following changes
HorizSync 30.0 -54.0
VertRefresh 54.0 - 120.0

reduce the resolution......
Modes "1024x768" "800x600" "640x480"

try it.....lets see then

regards

ciotog 10-13-2005 02:06 AM

Before adjusting the HorizSync and VertRefresh ranges (which are correct in your original configuration), have you tried rebuilding the ATI driver? I use an nVidia graphics card, and the driver has to be rebuilt every time I compile a new kernel.

pappsynz 10-13-2005 04:44 AM

Hi,

I imagine that the driver was rebuilt when I first built the new kernel from source?

Ok, I've just rebuilt the ATI r128 driver and I still have the same issue?

ciotog 10-13-2005 11:17 AM

What does X write to the console when you try to start it?

pappsynz 10-13-2005 11:23 AM

X wasn't actually writing anything to the console, it was showing me the log that it had produced (which just told me where to find XF86Conf) and tried to run the X Configuration utility again.

I have just now cut my loses and installed RH Fedora Core 1. And I am pleased to say that I have built my own 2.4.22 kernel and all has booted wonderfully. X server has also started with no hiccups.

I am a little disappointed that I was unable to work this out, but I guess it points to finger at the RHEL distro that I had?

Thanks for all your help by the way guys!

Pappsynz.


All times are GMT -5. The time now is 12:43 PM.