LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-17-2005, 01:48 PM   #1
Circuit Monkey
LQ Newbie
 
Registered: Mar 2005
Distribution: knoppix installed on harddisk
Posts: 27

Rep: Reputation: 15
X Server wont run


Upon starting my freshly installed Debian, I recieve the following error...

I cannot start the X server (your graphical
interface). It is likely that it is not set
up correctly. Would you like to view the X
server output to diagnose the problem?

<Yes> <No>



Upon entering "Yes" I am presented with the following screen....



warning: process set to nice value 0 instead of -10 as requested

This is a pre-release version of XFree86, and is not supported in any
way. Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org. Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository
(http://www.XFree86.Org/cvs)

XFree86 Version 4.1.0.1 / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: 21 December 2001
If the server is older than 6-12 months , or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/FAQ)
Build Operating System: Linux 2.6.9-ac6-ac6 i686 [ELF]
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Thu Mar 17 13:54:35 2005
(==) Using config file: "/etc/X11/Xf86Config-4"

<EXIT>

Upon entering "EXIT" the following screen occurs....

Would you like me to try to run the X
configuration program? Note that you will
need the root password for this.

<Yes> <No>



So there you go....please know that I am extremely new to linux...
I barely know how to do anything at all in it..thanks.
 
Old 03-17-2005, 01:59 PM   #2
soulstace
Member
 
Registered: Mar 2005
Location: USA
Distribution: Knoppix
Posts: 64

Rep: Reputation: 15
Did you go thru the X configuration program? I suggest trying that. It should set you up with a default config for the X window system.
 
Old 03-17-2005, 02:56 PM   #3
Circuit Monkey
LQ Newbie
 
Registered: Mar 2005
Distribution: knoppix installed on harddisk
Posts: 27

Original Poster
Rep: Reputation: 15
when I try to run the X Configuration program it crashes my system...power on my hd flickers off and system wont reboot with ctrl alt del....I'm loading knoppix now because I saw somewhere that people use that for troubleshooting their linux systems?...but I basically have no idea what to do...

Last edited by Circuit Monkey; 03-17-2005 at 03:21 PM.
 
Old 03-17-2005, 03:19 PM   #4
Circuit Monkey
LQ Newbie
 
Registered: Mar 2005
Distribution: knoppix installed on harddisk
Posts: 27

Original Poster
Rep: Reputation: 15
well, I've loaded knoppix and I'm looking at all the files in my hard drive...I guess I wanna find the X Configuration file and fix it?

???
 
Old 03-17-2005, 05:06 PM   #5
soulstace
Member
 
Registered: Mar 2005
Location: USA
Distribution: Knoppix
Posts: 64

Rep: Reputation: 15
A common problem indeed. Which is why I chose Fedora Linux because it is one of the very few that the X window system actually works with my display & graphics card. All the other distros I tried (besides knoppix) just gave me headaches...

According to your log, the file you want to edit is in

/etc/X11/Xf86Config-4

Fedora uses a slightly different filename

/etc/X11/xorg.conf

Last edited by soulstace; 03-17-2005 at 05:13 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
why wont Azureus run? JustinJS Fedora 2 06-15-2005 12:21 PM
postgresql-server wont run for obscure reasons... supersucker Linux - Software 7 03-29-2005 07:00 PM
Gnome wont run puke99 Red Hat 0 01-08-2005 11:18 PM
Trying to run photoshop in wine. Install, but wont run. bruno buys Linux - Software 14 07-15-2004 04:30 PM
xmess wont run madskillz Linux - Games 3 06-10-2004 02:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration