LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   X Server Configuration Question (https://www.linuxquestions.org/questions/linux-newbie-8/x-server-configuration-question-608920/)

Kharl 12-24-2007 02:15 PM

X Server Configuration Question
 
Greetings to all, and thanks for your time. : )

I have a mildly borked display that will flicker on and off, however, I managed to get it working in windows by changing the following values in the Nvidia Control Panel:

Code:


Horizontal Front Porch: 48
Vertical Front Porch: 3
Active Horizontal Pixels: 1600
Active Vertical Lines 1200
Horizontal Total: 1760
Vertical Total: 1235
Horizontal Sync Width: 32
Vertical Sync Width 4
Horizontal Sync Polarity: (-)
Vertical Sync Polarity: (+)
Horizontal Scan Rate: 74.10
Pixel Clock: 130.0041

A screencap of the config panel can be found here

The question is, then, how do I stick these values into the X config for this screen?

tommytomthms5 12-24-2007 09:42 PM

so are you dual booting windows and linux if so what flavor of linux?

Kharl 12-25-2007 01:39 PM

After further research, I managed to find the solution to this issue. I figure I might as well followup and document it, incase someone else runs into the same issue. For more background, the Distro I am using is Ubuntu 7.10, however, as it deals with the X server, it should work with most distros. The specific problem is with the Syncmaster 204B ( seems some of them are defective, they will flash on and off with off times of over 1 second ). Aswell, I am setting this up with another monitor using Nvidia's TwinView, so the settings are a bit more different than usual.

The solution to this is to change the moniter's timings to CVT-Reduced Blanking. ( Found in the thread: http://www.nvnews.net/vbulletin/show....php?t=82982#9

You can get the timing ( in this case for 1600x1200 ) by typing

Code:

cvt 1600 1200 60 -r
If your distro doesn't have this program, it can be found at http://www.uruk.org/~erich/projects/cvt/.

The output of which is placed under the "Moniter" section of the xorg.conf file, after a ModeLine. ( In my case, I'm using Nvidia's Twin view, which to me seems a bit odd as only one monitor is defined, but it seems that you keep this defined under the one monitor section. )

Code:

ModeLine "1600x1200_59.92_rb" 130.2 1600 1648 1680 1760 1200 1203 1207 1235 +hsync -vsync
Keep in mind, I believe this is monitor specific, so generate your own output using the cvt command.

Next, the mode should be put in a "Display" section, which seems to usually be a subsection of "Screen".

Code:

Modes "1600x1200_59.92_rb"
For me, this doesn't work as I'm using a TwinView implementation, which seems to define a single display with "metamodes". In my case, the code was defined under "Screen", NOT "Display", as such:

Code:

Option "metamodes" "CRT: nvidia-auto-select +0+0, DFP: 1600x1200_59.92_rb +1280+0"
It would seem that each monitor is labeled initially, followed by a colon, then the mode, offset, then seperated by a comma. I'm not entirely sure where the label is defined, however, I was able to find it in my nvidia-settings under display configuration, they were labelled CRT-1(Its not a CRT, but whatever floats the config's boat, I guess) and DFP-0.

Finally, so that the setting won't try and shift towards those in the monitor's EDID, under the section "Device", we need to put the following code to get it to use the exact timing instead of the EDID ones.

Code:

Option "ExactModeTimingsDVI" "yes"
Save it to your xorg.conf, reboot, and pray to whatever diety you worship.

Anyhow, sorry if that was a bit verbose, I just wanted to keep a record of the solution I found incase another poor sap runs into a similar issue. Merry Christmas to all of ya!


All times are GMT -5. The time now is 02:33 AM.