LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-17-2003, 02:57 AM   #1
KendersPlace
Member
 
Registered: Feb 2003
Location: Phoenix, AZ - USA
Distribution: RedHat 8, Micro$haft
Posts: 33

Rep: Reputation: 15
X is hanging.


Just downloaded and installed the newest ver of L from RedHat's site. Install goes just fine... however.... when I start X, the system pretty well freezes.

I run "startx" - I get the x pointer on a black screen, then eventually all I get is "xterm" and a terminal window on a black desktop.

After much clicking around on my black desktop (no bar at the bottom as expected) I get a light green colored drop down box when clicking and a narrow window at the top labled "TWM Icon Manager". I can make it longer or shorter, but can't figure out the right spell to cast on it to just let me into X. This is getting very frustrating. Have re-installed L about 5 times now, each w/ different options... still the exact same thing starting X.


When I exit out of the hung X (by killing the X process), I get this print out:

XFree86 Version 4.2.0 (Red Hat Linux release: 4.2.0-72) / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.18-11smp i686 [ELF]
Build Host: daffy.perf.redhat.com

Module Loader present
OS Kernel: Linux version 2.4.18-14 (bhcompile@stripples.devel.redhat.com) (gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)) #1 Wed Sep 4 13:35:50 EDT 2002
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Mon Feb 17 01:14:38 2003
(==) Using config file: "/etc/X11/XF86Config"
WARNING: You selected Fvwm2 as your window manager, but your installation
does not appear to be functional. The executable /usr/X11R6/bin/fvwm2 was
not found on your system.



Last edited by KendersPlace; 02-17-2003 at 04:01 AM.
 
Old 02-17-2003, 05:24 AM   #2
doublefailure
Member
 
Registered: Mar 2002
Location: ma
Distribution: slackware
Posts: 747

Rep: Reputation: 30
sorry for u..

i think best thing u can do is supply your hardwares
(graphic card/monitor..) with question..
and also do google.group search with the hardware and 'x' as keyword..
 
Old 02-17-2003, 05:25 AM   #3
membrax
Member
 
Registered: Nov 2002
Location: 50'48''N - 4'21''E
Distribution: SuSE7.1 - SuSE8.1 - SuSE8.2 - RH6.2 - RH7.1 - RH7.3 - RH8.0 - RH9.0 - Fedora Core 1
Posts: 281

Rep: Reputation: 30
Could you provide us a detailed list of your hardware (mainly your Gfx card) ?
 
Old 02-17-2003, 05:49 AM   #4
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
Don't you get a graphical login screen?

Try making sure that GNOME is installed - or install fvwm2, which is what it's looking for. What you're seeing is the failsafe mode.
 
Old 02-17-2003, 02:21 PM   #5
KendersPlace
Member
 
Registered: Feb 2003
Location: Phoenix, AZ - USA
Distribution: RedHat 8, Micro$haft
Posts: 33

Original Poster
Rep: Reputation: 15
I'm running a Riva TNT2 32MB card, which it finds when probing no problem. The graphical screens work fine during the install. The boot loader graphical screen displays properly. Also, if I run the config utility for X (where you set screen resolution and such), the example screen displays just fine. (Where it says "Can you see this message" with a count down. Everything including the desktop looks fine.

During setup I specified to install X but not Gnome. I'll re-install and allow it to install Gnome also this time.

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hanging at boot Risc91 Red Hat 4 01-16-2006 06:58 PM
Fedora 3 Keeps Hanging klayman17 Fedora - Installation 1 01-26-2005 09:20 PM
hanging on first run slim27616 Mandriva 1 11-22-2004 10:44 AM
kdict is hanging devinWhalen Linux - Software 2 03-29-2004 08:35 AM
X is hanging SLaCk_KiD Slackware 1 03-03-2003 04:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration