LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   X failing to start... (https://www.linuxquestions.org/questions/linux-newbie-8/x-failing-to-start-25842/)

Tayl 07-16-2002 12:53 AM

X failing to start...
 
I am new to Linux, just got it running today, am now running Red Hat 7.2 on a AMD K-6 233 MHz with 32 MB of RAM(an old system that I wanted to try Linux on). Anyways, I installed it fine, with Classic X Windows and X Windows, and the Gnome desktop environment. Now, being a total nOOb, I just assumed that X would be configured correctly. Well, I got an error when I typed in "StartX" so I configured it with xf86config. Now I get this error message when I try to run X:

------------------------------------------

Config Error: /usr/X11R6/lib/XF86Config: 48
subsection "extmod"

Module section keyword expected
giving up
xinit: Connection refused(errno 111):
unable to connect to X server
Xinit: no such process(errno 3):Server error
----------------------------------------------------

I am once again stumped. First question is how to fix this. Second, will it be possible to run Gnome on a slow system like mine? When I mean run, I really don't care how slow it is, I'm just going to play around on it, nothing serious.(Upgrading is not an option, the system is too old to even find the correct RAM...that would take too much effort). Also, I heard on another board of other, less strenuous desktop environments. I have NO idea how or where to look for them, so any help on that front would be appreciated. Man, this Linux stuff is hard....but it sure is fun! :D

j-ray 07-16-2002 01:32 AM

2. gnome should work on that hardware
1. did u try xconfigurator? comes with RH as far as i know.
maybe u find out what´s wrong in the config file/module section or post what´s in there.
cheers, jens

da Perp 07-16-2002 08:22 AM

do you people even look at the error messages and the files they complain about? where it says subsection ´extmod´ it´s supossed to say subsection modules or Module or something, to find this out Read The Nice Manual, follwed on the next line by i.e. ´extmod´..... rm your ALL XFree86cfg files, then create a new default one with ´XFree86 -configure´. after that find your new XF86config and test it by running ´XFree86 -xf86config /path/to/your/XF86config, if it doesnt work, then try recreating it with xf86config. good luck!

Peace out...

progster 07-16-2002 09:34 AM

da perp, that's a bit drastic. First check which config you are using (the default one (/etc/X11/XF86Config) or your own (most likely /home/yourhome/XF86Config), edit the one you use. Your "module" section should look something like this:
Code:

Section "Module"
    Load        "dbe"          # Double buffer extension
    SubSection  "extmod"
      Option    "omit xfree86-dga"  # don't initialise the DGA extension
    EndSubSection
    Load        "type1"
    Load        "freetype"
    Load        "glx"

EndSection

May vary from system to system though, if you don't use the nvidia driver for example you won't need the "load glx". Anyway you should check your extmod subsection ;-)

~Progster

Tayl 07-17-2002 01:39 PM

Ok, I got it working. I eventually had to remove all XF86Config files and run XFree86 -configure. After playing with the resolution and stuff, I got it working. Thanks all. Now, it's on to fixing my sound...;)

da Perp 07-19-2002 05:51 AM

A bit drastic, eh progster?

PEACE


All times are GMT -5. The time now is 04:56 PM.