LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-16-2012, 05:24 PM   #1
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 522

Rep: Reputation: 31
Writing accents with Suse


Hi!
I' m using Suse Enterprise Desktop 11 on a notebook HP 655. When I try to write accents on letters, I get the accents near the letters like this "'e" or "`e" instead having "" or "". I guess that I should change something in the control center->Keyboard->Layout. But I don't know what.

Thank you for any help.
 
Old 11-16-2012, 05:30 PM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Could you please post the output of
Code:
echo $LANG
Are you using X-window? and if yes, which Windowmanager? With KDE you can look into "System Settings" -> Keyboard-settings and also in the regional settings.

Markus
 
Old 11-17-2012, 12:19 AM   #3
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 522

Original Poster
Rep: Reputation: 31
Quote:
~> echo $LANG
de_DE.UTF-8
xpucto@linux-
I use GNOME. As Keyboard layout, I use Germany eliminate dead keys.

Xpucto
 
Old 11-17-2012, 02:37 AM   #4
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Well, you should not use "eliminate dead keys", because this puts the or ` directly onto the screen whereas "dead keys" means that the character is printed after the next button is pressed (e in your case). Try the simple german layout.

The $LANG should not be the problem.

Just tested here, with
Code:
setxkbmap -variant ""
you can check if it works (temporarily because this will be lost after rebooting). I'm no expert for Suse and Gnome as well, I don't therefore know if you have to change the settings for X or for Gnome.

Markus

Last edited by markush; 11-17-2012 at 02:41 AM.
 
1 members found this post helpful.
Old 11-17-2012, 03:09 AM   #5
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 522

Original Poster
Rep: Reputation: 31
Thank you for your answer! I did choose "Germany" (or "Germany dead acute grave", both work) and it worked. Only the "^" did not work with some program. Then I unchecked the option "Separate layout for each window" and it worked everywhere. Here the explanation about the "separate layout" option:
Quote:
By default, changing the keyboard layout affects the active window only. This means that if you change the layout and switch to another window, this window will use the old one, which might be confusing. To turn this behavior off, deselect the Separate layout for each window check box.
Thanks again.

Xpucto
 
Old 11-17-2012, 10:51 AM   #6
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 3,493

Rep: Reputation: 928Reputation: 928Reputation: 928Reputation: 928Reputation: 928Reputation: 928Reputation: 928Reputation: 928
Your best bet is to set a Compose key — the Windows Menu is a good choice. Then you can use sequences (pressed separately) like
Comp + apostrophe + "a" for ""
Comp + grave + "e" for ""
Comp + "^" + "o" for ""

Dead keys are a pain!
 
Old 11-19-2012, 01:08 AM   #7
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 522

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by DavidMcCann View Post
Your best bet is to set a Compose key the Windows Menu is a good choice. Then you can use sequences (pressed separately) like
Comp + apostrophe + "a" for ""
Comp + grave + "e" for ""
Comp + "^" + "o" for ""

Dead keys are a pain!
Thank you for the tip but how do I do this?

I also have the problem that every time I restart Linux, the "Germany eliminate dead keys" are automatically put back in the layout lists and then the accents don't work anymore until I delete that "Germany eliminate dead keys" again from the list. At the next new start of Linux this layout is back again...
 
Old 11-19-2012, 11:41 AM   #8
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 3,493

Rep: Reputation: 928Reputation: 928Reputation: 928Reputation: 928Reputation: 928Reputation: 928Reputation: 928Reputation: 928
Have a look at this:
http://userbase.kde.org/Tutorials/ComposeKey
 
Old 11-19-2012, 11:55 AM   #9
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Quote:
Originally Posted by xpucto View Post
Thank you for the tip but how do I do this?

I also have the problem that every time I restart Linux, the "Germany eliminate dead keys" are automatically put back in the layout lists and then the accents don't work anymore until I delete that "Germany eliminate dead keys" again from the list. At the next new start of Linux this layout is back again...
How did you change the settings? if you want to have it permanently you should edit the appropriate file in /etc/X11/xorg.conf.d/??-keyboard-layout or (when you login to your computer with a display manager (gdm I suppose) edit your ~/.xprofile and insert the settings there.

Markus
 
Old 11-21-2012, 12:43 AM   #10
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 522

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by DavidMcCann View Post
I looked at the information about persistent configuration but couldn't find any file like "/etc/X11/xinit/xinput.d/default"... probably because I use GNOME though...

I also couldn't find any
Quote:
/etc/X11/xorg.conf.d/
or any .xprofile file.

I made the changes using Control Center->Keyboard->Layout.
 
Old 11-21-2012, 12:46 AM   #11
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
You can create a file .xprofile in your homedirectory and put the settings you do with setxkbmap there in. the file .xprofile should be sourced when you login. But it's possible that some distributions handle these things different.

Markus
 
Old 11-21-2012, 11:23 AM   #12
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 3,493

Rep: Reputation: 928Reputation: 928Reputation: 928Reputation: 928Reputation: 928Reputation: 928Reputation: 928Reputation: 928
Quote:
Originally Posted by xpucto View Post
I looked at the information about persistent configuration but couldn't find any file like "/etc/X11/xinit/xinput.d/default"... probably because I use GNOME though...
I made the changes using Control Center->Keyboard->Layout.
Then you did it right! You might like to mark your original post as solved.

Sorry I didn't notice you were using Gnome. There's almost always a configuration tool in the menu with a desktop like KDE or Gnome, and it's best to use them rather than messing around in files as recommended by old-school users (who have the advantage of understanding them!)
 
Old 11-21-2012, 04:20 PM   #13
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 522

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by DavidMcCann View Post
Then you did it right! You might like to mark your original post as solved.

Sorry I didn't notice you were using Gnome. There's almost always a configuration tool in the menu with a desktop like KDE or Gnome, and it's best to use them rather than messing around in files as recommended by old-school users (who have the advantage of understanding them!)
Well, that's actually the problem I have described: I've used Control Center->Keyboard->Layout but every time I restart the computer I have the old configuration back again and every time I have to delete the "Germany Eliminate Dead Keys" layout. So it is no solved...

Last edited by xpucto; 11-21-2012 at 04:24 PM.
 
Old 11-21-2012, 04:24 PM   #14
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
My description refers to people who have no root-access to their computer and have therefore to do the settings on user-level. It should work for most distributions (but it is correct what DavidMcCann wrote, prefer the tools of your distribution if they work).

Markus
 
Old 11-22-2012, 04:06 PM   #15
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 522

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by markush View Post
My description refers to people who have no root-access to their computer and have therefore to do the settings on user-level. It should work for most distributions (but it is correct what DavidMcCann wrote, prefer the tools of your distribution if they work).

Markus
Well, as I said : my tool doesn't work since the result vanishes every time I restart the computer. I haven't understood what I should exactly put in my xprofile file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
English with accents. stf92 General 17 07-09-2011 10:53 AM
accents in the shell ccee Linux - Newbie 1 02-11-2010 11:47 AM
setxkbmap no accents bobbens Linux - Software 0 03-17-2005 12:17 PM
Keyboard and accents... djib Mandriva 2 09-15-2004 12:07 PM
problems with accents and s J0sep Red Hat 7 08-17-2004 04:05 PM


All times are GMT -5. The time now is 09:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration