LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-11-2004, 06:05 AM   #1
kurt_angle
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Rep: Reputation: 0
Write to Fat32


I just mounted my Windows partition, i can read and copy files FROM that partition, however i couldn't WRITE to that partition.

My Windows partition is using FAT32 and i should be able to write.

is it because my way of mounting is incorrect?

I right-clicked that the mounted patition and got rid of the "read only" option, but still i can't write.

Are there any solutions to this, or are there methods to access the linux partition from Windows?

I'm currently on RH9 and WinXP.

Thanks.
 
Old 04-11-2004, 06:34 AM   #2
melinda_sayang
Member
 
Registered: Dec 2003
Location: Petaling Jaya
Distribution: Ubuntu
Posts: 475

Rep: Reputation: 31
/dev/hda5 /mnt/data vfat noauto,users,rw,umask=022 0 0

Add this line to /etc/fstab. /dev/hda5 is my windows partition. yours maybe different.
 
Old 04-11-2004, 01:01 PM   #3
Hammett
Senior Member
 
Registered: Aug 2003
Location: Barcelona, Catalunya
Distribution: Gentoo
Posts: 1,042

Rep: Reputation: 54
Adding to above, try also chown on your /mnt/windows directory if above does not the trick
 
Old 04-11-2004, 02:04 PM   #4
davec
LQ Newbie
 
Registered: Apr 2004
Location: Dublin, Ireland
Distribution: fedora core 1, redhat 9.0, slackware 9.0
Posts: 22

Rep: Reputation: 15
problem is that xp uses NTFS, and linux does not write to NTFS! it can deal with fat32 well enough tho, maybe you should change over to win2k, then you have full write capabilities.... be careful tho, don't modify any win system files under linux, or you'll bugger up windows(some might say thats a good thing!!!)
 
Old 04-11-2004, 02:07 PM   #5
Hammett
Senior Member
 
Registered: Aug 2003
Location: Barcelona, Catalunya
Distribution: Gentoo
Posts: 1,042

Rep: Reputation: 54
You can change filesystem to fat32 without any data loss with partition magic.
 
Old 04-11-2004, 06:53 PM   #6
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Before using Partition Magic or parted, back up.
 
Old 04-12-2004, 03:30 AM   #7
kurt_angle
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Original Poster
Rep: Reputation: 0
Smile

thanks guys ! it worked..thanks for all your help !!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Write to FAT32 Partition ok? ziphem Linux - Newbie 8 01-25-2005 07:39 PM
Write to FAT32 cause error! welson_sun Linux - Software 5 09-07-2004 03:41 PM
Getting write access to FAT32 wgself Red Hat 1 01-16-2004 09:48 AM
FAT32 write class_struggle Linux - Newbie 3 11-26-2003 08:20 AM
it's fat32 why cant I write to it? ampex189 Linux - Newbie 2 10-12-2003 02:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration