LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   write permissions in /etc/fstab for vfat filesystem (https://www.linuxquestions.org/questions/linux-newbie-8/write-permissions-in-etc-fstab-for-vfat-filesystem-376215/)

btb 10-23-2005 11:00 PM

write permissions in /etc/fstab for vfat filesystem
 
Hi all, First, I am running FC4. I've added this line to my /etc/fstab file to mount my vfat partition:

Code:

/dev/hda5    /fatsys        vfat    auto,user,rw,sync,exec,uid=500,gid=500    0 0
unfortunately, this does not allow me to write to fatsys when I'm not logged in as root. I've tried different configurations of the options, as well as trying to change the permissions as root by chmod. It does not allow non root users to have write permissions. Any tips?

Thanks!

freakyg 10-23-2005 11:10 PM

Re: write permissions in /etc/fstab for vfat filesystem
 
Code:

/dev/hda5    /fatsys    vfat    owner,users,rw    0 0
try that.......

btb 10-23-2005 11:14 PM

That doesn't work either unfortunately. Even when I try to change the permissions in the filebrowser as root, it just doesn't click the write box for other and group permissions.

update: I've also tried putting the permissions in the options:
auto,user,rw,sync,noexec,uid=500,gid=500,mode=777

No luck! :(

btb 10-24-2005 12:22 AM

I can't even add write permissions for individual files in the fatsys. Also I tried a restart, and with the configuration of options I have above, fatsys does not mount automatically at boot time, although I have "auto." I tried it with "defaults" and it was able to mount automatically at boot time. But still the write permissions problem persists.

Any ideas would be appreciated!

michaelk 10-24-2005 07:31 AM

To allow read / write for all users

/dev/hda5 /fatsys vfat users,umask=000 0 0

A FAT32 filesystem does not have any permissions.

btb 10-24-2005 02:37 PM

I added the umask and it works fine. thank you! here is the complete setup:

auto,rw,user,sync,exec,dev,suid,uid=500,gid=500,umask=000


All times are GMT -5. The time now is 07:24 PM.