LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Wireless not working (https://www.linuxquestions.org/questions/linux-newbie-8/wireless-not-working-681340/)

luvthepenguin 11-05-2008 01:13 PM

Wireless not working
 
The network manager in upper right does show available wireless networks but selecting them does not seem to work. When I do ifconfig, wlan0 does not show an IP address. The hardware should work because it worked fine until I tried to switch from my work wireless to my home wireless.

when I try a command like:
$ iwconfig wlan0 ap any

I get this as a response:
Error for wireless request "Set AP Address" (8B14) :
SET failed on device wlan0 ; Operation not permitted.

I also get a permissions error when I try ifup
$ ifup wlan0
ifup: failed to open statefile /var/run/network/ifstate: Permission denied

I am the admin on my computer so not sure the reason for these errors. I am on Ubuntu 7.10. How can I get my machine to recognize the wireless networks, manually or otherwise? Thanks so much for your help!!

zakonnik 11-05-2008 02:46 PM

Not sure what you've got in mind but try 9as root):
Code:

iwconfig wlan0 up
iwlist wlan0 s


luvthepenguin 11-05-2008 06:17 PM

thank you zakonnik, I got it to work by editing the /etc/network/interfaces file... would you or someone else be able to point me to a resource to install a wireless card (for a different computer)? I downloaded the driver but not sure where to put the files and to get it working. The resources I found on the web so far don't walk me through command by command.


All times are GMT -5. The time now is 03:15 AM.